Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

AFD missing, no internet


  • Please log in to reply
1 reply to this topic

#1 Codeplayer

Codeplayer

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Tallinn, Estonia
  • Local time:08:38 AM

Posted 20 November 2012 - 03:15 AM

Hi!

I have no internet access on my Win 7 Home Premium
There is never ending identifying... displayed at the Network and Sharing Center for both, Wifi and LAN.

I discovered, that the DHCP service would not start with the error:
Error:  Could not start the DHCP Client Service on local computer
Error 1068: The dependency service or group failed to start.

The DHCP Service won't run seemingly because there is no AFD either in the services or through device manager.
Also, the HTTP in Device manager has an exclamation mark.

I have fought with a DNS-Hijacker for some time now.

I always ended up with Combofix from Bleeping Computer and then the problem was then solved for some months. It went on as okay for couple of times and now the last time when the DNS-problems started, I ran Combofix again, but now I had AVG 2013 and I was late with turning it off. I don't know, if that was the reason. Anyway, everything worked great after restart. About other probable causes, I was trying to connect my ex-windows-mobile-now-with-Android-htc-Touch-Cruise with my PC and to get it to install the ADB-drivers. I deleted some htc-related drivers (which ones, I don't recall). Next day when I came to work, I noticed that my computer had restarted and the issue was there. It started happening on 16th of november 2012.

What I have done so far:

Tried to see if any recent Windows Update had broken my networking, The Windows update history window comes up blank.
Tried reinstalling LAN drivers, created somehow the first & only system restore point
Tried running Combofix again, broke startup, restored system to 16.11.2011 5AM
Tried trouleshoot Router/switch/cable/ problems, other WXP/W7 computers work fine with that cable, also on different networks, both LAN and Wifi at home and at work, tested simultaneously with different new systems to the network (XP, W7).
Tried installing new Windows 7 on another blank HDD to exlude PC-s hardware problems- On new clean installation, everything works
Tried reseting Winsock by "netsh winsock reset all"
Tried setting static IPv4-addresses manually with google DNS, that gave me first results,
I pinged sucessfully any IP, but no Dynamic host names. I tried entering IP-addresses directly to browser, but with no luck.
I then noticed that my security center service was not present and running, I repaired that with some registry fix and restart.
Then I noticed viewing the Event log, that the DHCP service not running and that I have no AFD in my Device manager nor Services.
I have afd.sys file.

I uploaded all relevant scan logs, that I have done by trying to troubleshoot the issue, here:

https://www.dropbox.com/sh/6hzqk4qa1fevg8g/McYS68A4cv

Please help :)

Edited by Codeplayer, 20 November 2012 - 03:42 AM.


BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 55,405 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:12:38 AM

Posted 20 November 2012 - 06:45 AM

Please...initiate a topic in the appropriate malware forum by following the instructions at Preparation Guide, Before Using Malware Removal Tools and Requesting Help - http://www.bleepingcomputer.com/forums/topic34773.html .

I emphasize that you submit the requested logs only...and that you do so by pasting them into your post...do not submit attachments or upload files to another website.

<<Tried running Combofix again...>>

You may also include your ComboFix log detail as part of the content you submit in your new topic in the Malware Removal Logs forum.

Thanks for understanding :).

Louis




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users