Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

"Boot critical file is corrupt", Laptop no longer boots to Vista after being dropped


  • Please log in to reply
4 replies to this topic

#1 wpodwyso

wpodwyso

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:02:32 PM

Posted 08 November 2012 - 08:48 AM

Patient is a Dell Inspiron 1720 laptop. After dropping the laptop it will no longer boot to Windows Vista.

I get a "Windows failed to start. A recent hardware or software change might be the case", with the option to launch Startup Repair. Startup Repair runs but fails to repair, "If you have recently attached a device, remove it and restart". All that I have plugged in to the laptop is an ethernet cable at this point. I get the following:

Root cause found:
bugcheck c000021a. parameters =
0x81603f00,
0xc0000006,
0x75776000,
0xd9f6e4.
boot critical file is corrupt.
repair action: file repair. result: failed. error code = 0x2
repair action: system files integrity check and repair. result: failed. error code= 0x79


After getting into Safe Mode for the first time, a window pops up with the following:

Problem Details:
Problem Event Name: Blue Screen
OS version: 6.0.6002.2.2.0.768.3
Locale ID: 1033
additional info:
BCCode: c000021a
BCP1: 8c9d42c8
BCP2: c0000005
BCP3: 75a61292
BCP4: 00daf43c
OS version: 6_0_6002
Service pack: 2_0
Product: 768_1

Then I get an automatic restart after problems were detected.


Upon my next successful Safe Mode attempt, I attempt to run each of the items in my StartUp folder individually, and get no errors. I then run Event Viewer.

I get one error in the Application category:
(Source / Event ID / Task Category)

Event System / 4609 / Event System
Properties: "The COM+ Event System detected a bad return code during its internal processing. HRESULT was 8007043c from line 45 of d:\longhorn\com\complus\src\events\tier1\eventsystemobj.cpp. Please contact MS product support services to report the error."

I get numerous errors in the System category. Most are DCOM and Service Control Manager Eventlog Provider errors, which I can detail if requested, but the most serious looking errors are the following:
(Source / Event ID / Task Category)

Ntfs / 55 / (2)
Properties: "The file system structure on the disk is corrupt and unusable. Please run the chkdsk utility on the volume c:."
Binary data:
In words:
0000: 000c000d 00380002 00000002 c0040037
0008: 00000000 c0000032 00000000 00000000
0010: 00000000 00000000 00120872 ffffffff
0018: ffffffff

Ntfs / 55 / (2)
Properties: "The file system structure on the disk is corrupt and unusable. Please run the chkdsk utility on the volume OS."

Service Control Manager Eventlog Provider / 7026 / None
Properties: "The following boot-start or system-start drivers failed to load:
AFD, DfsC, mfehidk, mfenlfk, mfewfpk, NetBIOS, netbt, nsiproxy, PSched, RasAcd, rdbss, Smb, spldr, tdx, Wanarpv6.


I've tried running "sfc /scannow" from the command prompt two times. Both times it has stalled at 37% indefinitely.

I've tried a "chkdsk c: /f /r" from a Vista dvd, and it ran, and ran, and ran. For about 14 hours it removed bad sectors. Afterwords it did boot up to Vista, but bluescreened after sitting for a while.

Any suggestions? How likely is it that replacing the hdd will fix the issue?

Edited by hamluis, 08 November 2012 - 10:50 AM.
Moved from Vista to Internal Hardware - Hamluis.


BC AdBot (Login to Remove)

 


#2 jhayz

jhayz

  • BC Advisor
  • 6,922 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:32 AM

Posted 09 November 2012 - 02:03 AM

How about running a [Linux] Live Windows disc first for assurance? About https://en.wikipedia.org/wiki/Live_CD However, based on your post, the drive seems to be shut.

Tekken
 


#3 AustrAlien

AustrAlien

    Inquisitor


  • Members
  • 6,772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cowra NSW Australia
  • Local time:05:32 AM

Posted 09 November 2012 - 04:49 AM

Let's have a look at the hard drive's S.M.A.R.T. data to see if it has sustained impact damage, and if so, the extent of damage.

On a working computer, please download the latest version of PartedMagic:
Write (in the appropriate manner) the downloaded .iso file to either CD or USB/flashdrive:
Boot the problematic computer from the PartedMagic CD or flashdrive:
  • At the first menu with Default settings (Runs from RAM) selected, press <ENTER>.
    Be patient while PartedMagic loads into memory, and then displays its Desktop.
Success? Let me know if you can successfully boot to the Desktop of PartedMagic, and whether you are using a bootable CD or a flashdrive.

Posted Image
The Desktop of PartedMagic (version 2012-08-09)

At the PartedMagic Desktop:
  • Double-click the Disk Health icon on the Desktop.
  • In the GSmartControl window that opens, double-click on the device that represents the hard drive.
  • In the Device Information window that opens, click View Output.
    A Smartctl Output window will open.
  • Right-click in the text output > Select All.
  • Right-click in the selected area > Copy.
In the next step you will paste this text into your topic reply.
At the PartedMagic Desktop:
  • Double-click on the Firefox icon to open the Firefox browser window.
  • Enter the BC forums address www.bleepingcomputer.com/forums in the address box and press <ENTER>.
  • Sign in to the forums and locate your topic.
  • Paste the text from the Smartctl Output window in a reply to your topic.

    Note: Please enclose the pasted report in CODE tags so that the spacing/formatting is preserved.
  • Firstly, click on the "Insert code snippet" button Posted Image
  • You will then see the "start" and "end" code tags (highlighted in dark blue/selected in the image) in the text box.
  • Click between the two tags to insert the cursor between the tags and then press <Ctrl+V> to paste the report there.

Edited by AustrAlien, 09 November 2012 - 06:07 AM.

AustrAlien
Google is my friend. Make Google your friend too.

Posted Image

#4 wpodwyso

wpodwyso
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:02:32 PM

Posted 09 November 2012 - 07:59 PM

I'm using a bootable CD. I can get to the first menu. However, I get an error while trying to load to RAM:

Copying files to RAM...........................
cp: read error: Input/output error


Mounting PMAGIC_2012_10_10.SQFS... mount: wrong fs type, bad option, bad superblock on /dev/loop1,
In some cases useful info is found in syslog - try
dmesg | tail or so


Mounting //ssfs_disk/PMAGIC_2012_10_10.SQFS failed.


It leaves me at a command prompt. I should note that I have zero experience with Linux so I will need handholding with any troubleshooting commands.

#5 AustrAlien

AustrAlien

    Inquisitor


  • Members
  • 6,772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cowra NSW Australia
  • Local time:05:32 AM

Posted 10 November 2012 - 04:03 AM

Sorry about the delay getting back to you. I've seen that issue with PartedMagic before, but I haven't had much time today to figure out what it's all about and how to get around it yet.

A DELL Inspiron laptop will have the facility to boot to the DELL Diagnostics and be able to test the hard drive (along with other things). The DELL diagnostics are known to be generally reliable.

Pre-Boot System Assessment (PSA) Diagnostics and Error Codes For Dell Computers
AustrAlien
Google is my friend. Make Google your friend too.

Posted Image




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users