Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows 7 cannot connect to server


  • Please log in to reply
11 replies to this topic

#1 Shandley

Shandley

  • Members
  • 166 posts
  • OFFLINE
  •  
  • Local time:07:13 AM

Posted 01 November 2012 - 10:34 AM

Greetings,

I have a small network. I have one small server running Windows 2000 Pro SP4 (yeah, I know but it works very well otherwise). I have multiple computers I use to access the Windows 2000 Pro server with multiple Windows operating systems including XP Home, XP Pro, Vista Home, and even a windows 98 machine (don't ask).

Everything was working great except the Windows 7 machine (of course). In fact, the windows 7 machine was working fine until yesterday.

When I double click on my mapped network drive, it asks me for a Network username and password and says:

Enter Network Password

Enter Your Password to connect to: Server (name of the server is Server)
LAPTOP\Jerry (Laptop is the name of the computer and Jerry is the username. Everything is case insensitive but I entered it case sensitive anyways).
<Password Field Here>
<checkbox> Remember my credentials
Logon failure: unknown user name or bad password.

I hear this is very common. I have user names and passwords set up in the Windows 2000 Pro server which match the Windows log in Username and password. This is true for all users across the network and everything works great (if I remove a user, they can no longer access the server).

I have tried:
Disabling the HomeGroup
Setting the advanced share settings to on or off depending on the options (as free and least secure I can get).
Disabling Firewalls (on both ends).
Guest Account on the Windows 7 Machine is off.
Added new user with same credentials as a known working user/password to the Windows 7 machine and tried to access the server with the same results.

Please note: I have NOT changed a thing on the Server end of things. I am not the user of the Windows 7 machine so i am unsure what exactly happened; however, I am told (and I believe) that the user did nothing to provoke this). The user account is still active. I can access the server on a different machine using his log in.

The windows 7 machine can see other computers in the network and view their files.


Any ideas?

Edited by Shandley, 01 November 2012 - 10:47 AM.


BC AdBot (Login to Remove)

 


#2 Shandley

Shandley
  • Topic Starter

  • Members
  • 166 posts
  • OFFLINE
  •  
  • Local time:07:13 AM

Posted 01 November 2012 - 12:20 PM

Solved (at least for me)!

Windows sent out an update removing a level of security check. None the less, here is the solution that worked for me.

In Windows 7, click Start (or tap the windows button).
Type regedit and hit Enter.
Open the following path: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
If it does not already exist, create a DWORD value and call it LmCompatibilityLevel
Set the value to 1
Reboot

Edited by Shandley, 01 November 2012 - 12:20 PM.


#3 computerxpds

computerxpds

    Bleepin' Comp


  • Moderator
  • 4,488 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:11:13 AM

Posted 01 November 2012 - 12:24 PM

Hello,

Glad you solved it, and Thank you for posting that you solved it and the info to help future users fix it. :)
sigcomp.png 
If I have replied to a topic and you reply and I haven't gotten back to you within 48 hours (2 days) then send me a P.M.
Some important links: BC Forum Rules | Misplaced Malware Logs | BC Tutorials | BC Downloads |
Follow BleepingComputer on: Facebook! | Twitter! | Google+| Come join us on the BleepingComputer Live Chat on Discord too! |

#4 shainski

shainski

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:10:13 AM

Posted 29 March 2013 - 12:09 PM

Thank you Shandley.

 

Your solution worked on one of my computers, but not the other.  Inexplicably, two work computers could not connect to the server.  One was Windows7 and the other Windows8.  They both had been able to connect the previous day (and another Windows7 computer did not have this problem).

 

I used your regedit solution and the Windows7 computer now has no connection issues.  It did not work on the Windows8.  If i find a solution, i will post it here in case anyone else comes across this thread for research.



#5 shainski

shainski

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:10:13 AM

Posted 29 March 2013 - 12:35 PM

I did find a solution for my Windows8 PC:

 

here it is

 

(it comes from the following link:http://answers.microsoft.com/en-us/windows/forum/windows_7-networking/windows-7-asks-enter-network-password-when/2a8e6d6f-74a1-43c7-8530-24e8522ea955?page=8&tm=1364578338788

 

Did some searches on the net and below is what i did to solve the problem that was occuring

Permitting Network Access Without a Password

To allow users to log onto their computers without a password and then access the XP Professional machine without a password, you must make a security policy change:

 

  1. Go to Control Panel | Performance and Maintenance | Administrative Tools | Local Security Policy.
  2. Expand Local Policies | Security Options.
  3. Double-click Accounts: Limit local account use of blank passwords to console login only, which is enabled by default. Disable this option and click OK.

this stopped the network access dialog box appearing when tryin to access my xp machine from windows 7 ! !



#6 hedera

hedera

  • Members
  • 91 posts
  • OFFLINE
  •  
  • Local time:08:13 AM

Posted 30 March 2013 - 04:42 PM

I've been fighting this exact problem daily for 3 weeks, or ever since I bought a new ThinkPad from Lenovo.  I have 2 Win7 Pro 64-bit systems, the ThinkPad and an HP Pavilion desktop.  I never had the problem with my old laptop, a Dell running Win7 Ultimate 64-bit which I rebuilt myself. I synchronize a list of folders between the two systems (using GoodSync) so I can work on ether box.

 

Believe me, I have all the standard permissions set.  But I shut down all my computers every night, and every morning when I bring them up, I have to rename the desktop and reboot it at least once, sometimes twice, in order to get access to fully shared folders on the ThinkPad.  I have just implemented shainski's solution on the ThinkPad and will report here if it fixes it.  If it doesn't work I'll give Shandley's solution a try.



#7 hedera

hedera

  • Members
  • 91 posts
  • OFFLINE
  •  
  • Local time:08:13 AM

Posted 30 March 2013 - 05:06 PM

As I thought about it again, I realized that Shandley's solution, to add the registry key, more closely matched my situation of 2 Win7 computers talking.  I added the registry key to the ThinkPad and rebooted. Then I cold booted the HP desktop.  When I brought it up I could connect straight through.  Thank you, thank you, thank you, I was going crazy!



#8 kashif27

kashif27

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:08:13 PM

Posted 05 April 2013 - 08:41 AM

Thanks A Lot . Worked for me too :bananas:

 

Solved (at least for me)!

Windows sent out an update removing a level of security check. None the less, here is the solution that worked for me.

In Windows 7, click Start (or tap the windows button).
Type regedit and hit Enter.
Open the following path: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
If it does not already exist, create a DWORD value and call it LmCompatibilityLevel
Set the value to 1
Reboot

 



#9 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,123 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:11:13 AM

Posted 08 April 2013 - 04:14 PM

Thank you all for posting your solutions Its great addition to my knowledge base. :thumbup2: 

 

Please use caution when editing the registry  Make backups using Erunt Or Windows system restore point. A minor edit in the wrong spot or typo can leave the system unbootable. 


Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +

#10 hedera

hedera

  • Members
  • 91 posts
  • OFFLINE
  •  
  • Local time:08:13 AM

Posted 11 December 2013 - 12:23 AM

Actually, Shandley's solution really didn't work for more than a day or two.  My connectivity problem was eventually solved the hard way - the hard drive on my desktop died.  The local computer shop installed a new, faster,bigger drive with Win7 Pro 64 bit, and although I had to do a few reboot-and-renames, after about 2 weeks I was able to connect directly after every cold boot.  Must have been a corrupted area on the dying drive.



#11 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,123 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:11:13 AM

Posted 11 December 2013 - 01:59 AM

That is definatly a possibility 


Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +

#12 technonymous

technonymous

  • Members
  • 2,499 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:13 AM

Posted 13 December 2013 - 12:45 AM

That setting works and is a quick fix, but remember that LM is a lower security protocol. The server should be updated to service pack 4 if it isn't already. Then you can change that setting to 3 or higher and push NTLMv2 that uses 128bit encryption. Just saying. :)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users