Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Keyboard only works in Safe mode or bios


  • Please log in to reply
1 reply to this topic

#1 damastaglen

damastaglen

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:10:12 AM

Posted 17 October 2012 - 03:00 PM

Hi

I have the most strange issue with my keyboard. It works in Bios, it works in safe mode, it works when I try to repair windows (repair files are added to a partition on the laptop - its how I bought it) but whenever windows boots normally, the keyboard won't work.

It is a built in keyboard to my laptop and the fact it works everywhere else tells me it's fine (just in case connectors were damaged I stripped it and had a look anyway).

Things I have tried
1) uninstalling the driver in safe mode - this reinstalls when I reboot but still no joy. The strange part is I do not think the driver files are corrupted because safe mode and normal mode seems to use the same drivers (standard ps2).
2) The manufacturer (HP Compaq) has no specific drivers which leads me to believe that standard ps2 is right but I reinstalled quick buttons -no joy
3) there are no conflicts or yellow exclamation point in device manager
4) the only thing I did was upgrade my AV (AVG 2013) so uninstalled -no joy.
5) ran AV and MBAM and ran TDSS killer just in case - no virus or malware
6) cleaned registry with Ccleaner -no joy
7) no processes or startup items are unusual but I have killed /disabled just in case-no joy
8) did a system restore (no joy)
9) I had backed up the registry ages ago so I tried that -no joy
10) Tried on battery and plugged in no battery in case the power is an issue -no joy
11) reflashed Bios - no joy
12 - All language sttings looked ok

A USB keyboard works if plugged in

Just in case I did run hijack this too

Please help before I throw it out the window!!!!!!!!

Thanks in advance

Edited by damastaglen, 17 October 2012 - 03:02 PM.


BC AdBot (Login to Remove)

 


#2 damastaglen

damastaglen
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:10:12 AM

Posted 17 October 2012 - 03:03 PM

if it helps it is a Compaq Presario CQ56 253SA with 64 bit win 7




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users