Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Trouble reformatting external hard drive


  • Please log in to reply
2 replies to this topic

#1 Aletheia

Aletheia

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:07:13 AM

Posted 14 October 2012 - 09:31 PM

I have a WD 500gb portable hard drive (My Passport series) that I bought about a year and a half ago. It's served me pretty well for the most part, but this past week I started getting cyclic redundancy errors when I tried to download to it. This was only happening for some downloads and not others, so after a little googling, I figured that I probably had some bad sectors and I would need to reformat it. So last night, I backed up the important stuff and started a full format. I should probably mention that I'm using Windows 7, but on an older laptop that doesn't really do anything fast.

I left it for a couple of hours last night, but it wasn't really moving and I thought it might have frozen, since like I said, my laptop is pretty slow. I canceled the format, pulled out the drive and reconnected it, and tried again, leaving it overnight this time. I kept an eye on the bar for a bit before bed, and it moved up to maybe around 5% (no actual percentage shown) in the first hour or two, so I left it on and went to sleep. When I checked it this afternoon (12+ hours later), it had barely gone up overnight, if at all. So I cancelled, disconnected, and retried.

That was about 5 hours ago. Once again, it moved up to around 5% in the first couple of hours, but as far as I can tell, it hasn't moved at all since then. Am I being impatient? Did I screw things up by stopping the format before? Should I just break down and buy a new external, or is there any way I can salvage this one?

Any help or advice would be appreciated!

Edit for specs: Laptop is Sony Vaio, model # PCG7L1L. Can't find an exact model number on the drive, but it's an older model WD Passport, 500gb, USB 2.

Edited by Aletheia, 14 October 2012 - 10:12 PM.


BC AdBot (Login to Remove)

 


#2 Platypus

Platypus

  • Moderator
  • 14,689 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Australia
  • Local time:09:13 PM

Posted 15 October 2012 - 12:15 AM

My feeling always in these situation is that it just isn't worth it. You could try the Data LifeGuard tools from Western Digital support, and a zero-fill may be successful. But once a drive has started throwing CRC errors, it isn't going to get any better, and that means you can't trust the drive to remain reliable in the future.

Top 5 things that never get done:

1.


#3 Aletheia

Aletheia
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:07:13 AM

Posted 15 October 2012 - 12:34 AM

Thanks. I think I'm going to try the zero-fill for now, but I'll start shopping around for a new drive. I've been wanting more space anyway. Oh my poor wallet...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users