Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Modify time limit to logon to Windows RDP session


  • Please log in to reply
1 reply to this topic

#1 bluesteel72

bluesteel72

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:05:45 AM

Posted 08 October 2012 - 04:12 PM

When I connect to a remote Windows server using Windows native RDP/Remote Desktop Connection from my WinXP PC, I've got about 30 seconds to select a logon account and/or type in the password. We've recently introduced two-factor authentication for OS logon. In some cases where the remote server is slow, or there's a network lag because the server is on the other side of the globe, that 30 seconds isn't long enough for the remote server to read/interpret the cert on my smartcard and give me the opportunity to enter my smartcard password. At times, the screen just begins to give me the password field, and then it times out and ends the session. Is there some setting (either on my PC or on the remote servers) that can be changed to allow a longer period of time to enter logon credentials? Like, increase it to 45 seconds before timeout? I've been unsuccessful in finding anything online about how to extend this setting. I've looked at the Local Computer policy settings on my PC to see if any GPO's are setting that 30-second timeout -- nothing seems to be coming down from GP that I can see. I did go to Local Computer Policy > User Configuration > Administrative Templates > Terminal Services > Sessions and changed "Sets a time limit for active but idle TS sessions" from 'Not configured' to 'Disabled', but that made no difference. The idle session timeout configuration on all our remote servers it set a value much higher than 30 seconds, so I don't see that as the issue. I've looked at the Remote Desktop Connection options on my PC, but there's nothing there to help me. I would assume there's some place in the registry where this can be changed, but I've had no luck finding the right key.

If anyone knows how I can do this, please post the answer.

Thanks!

BC AdBot (Login to Remove)

 


#2 Firefoxthebomb

Firefoxthebomb

  • Members
  • 457 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA -- Texas
  • Local time:05:45 AM

Posted 09 October 2012 - 09:59 AM

See if this is helpful....

To Set Timeout Options for Remote Desktop Connections

1.From your computer's Start menu, point to Programs, point to Admin Tools, and then click Terminal Services Configuration.
2.In the right pane of the window, click RDP-Tcp.
3.Click the Sessions tab.
4.Specify the values you want to use.

firefoxsig-resized.jpg.b57936275b99d45f7

Dell Precision T7810, Win10 64bit fully updated, Symantec Endpoint Protection,
Watchguard Firewall, Intel Xeon E5-2620v4 CPUs, Dual 8 Core Processors, 32GB Ram,
E5-2620v4 @ 2.10GHz X 2, AMD FirePro W4100 with 4 Screens, 500GB SSD Boot Drive,
Raid-1 Dual 2TB Sata 10000 rpm Hard Drives, DVD Burner, IE11, Opera, MBAM, MBSB, MBAE





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users