Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Can't connect to the internet


  • Please log in to reply
5 replies to this topic

#1 sdbuilt

sdbuilt

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:08:13 PM

Posted 28 September 2012 - 07:33 PM

Hello, I am not sure what is going on but I cannot connect to the Internet and Windows Network Diagnostics says that the DNS sever is not responding. I have it set to obtain an IP address and a DNS server automatically... Still doesn't work.

If you want me to tell you what ipconfig/all says please tell me exactly what you are looking for because I actually have no way of getting a file from my computer onto my phone right now. However the default gateway, dhcp, and DNS are all 192.168.2.1 while the ipv4 is 192.168.2.2 <preferred>. Also keep in mind that none of my devices can connect to the Internet and I edited my original post to give a little more context..

Also, this happened when I had an iPad in transferring music, and I unplugged my Internet wireless adapter and plugged it into a different USB port, or at least I think that is when it happened. At any rate I got a message saying something about an IP address conflict which I did not pay much attention to.

One other detail is that it is not just my computer that can't connect. My iPhone and my friends iPad that I had plugged in so I could transfer music from my iTunes to his iPad cannot connect either..


Thanks for your help!

BC AdBot (Login to Remove)

 


#2 jhayz

jhayz

  • BC Advisor
  • 6,922 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:13 PM

Posted 28 September 2012 - 07:51 PM

What type and brand/model of computer, router is involved in your network problem? Have you tried reinstalling the WLAN adapter or resetting to factory defaults the router since it is configured in DHCP or auto IP address?

Tekken
 


#3 evti

evti

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Local time:02:13 PM

Posted 28 September 2012 - 09:56 PM

If it has to do with the IP address conflict, you can assign static IP addresses in your router to eliminate this problem. Things like that can do strange things to routers, so it's possible that it's related. Also try power cycling the router and modem, as well as restarting the computer. You can also try connecting to Google's public DNSes and see if that helps at all.

#4 sdbuilt

sdbuilt
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:08:13 PM

Posted 28 September 2012 - 10:02 PM

I have a belkin router and a windows 7 pc. I did try to reset the router to factory defaults. I also shut the router and modem off and also tried restarting my computer. I even restored my computer to yesterday's settings..

How do I assign static ip addresses? Also how do I connect to googles public DNS? Is that a good long term solution that will work for every iPhone or iPad that walks into my house and tried to connect to my wireless network?

#5 evti

evti

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Local time:02:13 PM

Posted 29 September 2012 - 07:08 PM

I have a belkin router and a windows 7 pc. I did try to reset the router to factory defaults. I also shut the router and modem off and also tried restarting my computer. I even restored my computer to yesterday's settings..

How do I assign static ip addresses? Also how do I connect to googles public DNS? Is that a good long term solution that will work for every iPhone or iPad that walks into my house and tried to connect to my wireless network?


To be able to tell you how to set static IPs, I would have to know the exact model of your router. But for the DNS thing:

1. In the bottom right corner, click on your network connection (the wireless icon if it's wireless)
2. Click "Open Network and Sharing Center"
3. Click "Change adapter settings"
4. Whichever adapter is currently connected, right click on it and select "Properties"
5. Find "Internet Protocol Version 4" in the list and click on it once
6. Click "Properties"
7. Click the button next to "Use the following DNS server addresses" and enter the following:

Preferred DNS Server: 8.8.8.8
Alternate DNS Server: 8.8.4.4

8. Click "OK", and close out of everything. It will automatically apply the settings.

If the problem is, in fact, an IP conflict on your network, assigning static IPs to your devices should help. If other devices come on to your network, it depends how many are there at a time whether static IPs will work. It is guaranteed to work if you assign a static IP to everything that comes onto your network, but not all of us want to do that. So, if you only have a couple other devices (aside from your own) on the network at a time, there is an extremely good chance there won't be an IP address conflict, unless there is some other underlying problem.

#6 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,123 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:12:13 AM

Posted 29 September 2012 - 11:15 PM

If the 8.8.8.8 dns does not work verify your router is even being assigned an ip or has access to he internet. Start at the first device and verify connectivity. Disconnect the router and unplug the modem and plug a pc directly into the cable or dsl modem, plug the modem back in and identify all service lights are green (can vary by modem usually power, link, internet,). On the pc directly connected to the modem start the command prompt ( hold the windows key down and press "R" type cmd and press enter) type ipconfig /release and press enter, when the comand prompt returns type ipconfig /renew press enter. If the pc receives an ip address type ping Google.com and press enter. If no ip is assigned call your isp and have the modem checked. If the ping is sucessfull, power down the modem and reconect the router (the router should be off) connect a pc directly to the router. Power the modem on first and wait for he internet light to turn green. Turn on the router, wait for the router to boot and the status lights turn green. Repeat the ipconfig release/renew commands. If the ping to Google.com is not sucesfull try ping 8.8.8.8, let us know what happens.
Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users