Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

New power supply wont boot


  • Please log in to reply
1 reply to this topic

#1 rfgggg

rfgggg

  • Members
  • 76 posts
  • OFFLINE
  •  
  • Local time:08:34 PM

Posted 19 September 2012 - 08:27 PM

So once again i find my self here with another problem i have no idea how to fix...a couple of months ago my old power supply died-smoke effects included- after i check out my motherboard to the best of my ability and it seemed that only the power supply was bad...now i just got a new one and excitedly plugged it all in and hit the power button but all i got was all of my fans spining and lighting up(including the ram stick) but it wont post.........

things i have tried include:
1. check all connections
2. try different video card(cant go without one seeing how it has no onboard video)
3. removing hard drive and cd drive which do spin and the cd drive will open and close
4. changing ram sticks and moving them around
5. beating it with a hammer(a joke but anyway)


my motherboard has never made any beeps at all ever when posting even when i tried to get it to and still doesn't

this: is a link to the newegg page for the new power supply http://www.newegg.com/Product/Product.aspx?Item=N82E16817822008
sadly i cant remember or find a page for my motherboard because newegg stopped supplying them how ever it is a asrock(bout all i can remember sadly)sorry for not being much help there



other then all of that i can't think of anything else to add and would greatly appreciate some help...ive heard that it may just simply be that the power supply isnt compatible with my mother board but id rather try anything else before i have to deal with returning it and then waiting for another one to come in

BC AdBot (Login to Remove)

 


#2 Artrooks

Artrooks

  • Members
  • 1,463 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New York
  • Local time:09:34 PM

Posted 20 September 2012 - 12:05 PM

rfgggg,

(1.) What is the model number of your Asrock motherboard?

It would appear that the new power supply is functioning by turning on the fans and powering the CDROM and hard drive.

(2.) The fact that the motherboard has never beeped or doesn't appear to POST would make me question the motherboard.
  • Try removing all components (hard drives, CDROMs, memory, add-on cards including video card).
  • Turn on with just motherboard, power supply, keyboard and mouse. Any beeps?
  • Let us know.

Regards,
Brooks



 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users