Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Firefox won't open good pop-up windows when clicked


  • Please log in to reply
17 replies to this topic

#1 Claytronic

Claytronic

  • Members
  • 212 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:07 AM

Posted 15 September 2012 - 02:51 PM

I apologize if the title isn't clear enough, but it's the best way I could describe my issue.
Whenever I click on a link on one of my legitimate game websites to say... message another user (clicking "message this user" opens a small pop-up window that you can type in), nothing happens. This has happened ONLY since this morning and was working fine any other time, so I have no idea why it's doing this.
I'm scanning my computer for malware right now, I've cleared my cache, restarted Firefox, restarted my computer, checked NoScript to see if it was blocking anything when I clicked on "message this player".. nothing has fixed it.

Any help will be greatly appreciated :)

BC AdBot (Login to Remove)

 


#2 evti

evti

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Local time:02:07 AM

Posted 15 September 2012 - 03:13 PM

Did you update Firefox or anything between now and then? Firefox should show something up beside the address bar saying "popup blocked" if it blocks a requested popup. If you click on it, it should give the option to allow popups from that particular site in the future. Otherwise, you should be able to go into your settings and manually allow popups from certain sites.

#3 Claytronic

Claytronic
  • Topic Starter

  • Members
  • 212 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:07 AM

Posted 15 September 2012 - 03:14 PM

Did you update Firefox or anything between now and then? Firefox should show something up beside the address bar saying "popup blocked" if it blocks a requested popup. If you click on it, it should give the option to allow popups from that particular site in the future. Otherwise, you should be able to go into your settings and manually allow popups from certain sites.

Nope, haven't updated it (that I know of) and there is no "popup blocked" warning.

#4 Claytronic

Claytronic
  • Topic Starter

  • Members
  • 212 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:07 AM

Posted 15 September 2012 - 07:16 PM

Strange. I went out for a while, came back, turned on my computer, clicked "message this player" and it popped up. Tried it on another player's profile.. didn't work, another player, didn't work. Went back to the first.. didn't work.
Very strange.

#5 jhayz

jhayz

  • BC Advisor
  • 6,922 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:07 AM

Posted 15 September 2012 - 08:24 PM

Have you tried the gaming website for any fix, discussion or thread regarding the problem?

Tekken
 


#6 Claytronic

Claytronic
  • Topic Starter

  • Members
  • 212 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:07 AM

Posted 15 September 2012 - 08:25 PM

Have you tried the gaming website for any fix, discussion or thread regarding the problem?

It's a sim game so it aint really a big huge MMORPG or anything, but none of the players or staff members are having the same issue.

#7 jhayz

jhayz

  • BC Advisor
  • 6,922 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:07 AM

Posted 15 September 2012 - 09:09 PM

The only option I see related for that popup window issue with firefox option is the Contents tab and checkmarked Block popup windows with exceptions.

Tekken
 


#8 Claytronic

Claytronic
  • Topic Starter

  • Members
  • 212 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:07 AM

Posted 15 September 2012 - 09:10 PM

The only option I see related for that popup window issue with firefox option is the Contents tab and checkmarked Block popup windows with exceptions.

I actually tried that :( Tried making the game site one of the exceptions.. still didn't work.

#9 jhayz

jhayz

  • BC Advisor
  • 6,922 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:07 AM

Posted 15 September 2012 - 10:38 PM

Since you mentioned Firefox, how about using another browser instead to check on the difference? I don't play SIM games or anything so this may be my last suggestion as looking for that popup window is not much referenced to any fix when looking online. It maybe a browser setting or a bug from your end.

Tekken
 


#10 Claytronic

Claytronic
  • Topic Starter

  • Members
  • 212 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:07 AM

Posted 15 September 2012 - 10:43 PM

Since you mentioned Firefox, how about using another browser instead to check on the difference? I don't play SIM games or anything so this may be my last suggestion as looking for that popup window is not much referenced to any fix when looking online. It maybe a browser setting or a bug from your end.

It works in Internet Explorer, so it's just isolated to Firefox.

#11 jhayz

jhayz

  • BC Advisor
  • 6,922 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:07 AM

Posted 15 September 2012 - 10:48 PM

Can you just reinstall Firefox then?

Tekken
 


#12 Claytronic

Claytronic
  • Topic Starter

  • Members
  • 212 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:07 AM

Posted 15 September 2012 - 10:58 PM

Can you just reinstall Firefox then?

I could but I'm relying on some other sort of quick-fix before I go about re-installing all of my add-ons and such :P

#13 Claytronic

Claytronic
  • Topic Starter

  • Members
  • 212 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:07 AM

Posted 16 September 2012 - 06:16 AM

I forgot to mention that my scans came up 100% clean. I am about to get to bed so I will see how it is when I log in later on.

#14 buddy215

buddy215

  • Moderator
  • 13,195 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:West Tennessee
  • Local time:11:07 AM

Posted 16 September 2012 - 07:35 AM

You could try disabling NoScript temporarily or try Allow Scripts Globally from the drop down menu for NoScript.
You should check to be sure you have the latest NoScript and Firefox.

I allow NoScript RCs so my latest is 2.5.5rc2. Firefox latest is 15.0.1
Check your plugins for updates. Especially Java and Flash.

Some recent changes to NoScript:
  • Work-around for bug 789773.
  • Better Java applet origin identification algorithm.
  • Fixes for several incompatibilities and breakages introduced by Gecko 15, 16 and 17.
  • Work-around for a Gecko URL parsing quirk which might confuse the XSS injection checker (thanks .mario for reporting).
  • Better compatibility with ASP.NET web sites.
  • Holding the left mouse button down on an absolutely positioned page element and hitting the DEL key will remove it i scripts are disabled (useful to forcibly kill in-page popups). This feature can be disabled by setting the noscript.eraseFloatingElements about:config preference to false.

“Every atom in your body came from a star that exploded and the atoms in your left hand probably came from a different star than your right hand. It really is the most poetic thing I know about physics...you are all stardust.”Lawrence M. Krauss
A 1792 U.S. penny, designed in part by Thomas Jefferson and George Washington, reads “Liberty Parent of Science & Industry.”

#15 Claytronic

Claytronic
  • Topic Starter

  • Members
  • 212 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:07 AM

Posted 16 September 2012 - 05:22 PM

Alright.
I disabled Java, tried, no luck, enabled it and tried again with no luck still.
My NoScript is 2.5.5 and my Firefox is 16.0 Beta 3
The game site is on my NoScript's whitelist. I think it might possibly be my Firefox version (it was updated on the 14th)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users