Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

atapi.sys High CPU?


  • Please log in to reply
1 reply to this topic

#1 KanagiF

KanagiF

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:07:04 AM

Posted 11 September 2012 - 12:12 PM

Okay so I've asked in a couple other places but over all most are out of ideas, since I've spent the better part of the last 2 days, and all of the 2 before that working on this issue. The original thread is http://www.tomshardware.com/forum/347079-28-high-usage-interrupts#t2643258 in case you wanna see everything I have found/tried out.

When I built this computer a few days ago and I first set it up, it was at ~2% core usage with basic programs. But now the second it comes on, it's instantly at 70+ on atleast 2, or 3 cores. I've run DPC Checker, LatencyMon, and Process Explorer. Process Explorer pointed it out to be "System Interrupts" which is what started my google search to see it's a fairly common issue. (I'd never heard of it before.) Some fix it by disabling Sound Enhancements, or removing hardware. I've tried everything, and am on format number 6 (REALLY breaking in my new SSD, haha.)

My problem always comes back to 'atapi.sys' and to a lower extent 'usbhub.sys' or something like that. The atapi.sys being the major one. I found out that is the HDD driver but have tried anything I can to "update" it including firmware for the SSD, older drivers for my mobo, etc.

Tonight I'm going to try to just "uninstall" every IDE device one by one and let Windows re-update it, and also flash my BIOS back to 1.0, but after that I'm truly out of ideas. Anyone else had any kind of experience with this?

I'll list my specs - If a star is next to it, it's from my old comp.

Corsair 750W PSU*
nVidia 560Ti*
(2x4) 8GB G.Skill 1333 RAM*
ASRock Extreme 4- 1155
i5 3570K
Samsung 830 128GB
WD 600GB*
WD 2TB*

Posting from work so I can reply within a couple minutes - Won't be able to run any tests or attach files until I get home.

Edited by KanagiF, 11 September 2012 - 12:13 PM.


BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 55,896 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:07:04 AM

Posted 11 September 2012 - 06:20 PM

Well...it's (obviously) time to look at two things:

a. Your startups, using a tool like Autoruns (the Logon tab reflects the typical startup items)

AutoRuns for Windows - http://technet.microsoft.com/en-us/sysinternals/bb963902.aspx

b. Task Manager Processes tab.

I would eliminate all items on the Logon tab, other than the Microsoft entries and obvious things like my AV...and see the impact on processes. When you see the spike disappear along with the startup...you have the answer.

FWIW: atapi.sys errors/situations, like anything else, can be a sign of malware...which is another reason to take a look at the startups.

Louis




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users