Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Sharing Problem


  • Please log in to reply
8 replies to this topic

#1 randyrayd

randyrayd

  • Members
  • 91 posts
  • OFFLINE
  •  
  • Location:Austin, of course.
  • Local time:06:37 PM

Posted 15 March 2006 - 01:39 PM

Could anyone explain why my HD (C drive) gets changed automatically to allow sharing? I keep changing it to disallow sharing, but after a few days I check it and it is back to allow sharing.

When it does show back up as “share this folder” checked, the drive is listed as “C$” and not just “C”.

My OS is Win2K Pro and I have up-to-date AV and anti-spyware (scans have been run) plus a firewall on an encrypted LAN.


Thanks,
Randall

BC AdBot (Login to Remove)

 


#2 randyrayd

randyrayd
  • Topic Starter

  • Members
  • 91 posts
  • OFFLINE
  •  
  • Location:Austin, of course.
  • Local time:06:37 PM

Posted 15 March 2006 - 05:01 PM

I've discovered there are Administrative Share creations that are hidden for each drive.

If you want a secure network, you have to disable these shares permanently, and a registry edit is necessary.

Why in the world would M$ do this?

Thanks,
Randall

#3 Enthusiast

Enthusiast

  • Members
  • 5,898 posts
  • OFFLINE
  •  
  • Location:Florida, USA
  • Local time:06:37 PM

Posted 15 March 2006 - 05:58 PM

Setting Permissions for a File or Folder
To set the permissions for a file or folder:
1. Use Windows Explorer to locate the file or folder for which you want to edit the permissions.
2. Right-click the folder, and then click Properties.
3. Click the Security tab.
4. To add a new access control setting to the folder, click Add.
5. Select the users, computers, or groups that this access control setting is applied to, click Add, and then click OK.
6. To remove an access control setting, click Remove.
7. To edit the permissions for any group, select the user or group, and then use the corresponding check boxes in the Permissions pane.
8. Click OK to accept the settings, click Cancel to cancel any changes you have made, or click Apply to apply the changes without closing the file or folder properties.

http://support.microsoft.com/kb/324067/en-us

You must do this with an administrator level account.

Network permissions set by a domain administrator override any local settings, so if you are a user on a domain the network admin's settings will overrule yours.

Do you have Win 2 K set up with NTFS or FAT32?

Some security options are not available using FAT32.

#4 randyrayd

randyrayd
  • Topic Starter

  • Members
  • 91 posts
  • OFFLINE
  •  
  • Location:Austin, of course.
  • Local time:06:37 PM

Posted 15 March 2006 - 06:14 PM

You must do this with an administrator level account.

Network permissions set by a domain administrator override any local settings, so if you are a user on a domain the network admin's settings will overrule yours.

Do you have Win 2 K set up with NTFS or FAT32?


This is on my LAN at home so I'm an administrator on the computers. I didn't think I designated a domain on the LAN, so I'm confused on the "domain administrator" thing. I'm also not the sharpest pencil in the box concerning networking, so if that doesn't make sense, please excuse.

I'm using NTFS.

#5 Enthusiast

Enthusiast

  • Members
  • 5,898 posts
  • OFFLINE
  •  
  • Location:Florida, USA
  • Local time:06:37 PM

Posted 20 March 2006 - 10:44 AM

You wouldn't have set up a domain on a home network (unless you checked the box by mistake on setup)

You should have and probably did set up "workgroup" though.

You should be able to accomplish what is described above if you have it set up on NTFS. I'm not sure about FAT32 though. It doesn't have all the security settings that NTFS enables.

Let us know.

Edited by Enthusiast, 20 March 2006 - 10:46 AM.


#6 randyrayd

randyrayd
  • Topic Starter

  • Members
  • 91 posts
  • OFFLINE
  •  
  • Location:Austin, of course.
  • Local time:06:37 PM

Posted 20 March 2006 - 12:52 PM

I've found out the "share" creations are in the registry and are created each log on. So it doesn't matter if I disallow sharing. The C drive goes back to "shared" each boot.

Here's a link that will explain it:

http://www.petri.co.il/disable_administrative_shares.htm

The article says XP is this way also, but the shared drive may be indeed "hidden", as I can't find this configuration on my other computer which has XP.

I, personally, need to find out why M$ did this before making registry changes.

Randall

#7 Enthusiast

Enthusiast

  • Members
  • 5,898 posts
  • OFFLINE
  •  
  • Location:Florida, USA
  • Local time:06:37 PM

Posted 21 March 2006 - 12:00 AM

From the article:

"These shares are hidden, but available with full control to domain administrators."

Maybe you did set up a domain when Win2K was installed.

#

C$ D$ E$ - Root of each partition. For a Windows NT workstation/W2K/2003/XP Professional computer only members of the Administrators or Backup Operators group can connect to these shared folders. For a Windows NT Server/W2K Server computer, members of the Server Operators group can also connect to these shared folders.

If you haven't given out any other administrator accounts no one else will have access.

#8 randyrayd

randyrayd
  • Topic Starter

  • Members
  • 91 posts
  • OFFLINE
  •  
  • Location:Austin, of course.
  • Local time:06:37 PM

Posted 21 March 2006 - 09:36 AM

With your help, I may have figured this out.....although this computer is not part of a domain, it came from work and seems to be configured through Network ID Wizard to be able to be part of a domain. I'll try later to reconfigure and let you know. Kinda busy now trying to get my tax stuff done.

Thanks,
Randall

#9 Enthusiast

Enthusiast

  • Members
  • 5,898 posts
  • OFFLINE
  •  
  • Location:Florida, USA
  • Local time:06:37 PM

Posted 22 March 2006 - 12:12 AM

You are welcome. Hope you are successful in accomplishing what you want.

If not, come back here and we'll figure it out.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users