Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Denied Administrator Access


  • Please log in to reply
6 replies to this topic

#1 Twinkiey

Twinkiey

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:04:41 AM

Posted 01 September 2012 - 02:12 AM

I don't know if anyone could help me, but I seem to be having a problems with my computer's Administrator perks. My account is an administrator, and recently, I have been unable to do anything that requires that I be an administrator. Whenever I run an application that is set to Run as Administrator, an error box opens that says "The specified module could not be found" I can not access User Account Controls, the window just does not open, no error message. I can use applications that would normally display the error message in Safe Mode, but I still can't access things like User Account Controls. I run Windows 7 Home Premium 64-bit.

Edited by Twinkiey, 01 September 2012 - 02:16 AM.


BC AdBot (Login to Remove)

 


#2 InadequateInfirmity

InadequateInfirmity

    I Gots Me A Certified Edumication


  • Banned
  • 5,180 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:41 AM

Posted 01 September 2012 - 05:12 AM

How long have you had this issue?Boot into safemode with command prompt and try a system restore from there.Once in safemode with command prompt type rstrui.exe hit enter and choose your earliest restore point.

#3 Twinkiey

Twinkiey
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:04:41 AM

Posted 01 September 2012 - 09:21 AM

I've had it since the start of the month, I tried to do as you said, restore points had been disabled sadly, so that's not an option.

#4 InadequateInfirmity

InadequateInfirmity

    I Gots Me A Certified Edumication


  • Banned
  • 5,180 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:41 AM

Posted 01 September 2012 - 11:01 AM

Do you have your disk? You can save your self a headache and do a repair install.

#5 Twinkiey

Twinkiey
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:04:41 AM

Posted 01 September 2012 - 04:02 PM

I do not have the install disk, and I would like to keep my data intact if at all possible.

#6 InadequateInfirmity

InadequateInfirmity

    I Gots Me A Certified Edumication


  • Banned
  • 5,180 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:41 AM

Posted 01 September 2012 - 06:26 PM

You may want to create a restore point prior to doing this. Here is what I found on the net. Hope it helps you.

Download the .reg file save it to your desktop then right click it and select merge.Now reboot.
http://www.vistax64.com/attachments/tutorials/3782d1210316057-user-account-control-uac-turn_uac_off.reg?ltr=U
This will turn off UAC



open file explorer
right click on C:\
select Properties option
choose security tab
click advanced button
select owner tab
click Edit button
click on the name you want ownership rights changed to ie: your administrator user
tick the box "replace owner on subcontainers and objects"
hit apply

this should restore your ownership of C:\


hope this helps


Open elevated command prompt and copy and paste the following and reboot.Hit enter after each.
It may take a bit to run.


icacls * /T /Q /C /RESET

ICACLS/restore


You should use:
sc create SysCmd type= own type= interact binPath= C:\Windows\System32\cmd.exe
net start SysCmd

Alternatively you can enable the build administrator account through registry or access system repair through the System Recovery component

1) Reboot your PC
2) On post, keep tapping F8
3) Select System Recovery or whatever the name was
4) Wait until its loaded, you can do system recovery now.

5) If you don't choose system recovery and want to enable the build-in admin, select command prompt
6) Type regedit
7) File (menubar) > Load hive > Select: C:\Windows\System32\config\SAM
8) Go to: <Loaded hive>\SAM\Domains\Account\Users\000001F4
9) Right click and edit the F value
10) Look for a hexadecimal value 11 at row 8
11) Modify it to 10
12) Select loaded hive > File > Unload hive
13) reboot





I want you to create another user account give it admin privelages and see if the issue persist.


Open notepad and copy and paste the below into note pad and name it newprofile.bat

@echo off
net user new /add /expires:never /passwordreq:no
net localgroup “Administrators” /add new

Save it to your desktop right click run as admin.Then reboot your machine.Then you will have a new account named new do not log into that account just yet.Log into your normal account and then give new admin rights.To do this Hit start>Control Panel>User Accounts>Manage Another Account>Find new>Change Account Type> Standard User should be selected You will need to change the account to Admin >Then Hit the Change Account type button next to cancel.Now reboot into your new account and see if your problem persist. :)

Edited by InadequateInfirmity, 01 September 2012 - 07:25 PM.


#7 InadequateInfirmity

InadequateInfirmity

    I Gots Me A Certified Edumication


  • Banned
  • 5,180 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:41 AM

Posted 01 September 2012 - 06:58 PM

This information may be helpful as well.
http://www.sevenforums.com/tutorials/507-built-administrator-account-enable-disable.html

Also you can download Grant Perms by Farbar and type c: in the grant perms window and select unlock also try c:\\ and select unlock then reboot.
http://www.bleepingcomputer.com/download/grantperms/




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users