Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

32-bit apps not able to use the network; 64-bit apps can


  • Please log in to reply
4 replies to this topic

#1 imolaavant

imolaavant

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:01:56 PM

Posted 30 August 2012 - 09:47 PM

I can only connect to the network using 64 bit applications on Window 7 Pro SP1.

The problem occurred immediately after installing the latest version of iTunes (may or may not be related). I uninstalled iTunes with no change then reinstalled just to see if there was a difference: nope. IE 32-bit crashes after launching. Firefox opens but gives a "Server Not Found" error for all requests, local or internet. Filezilla will not connect to local or remote FTP servers. VNC will not connect to local servers - gives error "Unable to initialise Winsock2". I ran WireShark while making requests with Firefox. No http traffic was seen at all. The requests aren't even hitting the wire.

IE 64-bit works fine and command line tools like ftp and telnet to internal and external sites works fine - this is not a DNS, Firewall, or Routing issue.
I just installed the 64 bit version of Firefox and it works fine as well.

Unfortunately I just discovered that System Restore was not enabled so I can't roll back.

Same results in Safe Mode
Same results with a diagnostic startup via msconfig
Same results on wired or wireless network
Same results on different networks

sfc /scannow runs clean.
netsh int ip reset gives:

Reseting Interface, OK!
Restart the computer to compete this action.

netsh winsock reset gives:

Sucessfully reset the Winsock Catalog.
You must restart your computer in order to complete the reset.


Needless to say things are the same after rebooting.

I'm currently running a full system scan with Symantec Endpoint (I received an update earlier in the day and have their most recent defs), but I am 98.53% sure this is not malware related: I use Gmail filtered through Postini, I have Symantec Endpoint, I run SpyShelter Premium, I only use Firefox with AdBlock and NoScript configured to the point that browsing sites not normally frequented is annoying because most don't display properly without making exceptions in the aforementioned programs.

Please! Does anyone have any suggestions? I see plenty of posts on other forums about similar issues but either they never get resolved, the winsock reset worked, or the user reinstalled the OS. I really don't want to go that last route.

Thanks!

BC AdBot (Login to Remove)

 


#2 gavinseabrook

gavinseabrook

  • Members
  • 773 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:El Paso
  • Local time:10:56 AM

Posted 31 August 2012 - 12:45 AM

Have you tried a system restore back before the point where you had the issue?

Gavin Seabrook

 


#3 imolaavant

imolaavant
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:01:56 PM

Posted 31 August 2012 - 08:21 AM

Have you tried a system restore back before the point where you had the issue?


System Restore was disabled (I don't recall disabling it, not sure why it wasn't on) so I have no restore points to roll back to.

The Symantec scan and a Malwarebytes scan ran clean.

I'm off to see if there's a way to reinstall - not just reset - winsock(2). I'm convinced this is the problem since some apps give errors stating they can't initialize winsock. No 32-bit apps have network access and some 64-bit apps do. I'm not a developer, or even close, but from what I've been reading it seems as though 32-bit apps must use winsock but Microsoft offer a different method to access network resources for 64-bit applications. That said, a developer can use the old winsock method for 64-bit apps, which would explain why some work and some don't.

This is only affecting applications. Windows has connectivity, I can browse the network and as previously mentioned command line networking tools work.

#4 SleepyDude

SleepyDude

  • Malware Response Team
  • 3,083 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:06:56 PM

Posted 01 September 2012 - 11:56 AM

Hi,

Did you try running sfc?
Open the Command Prompt as Administrator (right click and select Run-as Administrator) then use the command:

sfc /scannow

Edited by SleepyDude, 01 September 2012 - 11:56 AM.

• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#5 imolaavant

imolaavant
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:01:56 PM

Posted 01 September 2012 - 12:17 PM

Issue resolved:

Deleting and importing the following registry keys from another machine fixed the problem:
HKLM\SYSTEM\CurrentControlSet\Services\Winsock
HKLM\SYSTEM\CurrentControlSet\Services\Winsock2




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users