Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


temp environment variable weirdness

  • Please log in to reply
2 replies to this topic

#1 wspider


  • Members
  • 3 posts
  • Local time:12:49 PM

Posted 14 August 2012 - 09:03 AM


Recently I've had some strangeness on my Windows 7 home premium system. I have problems with various office products..all of which complain of

Outlook could not create the work file. Check the temp environment variable.
Word could not create the work file. Check the temp environment variable.
Could not install the custom actions. The form cache file 'C:\Users\tom\AppData\Local\Microsoft\FORMS\FRMCACHE.DAT' is not valid. Contact your administrator.

Additionally at boot this pops up...

Catalyst Control Centre: Host application has stopped working multiuser

I've tried setting the temp variable via ie temporary internet file changes. I set it to C:\Users\tom\AppData\Local\Microsoft\Windows and after reboot I open a command window and try this

.... > C:\Users\tom>cd %TEMP%
.... > C:\Users\tom\AppData\Local\Temp>

I can cd to %TEMP% or %TEMP%\Temporary Internet Files and create and remove directories.

I've tried both of these, fix1 and fix2.

I've run a full scan with malware bytes and KIS

So looking for pointers to a solution. Thanks!

BC AdBot (Login to Remove)


#2 noknojon


  • Banned
  • 10,871 posts
  • Gender:Not Telling
  • Local time:02:49 AM

Posted 14 August 2012 - 05:54 PM

Hi -

Catalyst Control Center: Host application has stopped <<From Microsoft 7 Forum - Plenty more information here .

Ignore some of the usual "ranting" and there are decent solutions for you, mainly on page one -

Good luck -

#3 wspider

  • Topic Starter

  • Members
  • 3 posts
  • Local time:12:49 PM

Posted 15 August 2012 - 10:23 PM


I solved this myself..after adding a user and running tests under that login I saw that some folders under %USERPROFILE%\AppData have write privileges missing for my account.

I changed the HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders and Shell Folders Cache entry to a folder outside the AppData hierarchy. The 'could not create the work file' messages immediately went away. I moved the folder because despite removing 'READ ONLY' from the parent of the Temporary Internet Files folder the folder would become read only again. I deleted FRMCACHE.DAT and verified the folder it was in was writable by my account..that error disappeared. When Outlook was launched a new FRMCACHE.DAT file was created..and no error message.I then made user AppData\Local\ATI and AppData\Local\ATI\ACE were writable by my login..the Catalyst Control Centre messages went away too.

It's apparent that application folders under AppData have lost the write ability for my account. Fixing those fixed my error messages.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users