Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Possible malware infection on every single home PC


  • Please log in to reply
2 replies to this topic

#1 cheesehead9099

cheesehead9099

  • Members
  • 74 posts
  • OFFLINE
  •  
  • Local time:12:27 AM

Posted 09 August 2012 - 05:31 PM

Hello. I'm posting here because this is for some PCs that are not being looked at in my current log, which is in the virus and malware removal forum for one specific PC:
http://www.bleepingcomputer.com/forums/topic461689.html/page__st__105

Recently one of my PCs was infected by the sirefef virus, and I backed up my school documents before performing a complete reformat and reinstall of Windows. However, I find that my PC is still having problems (freezing, many different event viewer issues, etc.) and I'm convinced that I am still infected with the rootkit, and that I re infected myself by copying over those backed up files. I will be doing another clean reinstall without those files, and that should hopefully fix my problem.

However, here is the real issue. The major problem is that when I backed up my files onto two USBs, i wanted to make sure that they were free of viruses. So, like an idiot, I plugged the USBs into both my other home computers and scanned them for viruses. The report came up clean, and I disconnected the USBs.
Here's where the problem comes in. Now, on one of the PCs, whenever I try and run anything as administrator on a non-admin account, everything freezes up and multiple instances of consent.exe are shown in the task manager for every time that I run something as admin (i.e. if i try and run 3 programs as admin, nothing will pop up and 3 instances of consent.exe will appear). I looked it up and people said that this is possibly caused by a corrupt catroot2 database...so I tried the instructions posted here :http://www.wincert.net/tips/microsoft-windows/2522-consetexe-hangs-when-trying-to-use-run-as-administrator

However, whenever I try to run any of those esentutl commands, I always get 'access denied'. I tried using the take control command, changing the permissions, booting in safemode, renaming the folder (problem still persists), always gives me access denied. I can rename the folder regularly through windows explorer, but that does not solve the consent freezing problem.

I decided to check my other computer to see if the problem is on that computer too. There is no freezing...but the esentutl commands all still give me access denied whenever I try to access system32. Same with the infected PC.

Now I'm afraid that I've managed to infect ALL THREE of these PCs through the USB sticks...as far as I'm aware these issues were not present prior to the USBs being plugged in....all virus scans come up negative on both PCs, however on the first PC (the one with the consent.exe error) i recently removed Win32/FakeRean that MSE had detected.

I don't know what to do...now I feel as if every computer in my household is infected...I don't know where to go with this. Again, i am denied from using the esentutl command on anything in the system32 folder on ALL THREE PCs...would a repair install of Windows fix this issue?

BC AdBot (Login to Remove)

 


#2 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,738 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:10:27 PM

Posted 09 August 2012 - 10:35 PM

Sirefef rootkit requires advanced attention.

Please follow the instructions in ==>This Guide<== starting at Step 6. If you cannot complete a step, skip it and continue.

Once the proper logs are created, then make a NEW TOPIC and post it ==>HERE<== Please include a description of your computer issues, what you have done to resolve them, and a link to this topic.

If you can produce at least some of the logs, then please create the new topic and explain what happens when you try to create the log(s) that you couldn't get. If you cannot produce any of the logs, then still post the topic and explain that you followed the Prep. Guide, were unable to create the logs, and describe what happens when you try to create the logs.

It would be helpful if you post a note here once you have completed the steps in the guide and have started your topic in malware removal. Good luck and be patient.

If HelpBot replies to your topic, PLEASE follow Step One so it will report your topic to the team members.

My Website

My help doesn't cost a penny, but if you'd like to consider a donation, click DONATE

 


#3 cheesehead9099

cheesehead9099
  • Topic Starter

  • Members
  • 74 posts
  • OFFLINE
  •  
  • Local time:12:27 AM

Posted 10 August 2012 - 12:15 AM

I'm not sure if I actually have sirefef on all the machines.. I'm asking if the access denied issue could be caused by malware. I will create logs for both computers and post them anyhow




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users