Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Toshiba Laptop not shutting down


  • Please log in to reply
3 replies to this topic

#1 Inlovewithnight

Inlovewithnight

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:03:49 AM

Posted 08 August 2012 - 02:59 PM

Recently my Toshiba Satellite laptop which runs Windows 7 is not shutting down. When shutting down, I receive a message that there is a background program running. I have to shut down the computer using the power button. Before I shut down the computer, I close all opened programs and then I open the task manager to see if there are any applications still running and there aren't any running. Any help would be much appreciated. Thank you.

BC AdBot (Login to Remove)

 


#2 Allan

Allan

  • BC Advisor
  • 8,666 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:02:49 AM

Posted 08 August 2012 - 03:18 PM

What happens when you boot to safe mode and shut down - does it do so normally? Also, What is new or different since the last time everything worked properly (ie, new hw, new sw, virus, error, etc)?

If the shutdown is normal from safe mode you can try the steps below. NOTE - before editing the registry you should create a registry backup by one of the following methods:

1) Click on START - RUN and type: Regedit (press ENTER). On the menu bar click on file, then export, choose where you want to save it, then enter a name for it in the box titled: File Name. At bottom put a tick in "All", then click on save. If you ever want to restore the saved version, just IMPORT it.

2) System Restore (it should save a copy daily, but you can always create a restore point manually.

3) The best method, in my opinion, is to download and run ERUNT. It's the best registry backup utility available - and it's free!!!



Okay, now let's try this first:

1 )Start - Run - Regedit
Navigate to the following Registry key:
HKEY CURRENT USER\Control Panel\Desktop
Double click on the AutoEndTasks entry and replace the 0 with a 1 in the Value data text box

For the next two, if the dword value indicated does not exist, create it:

Double click on the WaitToKillAppTimeout entry in the right pane and change the Value data to 2000

Double click on the HungAppTimeout entry in the right pane and change the Value data to 1000

Reboot

2) HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
Right-click on WaitToKillServiceTimeout and change it to 2000


If that doesn't work, try this:

Open msconfig and on the General tab choose "selective startup" (uncheck all three items) and reboot. Does the problem still occur? If not, start adding items back to msconfig one or two at a time, rebooting after each change, until the problem reappears and you'll have identified the offending process. This is clearly a time consuming procedure, but it is the best way to determine if some process loading with the system is the cause of your problem.
After you've isolated the cause, do not use msconfig to permanently disable the process. Instead, if it is a service go to START - RUN and type: services.msc (then press enter) and disable the service OR, if it a program, you can download & run a simple app such as Mike Lin's Startup Control Panel (http://www.mlin.net/StartupCPL.shtml) to enable, disable, or otherwise manage startup programs.

#3 Inlovewithnight

Inlovewithnight
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:03:49 AM

Posted 09 August 2012 - 01:25 PM

Thank you. I will report back with results.

#4 Inlovewithnight

Inlovewithnight
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:03:49 AM

Posted 19 August 2012 - 10:10 AM

Hi,

I couldn't use your first suggestion using "regedit". I could not find the entry. I then looked in msconfig and found about 7 items belong to Toshiba, all of which seemed to be "bloatware", and I unchecked all of them. I did notice that when I close AOL, it's still running in my task manager processes, so I unchecked AOL in msconfig. I know you said not to permanently disable from msconfig, but so far my computer is shutting down just fine. I'm going to see if the problem reappears again. In the meantime, I want to thank you very much for all your help.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users