Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

powrprf.dll error message, avast and other programs won't load


  • Please log in to reply
1 reply to this topic

#1 debnyc

debnyc

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:02:01 PM

Posted 04 August 2012 - 02:16 PM

After several days of frustration I am turning to the experts for help with this error message/ possible virus.
this is on a Dell PC, OS: Windows XP Media Edition, Service Pack 3

Last week started getting the following error message upon start up
"The application or DLL C:\WINDOWS\system32\POWRPROF.dll is not a valid Windows image. Please check this against your installation diskette."

I checked AVAST, it was stopped and could not be restarted I have the(most recent version of Avast). Tried to load Boot Scan of Avast, but after trying to enter the options for boot scan, Avast wouldn't "take" the options and nothing happened. Could not repair AVAST from Control Panel.
Downloaded the Avast uninstaller to uninstall Avast uninstalled Avast
Downloaded a new copy of Avast, when I try to install it I get the same POWRPROF.dll error message.

Using MSCONFIG, I clicked startup and chose "Disable All" so that nothing loads automatically, (previously when all the installed programs were loaded at startup the Error message started every time I turned on the PC

Updated and ran Malewarebytes, perfomed Quick Scan scan found two problems, one a virus one a cookie issue, Malewarebytes deleted both for me.

Tried using Restore from main menu (Accessories, System Tools) cold not access Restore.

Today I downloaded Avira (which I had been using on this comp before Avast), Avira downloaded fine, performed a scan automatically which found nothing.(I prefer Avast on this computer to Avira, because it has caught problems in the past that Avira did not. This is my son's computer on which he plays a lot of games and uses Steam, and since his is more prone to a virus than me, I want his comp to have stronger protection.)

would love to have someone check installed programs, registry etc and see if something is actually hidden in here.

BC AdBot (Login to Remove)

 


#2 debnyc

debnyc
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:02:01 PM

Posted 04 August 2012 - 09:12 PM

Might be fixed, after running CC cleaner and Glary to clean up the registry and delete temp files (over 2000 registry problems found in Glary!), I uninstalled Avira, and copied the POWRPROF.dll file from my other XP machine, I renamed the one on the problem computer with "OLD" and copied the new one in the system32 location.

I was then able to successfully install Avast, so maybe somehow that one file was corrupt....

I will now schedule an Avast boot scan just to be safe.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users