Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

BITS not in services.


  • Please log in to reply
9 replies to this topic

#1 Zartos

Zartos

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Local time:05:57 AM

Posted 27 July 2012 - 06:00 AM

I recently got help from this website and was able to remove a pretty bad trojan that was on my computer. Now everything seems clean and everything is working fine except for the fact that when I try to update with windows update I get an error: http://imgur.com/Tz0TS

I click on get help with this error and it says to goto Services, right click on Background intelligent transfer service and click automatic: http://imgur.com/t8jey

The problem is is that it's not there. I believe this was the result of the damage from the trojan.

I've tried to search around on the internet on how to replace it but most of the posts are about vista except for this thread and it's only the last comment.

http://answers.microsoft.com/en-us/windows/forum/windows_vista-windows_update/background-intelligent-transfer-service-bits-not/c69ba6ad-bf60-4e53-9b7b-f97e9436e529

He says:

YES! THANK YOU! IT WORKS PERFECTLY!

This works for Windows 7 64-bit.

If anyone didn't get it you're supposed to type: sc create BITS binpath= "c:\windows\system32\svchost.exe -k netsvcs" start= delayed-auto in cmd and press enter.

Don't forget the space between = and delayed, it matters.

Then restart the PC or go to services.msn and right click on BITS and press start.

Thanks man, I was so angry cause everyone just gave tips that worked only on Vista."


He says it worked for him and he has Windows 7 64 bit like myself. I was just wondering if I should try this or if anyone else has an idea on how I can fix this.

Thanks =)

BC AdBot (Login to Remove)

 


#2 noknojon

noknojon

  • Banned
  • 10,871 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:11:57 PM

Posted 27 July 2012 - 08:53 AM

Hi -
Try this M/soft Fix It program >> http://go.microsoft.com/?linkid=9767096
•Click the Run now button below
•Then follow the onscreen prompts to launch

Let us know if it helps -

#3 narenxp

narenxp

  • BC Advisor
  • 16,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:08:57 AM

Posted 27 July 2012 - 09:43 AM

Most of the microsoft fixits would show error if BITS service is missing

Try to run fixit as adviced by Noknojon ,also


Download

FSS

Checkmark all the boxes

Click on "Scan".
Please copy and paste the log to your reply.

#4 Zartos

Zartos
  • Topic Starter

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Local time:05:57 AM

Posted 27 July 2012 - 05:33 PM

Downloaded and ran Microsoft Fix it
Saw this for a second: http://imgur.com/OBt4U
Then this popped up: http://imgur.com/zRzT7


FFS Log:

Farbar Service Scanner Version: 26-07-2012
Ran by David (administrator) on 27-07-2012 at 15:30:14
Running from "C:\Users\David\Desktop"
Microsoft Windows 7 Home Premium (X64)
Boot Mode: Normal
****************************************************************

Internet Services:
============

Connection Status:
==============
Localhost is accessible.
LAN connected.
Google IP is accessible.
Google.com is accessible.
Yahoo IP is accessible.
Yahoo.com is accessible.


Windows Firewall:
=============

Firewall Disabled Policy:
==================


System Restore:
============

System Restore Disabled Policy:
========================


Action Center:
============

Windows Update:
============
BITS Service is not running. Checking service configuration:
Checking Start type: ATTENTION!=====> Unable to retrieve start type of BITS. The value does not exist.
The ImagePath of BITS service is OK.
The ServiceDll of BITS service is OK.


Windows Autoupdate Disabled Policy:
============================


Windows Defender:
==============
WinDefend Service is not running. Checking service configuration:
The start type of WinDefend service is set to Demand. The default start type is Auto.
The ImagePath of WinDefend service is OK.
The ServiceDll of WinDefend service is OK.


Windows Defender Disabled Policy:
==========================
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Defender]
"DisableAntiSpyware"=DWORD:1


Other Services:
==============

sharedaccess Service is not running. Checking service configuration:
The start type of sharedaccess service is set to Auto
The ImagePath of sharedaccess service is OK.
The ServiceDll of sharedaccess service is OK.


File Check:
========
C:\Windows\System32\nsisvc.dll => MD5 is legit
C:\Windows\System32\drivers\nsiproxy.sys => MD5 is legit
C:\Windows\System32\dhcpcore.dll => MD5 is legit
C:\Windows\System32\drivers\afd.sys
[2012-03-12 11:59] - [2011-12-27 20:59] - 0499200 ____A (Microsoft Corporation) DB9D6C6B2CD95A9CA414D045B627422E

C:\Windows\System32\drivers\tdx.sys => MD5 is legit
C:\Windows\System32\Drivers\tcpip.sys
[2011-06-27 18:09] - [2011-04-24 22:32] - 1896832 ____A (Microsoft Corporation) 61DC720BB065D607D5823F13D2A64321

C:\Windows\System32\dnsrslvr.dll => MD5 is legit
C:\Windows\System32\mpssvc.dll
[2009-07-13 17:09] - [2009-07-13 18:41] - 0824832 ____A (Microsoft Corporation) AECAB449567D1846DAD63ECE49E893E3

C:\Windows\System32\bfe.dll => MD5 is legit
C:\Windows\System32\drivers\mpsdrv.sys => MD5 is legit
C:\Windows\System32\SDRSVC.dll
[2009-07-13 16:36] - [2009-07-13 18:41] - 0170496 ____A (Microsoft Corporation) 765A27C3279CE11D14CB9E4F5869FCA5

C:\Windows\System32\vssvc.exe => MD5 is legit
C:\Windows\System32\wscsvc.dll => MD5 is legit
C:\Windows\System32\wbem\WMIsvc.dll => MD5 is legit
C:\Windows\System32\wuaueng.dll => MD5 is legit
C:\Windows\System32\qmgr.dll => MD5 is legit
C:\Windows\System32\es.dll => MD5 is legit
C:\Windows\System32\cryptsvc.dll => MD5 is legit
C:\Program Files\Windows Defender\MpSvc.dll => MD5 is legit
C:\Windows\System32\ipnathlp.dll => MD5 is legit
C:\Windows\System32\svchost.exe => MD5 is legit
C:\Windows\System32\rpcss.dll => MD5 is legit


**** End of log ****

#5 narenxp

narenxp

  • BC Advisor
  • 16,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:08:57 AM

Posted 28 July 2012 - 12:05 AM

Download

BITS

Launch it,click YES

restart the PC and try to update

good luck

#6 Zartos

Zartos
  • Topic Starter

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Local time:05:57 AM

Posted 28 July 2012 - 04:27 AM

Worked! Thanks so much =)

#7 narenxp

narenxp

  • BC Advisor
  • 16,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:08:57 AM

Posted 28 July 2012 - 04:38 AM

You're welcome :)

#8 hughjass

hughjass

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:09:57 AM

Posted 28 July 2013 - 07:21 AM

Download

BITS

Launch it,click YES

restart the PC and try to update

good luck

 

I must have seen a dozen stupid answers ranging from "Use 'FixIt'" to "Just use System Restore" before stumbling upon your answer...  It just felt too simple but I was desperate so i gave it a shot...

 

You get my "Gold Medal" in the "Not being a total moron" and "Having real and useful advice" events!  Thank you so much for taking the time to be a productive member of the IT community :)!  The stupid BITS reg fix was giving me a real headache...  You've saved my sanity and my neighbor's computer.



#9 Tygger

Tygger

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:06:57 AM

Posted 05 January 2014 - 01:34 AM

Download

BITS

Launch it,click YES

restart the PC and try to update

good luck

I tried this fix but I get this error..

1524714_10153623414000062_669690693_n.jp



#10 mdk_1234

mdk_1234

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:57 AM

Posted 02 June 2014 - 10:17 PM

 

Download

BITS

Launch it,click YES

restart the PC and try to update

good luck

I tried this fix but I get this error..

1524714_10153623414000062_669690693_n.jp

 

 

 

Make sure you check permissions in regedit of the registry change you are trying to make.  I was having the same error because Full Control wasn't set to Allow.  That resolved the issue. 

 

regpermissions.png






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users