Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Port forwarding driving me crazy!


  • Please log in to reply
9 replies to this topic

#1 Toxic Potato

Toxic Potato

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:08:58 AM

Posted 20 July 2012 - 04:04 PM

I have absolutely had it with attempting to port forward for Internet games. No matter what I try, it never works when I attempt to host a server. I have checked my Windows Firewall, it's disabled entirely, I've tried disabling and even uninstalling my anti-virus software, and I've tried using the Hamachi program and Tunngle program (and it may be worth noting that Tunngle actually has worked at some point in time, but no longer for some reason...). I've even tried putting my router - a Netgear WNDR3700 - into DMZ, however, when I've tried hosting a server for any games, nothing. No one can join or even see the server. Even when I owned another router (the model escapes me, but it was DLink), not once did port forwarding ever work.

With the last bit of my patience, I tried connecting my modem directly back into my PC, as that has worked in the (distant) past, and yet, still absolutely nothing! It's driving me completely up the wall, and is causing far more frustration than it's worth, I would like to just be able to host and play a game with friends. :angry: There are some games that I can simply work around this as other users have hosted lobbies, so I can find someone else's server to join, but a few that I would like to play require a direct connection between users; I or a friend hosts (neither of which have worked so far), and the other inputs the other's IP and port (which we've both verified numerous times to be correct). No lobbies, no way to play with friends.

I'm not sure what other details might be needed, but if there's anything else I need to mention, please let me know and I'll get it posted ASAP; I desperately want this resolved... :wacko:

BC AdBot (Login to Remove)

 


#2 teeds2k

teeds2k

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:10:58 AM

Posted 20 July 2012 - 04:38 PM

How do you have the port forward setup on your firewall/router

#3 Toxic Potato

Toxic Potato
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:08:58 AM

Posted 20 July 2012 - 08:15 PM

Posted Image
This is how I have forwarding usually set up on my router. I got the Server IP from my Command Prompt (via ipconfig as usual). The program definitely uses port 10800 (it lets me choose a port to use, and I've tried many other ports as well). Other server applications also don't work when I try forwarding for them, regardless of what port they use.

However, I was unaware that the firewall has a port forwarding section. Should that matter, even if I have the firewall disabled? Also, I am using ESET NOD32 anti-virus, though I'm not sure if it has its own firewall, I couldn't seem to find anywhere in the settings that said so.

#4 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,111 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:12:58 PM

Posted 21 July 2012 - 12:18 AM

Eset node32 does not have a built in firewall the Smart secuirty suite does. This is likely an issue with Windows settings. What version(xp, Vista, 7) and type (home,pro,ultimate) of Windows are you using?

Chad Mockensturm 

Systems and Network Engineer

Certified CompTia Network +, A +


#5 Toxic Potato

Toxic Potato
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:08:58 AM

Posted 21 July 2012 - 12:38 AM

Windows 7 Home Premium, 64-bit.

#6 NpaMA

NpaMA

  • Members
  • 635 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Memphis, TN
  • Local time:12:58 PM

Posted 21 July 2012 - 12:44 AM

Have you confirmed that your modem does not have a firewall built in? Since it doesn't work when directly connected, it means it's most likely a firewall issue on the PC (which you mentioned above that you disabled), firewall problem on the modem (check the modem's control panel to see if you can DMZ or open ports in it), or your provider is intentionally blocking ports.

What model modem do you have? Who is your internet service provider (ISP)?

#7 Toxic Potato

Toxic Potato
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:08:58 AM

Posted 21 July 2012 - 12:51 AM

Have you confirmed that your modem does not have a firewall built in? Since it doesn't work when directly connected, it means it's most likely a firewall issue on the PC (which you mentioned above that you disabled), firewall problem on the modem (check the modem's control panel to see if you can DMZ or open ports in it), or your provider is intentionally blocking ports.

What model modem do you have? Who is your internet service provider (ISP)?


I'm not quite sure if my modem has a control panel, or if it does, I've no idea where it is.

I have an Arris TM602G modem, I believe I've had it for around five or six years now (bit fuzzy on this though, don't remember when I got it too well...), and my ISP has always been Comcast. With all the things I've tried, I'm not sure I'd be too surprised to find they're blocking ports.

Edited by Toxic Potato, 21 July 2012 - 12:52 AM.


#8 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,111 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:12:58 PM

Posted 21 July 2012 - 12:53 AM

You can use the Glasnost Test to check fowr blocked ports from your ISP. Then can sniff for protocol as well and block the requesting port. Popular for bittorrent traffic restricting.

Edited by Sneakycyber, 21 July 2012 - 01:02 AM.

Chad Mockensturm 

Systems and Network Engineer

Certified CompTia Network +, A +


#9 NpaMA

NpaMA

  • Members
  • 635 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Memphis, TN
  • Local time:12:58 PM

Posted 21 July 2012 - 01:10 AM

While connected directly to the modem, open up command prompt and enter the following command:

ipconfig /all

Under local area connection or something similar you should have a default gateway: XXX.XXX.XXX.XXX. Take note of this and your IPv4 address. In your web browser try accessing your default gateway's IP address (this is normally the IP of your modem). So for example, if your default gateway is 192.168.2.1, type http://192.168.2.1/ into the address bar.

If your default gateway and modem starts with 192.168.X.X then your modem most likely has a firewall. If this is the case, I'd recommend contacting Comcast and see if they can put your modem into bridged mode or DMZ your router inside of the modem.

Edited by NpaMA, 21 July 2012 - 01:12 AM.


#10 Toxic Potato

Toxic Potato
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:08:58 AM

Posted 21 July 2012 - 01:53 AM

You can use the Glasnost Test to check fowr blocked ports from your ISP. Then can sniff for protocol as well and block the requesting port. Popular for bittorrent traffic restricting.


I tested for BitTorrent, not sure if that's the one I should've chosen, but it said nothing appeared to be blocked.

While connected directly to the modem, open up command prompt and enter the following command:

ipconfig /all

Under local area connection or something similar you should have a default gateway: XXX.XXX.XXX.XXX. Take note of this and your IPv4 address. In your web browser try accessing your default gateway's IP address (this is normally the IP of your modem). So for example, if your default gateway is 192.168.2.1, type http://192.168.2.1/ into the address bar.

If your default gateway and modem starts with 192.168.X.X then your modem most likely has a firewall. If this is the case, I'd recommend contacting Comcast and see if they can put your modem into bridged mode or DMZ your router inside of the modem.


Unfortunately I can't connect myself directly to the router at the moment, other users are on the network and doing so would disconnect them. I've been through the router's settings page, however, though I definitely haven't seen settings for a firewall.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users