Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Recover GPS Data Files


  • Please log in to reply
2 replies to this topic

#1 senseless

senseless

  • Members
  • 56 posts
  • OFFLINE
  •  
  • Local time:03:14 AM

Posted 19 July 2012 - 11:23 AM

Windows XP Pro
Toshiba A25-S307
(Old!)

I reinstalled the OS and forgot to back up my GPS data files.
I let windows format the HD (60GB) during the installation process.

Is there any chance, sheer luck, that the files might be recovered?

I fiddled with Testdisk/photorec and boy, does it find files!
It was over 20,000 when I shut it down. It filled an 8GB flash drive.
Some of the pictures were definitely from the previous installation.
But no GPS files.
Maybe the program had not reached the sectors where they are?
Or it is not even looking for them?

My GPS files are .gdb and .gpx, neither of which appear on the list at cgsecurity.org
I looked at the instructions for adding custom signatures but it is beyond my understanding.
In general, this program is beyond my understanding.
I had trouble with the drive selection RE save location, but got it to work.

Also, I made a post, same topic, on the cgsecurity.org forum.

Any help appreciated. Thank you.

Edited by hamluis, 19 July 2012 - 12:20 PM.
Moved from Internal Hardware to All Other Applications - Hamluis.


BC AdBot (Login to Remove)

 


#2 James Litten

James Litten

    Ԁǝǝ˥q


  • BC Advisor
  • 1,945 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:03:14 AM

Posted 22 July 2012 - 02:57 PM

Hi Senseless

I saw your post at cgsecurity and then found this one by searching here for 'gps files'. You used a different name there so I was pleasantly surprised to see it was you :)

At this point the difficulty with your situation stems from the fact that you've written a substantial amount of stuff to the drive that you are trying to recover from. I loathe telling someone to try a solution that they have to purchase as opposed to an open source solution but in this case it is probably your last best chance.

Try Restorer Ultimate in demo mode and see if you can find your files with it...
www.bitmart.net

It may see your old partition and it's structure prior to your format and reinstall.

If you can, you'll need to purchase it to do the recovery.

Hope this helps
James

#3 senseless

senseless
  • Topic Starter

  • Members
  • 56 posts
  • OFFLINE
  •  
  • Local time:03:14 AM

Posted 22 July 2012 - 11:54 PM

Hi NeverSayDie...thanks for the reply.

photorec seems like a great program, and I recovered a ton of stuff with it, but it was all stuff that I had backed up before the format, (or don't need.)
Photorec does not look for the GPS data that I forgot to back up, mostly Garmin .gdb files, maybe some GPX (GPS eXchange Format/XML files.)

I have been trying to figure out how to add a gdb (Garmin database) signature to the photorec program.
There are very few references to the process online, and what little I could find seem to indicate that you need be a professional code-writer. I am not. But, neversaydie, eh? I love a challenge. Maybe I can "reverse-engineer" something, if I have enough clues. Here are the clues that I found:
http://www.cgsecurity.org/wiki/PhotoRec_FAQ
http://www.cgsecurity.org/wiki/Add_your_own_extension_to_PhotoRec
http://forum.cgsecurity.org/phpBB3/setup-a-signature-for-a-cs-file-t502.html
http://forum.cgsecurity.org/phpBB3/cannot-seem-to-make-custom-signatures-work-t663.html

Not much to work with. I tried everything.
You have to read the hexadecimal code of the file you want to make a signature for.
I used 3 different programs while figuring out what that means. Search "hex code reader"
I liked this one best, only for its copy/paste options, which are really handy during this process ...
Filealyzer:
http://www.safer-networking.org/en/filealyzer/index.html
The hex tab gives you the code.

The photorec program downloads with testdisk and latest versions include support to add custom signatures.
http://www.cgsecurity.org/wiki/TestDisk
fidentify is in the folder with the rest, and it is capable of registering your new custom signature with photorec, so the program will look for the desired files. fidentify will also check files to see of photorec is already searching for them, but I haven't figured out how to make it do that yet.
I tried and tried to get fidentify to register a new sig, but kept failing.
I was putting the sig in a text file, in the same folder as photorec and all the rest.
Then clicking the fidentify program.
But the fidentify .txt log showed zero recognition of the new signatures.

I even tried putting in signatures that were file types already being searched by photorec.
Nothing.

I figured it was a format issue, maybe my microsoft text programs weren't recognized, as they remained .txt files no matter what I named them. There are several other text files that download with the testdisk stuff. None of them display extensions, but all will open with notepad or wordpad, etc. They are called INFO, READ ME, AUTHORS, THANKS, but do not show a program icon association, hmm.

I opened INFO with wordpad, deleted the contents, and pasted in a signature. Renamed the file "photrec.sig"
Clicked fidentify, and it worked. The fidentify.txt log showed that I had registered a new signature with photorec.
I ran photorec and recovered a bunch of (supposed) Garmin database files, gdb.
I think I used this signature...I tried a few variations.
gdb 0 0x4D735263660002

I have no idea what all this means.
But I looked at a lot of hex to figure it.

After all that, garmin mapsource would not open the recovered files.
And, curiously, most of the recovered files are fairly HUGE, unlike the originals.
So, I used GPSBabel
http://www.gpsbabel.org/download.html

I tried converting a HUGE recovered gdb file to GPX format....just for laughs.
It worked. Mapsource opened the gpx file, perfect, and it was way smaller than the recovered file.
So, I tried converting a HUGE recovered gdb file to a gdb file and that worked too.
For example of size, recovered file 300,000kb converted to functional gdb 2kb.
recovered 170,000kb converted to 55kb.
Hmm, not much logic to it, but the converted files open, and my original data seems sound.

Saved the best for last.
I FOUND the entire data set that I thought I had lost!
I DID indeed back it up, to a secret folder, on an external, forgotten during panic mode...

I pursued this other stuff for personal curiosity.
Still trying to figure why I cannot get photorec to find GPX files, but I think it has something to do with UTF-8 encoding...
Maybe someday.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users