Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Troubleshooting a Network Laserjet that was installed via WSD (Web Service Device)?


  • Please log in to reply
2 replies to this topic

#1 ClearFocus

ClearFocus

  • Members
  • 93 posts
  • OFFLINE
  •  
  • Local time:05:23 AM

Posted 17 July 2012 - 02:33 PM

In all my time working with networks, computer, printers, etc. I had a first recently. I had a friend who has a HP Laserjet 2035n who was having daily problems printing. For the most part, he do all kinds of things and sometimes it would take 45min before it would finally print.

I took a look at immediately noticed the Port was using WSD with no mention of a IP address. The printer doesn't have a display and menu for me to look at the network config. So, I printed a configuration page by holding down the GO button for 5 seconds. I saw a manually assigned IP of 192.168.1.90. I removed the WSD printer assuming I could easily add it back. But, alas, I wasn't able to. I tried adding the printer using the standard IP address, but no matter what I tried printing, it would print each page multiple times and never stop. So, If I tried to print 1 copy of a 1 page notebook test document, it would continue printing the one page over and over again until someone kills the job.

I looked at another computer that has the same WSD port setup w/ this printer. Hers printed just fine. But, again, I couildn't find any IP address. I tried all kinds of things with no luck. I tried adding the printer as a WSD thru add printer (windows 7) and it never did work.

I'm not familiar with WSD and couldn't find much information that really helped me to understand how to use it. I couldn't find any installed application or service with that name either.

I hooked up the printer locally via usb cable for now.

Any help or insight is greatly appreciated.

BC AdBot (Login to Remove)

 


#2 The_Outkast

The_Outkast

  • Members
  • 161 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ft. Wayne, IN
  • Local time:05:23 AM

Posted 17 July 2012 - 05:35 PM

Try the following:

-Open Computer
-Click Network
-Right click the printer and select install

If you happen to see Uninstall instead of Install, select it, then try again to install it.

#3 coxchris

coxchris

  • Members
  • 1,151 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Atwater
  • Local time:01:23 AM

Posted 17 July 2012 - 07:16 PM

Are you assigning it to a TCP/IP port address of 192.168.1.90 via RAW IP scheme

Instructions for Manual IP Address http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=ca&taskId=115&prodSeriesId=3662025&prodTypeId=18972&prodSeriesId=3662025&objectID=c01720269

Or you can try sharing the printer through a local host

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=ca&taskId=115&prodSeriesId=3662025&prodTypeId=18972&prodSeriesId=3662025&objectID=c02171232

reference links home page is http://h20000.www2.hp.com/bizsupport/TechSupport/SupportTaskIndex.jsp?lang=en&cc=ca&taskId=115&prodSeriesId=3662025&prodTypeId=18972&supportTaskId=43364

http://msdn.microsoft.com/en-us/library/windows/desktop/bb756908.aspx WSD inforrmation

I never heard of WSD services before. My school district has a print sever. I use RAW TCP/IP addressing that normally works.

Hope its help some.

If you having trouble with 45 min wait times try resetting the Print Spooler device

Edited by coxchris, 17 July 2012 - 07:20 PM.

AA in Computer Networking Technology

BS in Information Technology 

Comptia A+, Project+, L+

Renewable:  N+,S+

CIW Web Design Specialist, JavaScript Specialist,  Database Design Specialist 

LPIC-1, SUSE 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users