Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Autocheck Boot Time Problem


  • Please log in to reply
69 replies to this topic

#1 Seemos Yantra

Seemos Yantra

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Chorrillos, Lima
  • Local time:03:52 PM

Posted 04 July 2012 - 05:20 PM

Hello, and thanks in advance for taking your time reading. My main problem passed undetected until now, in which I tried playing a game which normally runs softly, but now was all choppy. Normally, when I have similar problems, I run a defrag, clean my temporals, and run a boot-time CHKDSK, after which things are normally back to good as new. Nevertheless, I found out I COULDN'T do it this time. Each time I programmed the boot-time CHKDSK, I rebooted and it would not even show the bluescreen, it would simply skip directly to WindowsXP. The problem is on my C drive, which is my system drive (hence the need for the boot CHKDSK). My computer is an AMD Phenom II X2 550 at 3.11GHz, with 3GB RAM, and 2 500GB hard disks. I'm running Windows XP Service Pack 3 with COMODO Internet Security as it's main firewall/antivirus. I didn't had any similar problem since it's very installation, more than a year ago.

The registry entry says:
BootExecute RE_MULTI_SZ autocheck autochk /p \??\C: autocheck autochk*

In advance, thanks for reading. Any help will be much appreciated.
PD: I already tried the fsutil command and it marks no errors. I can defrag normally my hardrive. I also tried the sfc command with no luck either.

*Moderator Edit: Moved topic from XP to AII at the request of Allan. ~ Queen-Evie*

Edited by Queen-Evie, 05 July 2012 - 06:02 PM.


BC AdBot (Login to Remove)

 


#2 Allan

Allan

  • BC Advisor
  • 8,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:04:52 PM

Posted 04 July 2012 - 05:27 PM

please boot to the recovery console and run chkdsk /r

Edited by Allan, 04 July 2012 - 05:27 PM.


#3 Seemos Yantra

Seemos Yantra
  • Topic Starter

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Chorrillos, Lima
  • Local time:03:52 PM

Posted 04 July 2012 - 07:14 PM

please boot to the recovery console and run chkdsk /r

Done. I had to install the Recovery Console in order to use it, but I managed to. The CHKDSK process took a lot (at a moment, it even rolled back to 50%, but then advanced slowly back to 72% and then blinked to 100%) but it worked, apparently. The final report simply stated that some errors had been found and fixed, but nothing more. What's next? Should I test if the function is restored or is it any other step I should take?

PD: In advance, thanks.

#4 Allan

Allan

  • BC Advisor
  • 8,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:04:52 PM

Posted 05 July 2012 - 06:53 AM

Chkdsk /r runs 5 tests and each one will reset to zero and then show progress. It should always be allowed to complete and should never be interrupted (you did fine, just making sure you understand for future reference).

Is autocheck still trying to run on boot now?

#5 Seemos Yantra

Seemos Yantra
  • Topic Starter

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Chorrillos, Lima
  • Local time:03:52 PM

Posted 05 July 2012 - 10:44 AM

Chkdsk /r runs 5 tests and each one will reset to zero and then show progress. It should always be allowed to complete and should never be interrupted (you did fine, just making sure you understand for future reference).

Is autocheck still trying to run on boot now?

Tested: failed. I tried programming the autocheck to realize the boot time CHKDSK once more. No use. It would skip the procedure completely (no error messages like "Disck Locked" or stalling or anything, is simply like I never programmed it).

#6 Allan

Allan

  • BC Advisor
  • 8,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:04:52 PM

Posted 05 July 2012 - 11:15 AM

I don't understand your post, sorry.

Edited by Allan, 05 July 2012 - 11:15 AM.


#7 Seemos Yantra

Seemos Yantra
  • Topic Starter

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Chorrillos, Lima
  • Local time:03:52 PM

Posted 05 July 2012 - 11:24 AM

I don't understand your post, sorry.

Okay. Step by step:
1) The problem was that I CAN'T program boot time CHKDSK. I go to My Computer, my C: drive (which is my system drive), right click on it get to the menu Properties, and then into the tab TOOLS. There I try to program for CHKDSK to run, but the system says it can't be done because some files are in use and the system needs to execute the CHKDSK during boot-time (which, I know, is normal). It asks me if I want to schedule the procedure for the next reboot, to which I say YES. SO, I reboot the system, but CHKDSK is NEVER executed. It should appear just after the "Welcome To Microsoft Windows XP" splash screen with the moving bar, but instead simply proceeds to load the system normally, like I had never programmed it.

2) I tried all what you told me to do. It all worked nicely and it appeared to solve things (according to it's main report), but I still can't program CHKDSK to work on boot time.

Am I not making myself clear? Please, let me know if I am missing some particular detail. I might not be tech as tech savvy as I would like, but I am no 0 ground beginner either. In advance, thanks, and sorry if I come out as rude by any mean, not my intention at all.

#8 Allan

Allan

  • BC Advisor
  • 8,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:04:52 PM

Posted 05 July 2012 - 11:28 AM

To schedule checkdisk to run on the next boot do the following:

right-click on a command prompt icon and open as administrator. In the command prompt window type: chkdsk /r (then press ENTER). You'll be told the disk is in use and asked if you want to run checkdisk on the next boot. Say yes, exit the command prompt window, and reboot.

#9 Seemos Yantra

Seemos Yantra
  • Topic Starter

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Chorrillos, Lima
  • Local time:03:52 PM

Posted 05 July 2012 - 11:38 AM

To schedule checkdisk to run on the next boot do the following:

right-click on a command prompt icon and open as administrator. In the command prompt window type: chkdsk /r (then press ENTER). You'll be told the disk is in use and asked if you want to run checkdisk on the next boot. Say yes, exit the command prompt window, and reboot.

Just did exactly as you asked me.
1) Went to START, RUN, typed CHKDSK /r.
2) A CMD window with DOS text appeared saying the same about the disk being in use and asking me to schedule the CHKDSK for boot time. I answered YES.
3) I rebooted.
4) This time, after the splash screen, the blue screen that normally appears when CHKDSK is about to execute appeared, but it reported "Cannot open the volume for direct access" and, after a few seconds, it proceeded to load the system normally.

What do we do now?

#10 Allan

Allan

  • BC Advisor
  • 8,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:04:52 PM

Posted 05 July 2012 - 12:28 PM

That is not what I suggested you do. I said nothing about "start - run". You need to open a command prompt as administrator. You can find a command prompt in Start - Programs - Accessories. When you find it, RIGHT CLICK on it and run as administrator. Then do the rest.

#11 Seemos Yantra

Seemos Yantra
  • Topic Starter

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Chorrillos, Lima
  • Local time:03:52 PM

Posted 05 July 2012 - 12:44 PM

That is not what I suggested you do. I said nothing about "start - run". You need to open a command prompt as administrator. You can find a command prompt in Start - Programs - Accessories. When you find it, RIGHT CLICK on it and run as administrator. Then do the rest.

Fine. Did as you told me.
1) Opened the CMD, executed it as the main Administrator account (inputed my password on it).
2) Typed the CHKDSK /r command. It displayed the next (I'm translating from spanish because my OS is in spanish) :

The file system type is NTFS.
The actual volume cannot be locked.

CHKDSK can't be run due other process using the volume. Would you like this volume to be checked in the next reboot? (Y/N) y

This volume will be check during the next system reboot.


3) I am proceeding to reboot in this instant.

#12 Allan

Allan

  • BC Advisor
  • 8,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:04:52 PM

Posted 05 July 2012 - 12:47 PM

Again, you are not following instructions at all. I'll try one more time. If chkdsk did not run on the reboot please follow these instructions EXACTLY:

Right-click on a command prompt icon and click on RUN AS ADMINISTRATOR. In the command prompt window type: chkdsk /r (then press ENTER). You'll be told the disk is in use and asked if you want to run checkdisk on the next boot. Say yes, exit the command prompt window, and reboot.

Edited by Allan, 05 July 2012 - 12:49 PM.


#13 Seemos Yantra

Seemos Yantra
  • Topic Starter

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Chorrillos, Lima
  • Local time:03:52 PM

Posted 05 July 2012 - 01:00 PM

Again, you are not following instructions at all. I'll try one more time. If chkdsk did not run on the reboot please follow these instructions EXACTLY:

Right-click on a command prompt icon and click on RUN AS ADMINISTRATOR. In the command prompt window type: chkdsk /r (then press ENTER). You'll be told the disk is in use and asked if you want to run checkdisk on the next boot. Say yes, exit the command prompt window, and reboot.

Well, is exactly what I did:
1) START, ALL PROGRAMS, ACCESORIES, COMMAND PROMPT. Right clicked on it, runned it as the very and ONLY account that exists on this computer which is the Administrator one (there aren't ANY other accounts, not even selectable). I putted my password, and the DOS box (titled Command Prompt) appeared. I then typed the command you asked me. I DID exactly as you asked me down to the point.
2) I rebooted.
3) The result was exactly the same: it appears as the CHKDSK is about to execute, but it reports this:
The fyle system type is NTFS.
Windows is about to check the C: volume...
Cannot gain direct access to the volume.
Windows scandisk is terminadted.


(I might have commited a bit of an incosistence in the last line there because the messages appears way too briefly before it proceeds to continue loading the system normally, but it is more or less what it says on the blue screen during the event).

I'm doing exactly as you ask me, following you the most I can based on the small information you give me. I apologize in case I am making you loose your temper, I imagine you must be stressed. So AM I, but I am trying to help you help me, and I thank you in advance for taking your time. So, please, let's continue. What's next?

Edited by Seemos Yantra, 05 July 2012 - 01:01 PM.


#14 Allan

Allan

  • BC Advisor
  • 8,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:04:52 PM

Posted 05 July 2012 - 01:02 PM

I'm sorry, but you are not following the instructions. When you right click on the command prompt a context menu will open. One of the choices in that context menu is "Run As Administrator". I want you to choose that option.

#15 Seemos Yantra

Seemos Yantra
  • Topic Starter

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Chorrillos, Lima
  • Local time:03:52 PM

Posted 05 July 2012 - 01:20 PM

I'm sorry, but you are not following the instructions. When you right click on the command prompt a context menu will open. One of the choices in that context menu is "Run As Administrator". I want you to choose that option.

I AM following you, and since it seems you do not take my word for it, I am showing you with screenshots, STEP BY STEP.

1) I RIGHT clicking Command Prompt as you asked me in the RUN AS option of the context menu:

Posted Image

2) Then I am presented with THIS box. As you can see in both images, my account is the MAIN administrator account. There are no others even if I show the roll down menu in the lower part. See? :

Posted ImagePosted Image

3) Then I proceed to do as you ask me, by typing the command and scheduling the scan, as you can see here:

Posted Image

I can't take an screenshot of what happens during the blue screen due obvious reasons, but I can take a picture with my cellphone if you need it. Now, do you SEE I am doing exactly as you ask me?

So, now, please, can we continue?
PD1: if I try the "Actual Account" that is listed by default, then the message on the Command Prompt after trying to input the command is "Access Denied". Hence why I choose the second option where I am asked to input my password.
PD2: Yes, after it, I rebooted the system and the very same message appeared about Windows not being able to gain direct access to the volume.

Edited by Seemos Yantra, 05 July 2012 - 01:28 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users