Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Dell XPS630 BIOS ACPI Problem


  • Please log in to reply
1 reply to this topic

#1 BrianBuilds

BrianBuilds

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:07:45 AM

Posted 30 June 2012 - 11:34 PM

Hi guys, originally posted this in a XPS 630 forum, but it's pretty dead over there, so I tried another tech forum online, but surprisingly no one has responded in a few days. I will copy and paste my previous posts. System specs up first:

Dell XPS 630i refurbished
Q6600 @ 2.4 GHz (stock)
6gb RAM (2gb OEM + 4gb added)
1x 8800 GT (OEM)
300gb OEM HD (XP - stock)
1TB Samsung HD (Win7 Pro SP1)

2 days ago I turned my computer off properly before going out. A few hours later I'm back and try to start it up, but pressing the power button does nothing. All I hear is clicks.

From this thread (http://www.my630i.com/viewtopic.php?f=61&t=4521) I diagnosed it as a bad PSU. Seems likely because now that I've learned that leaving it unplugged for about 5 mins (drain the capacitors?) will start it up. I've ordered a Corsair TX750m from Tiger as a replacement (Great price btw, around $55 after a $20 rebate, even without the rebate it seems like a great price).

The real problem is that the PSU and/or my troubleshooting might have caused a whole new strain of problems. If I'm remembering this correctly, whenever I try to boot into my Win 7 HD, the hard drive is detected but it says there is no boot device. I believe it's the same with the XP HS too. Then I burned a Win7 recovery disc from a different computer, and it gave me a screen saying "Windows failed to load because the firmware (BIOS)is not ACPI compatible." (same screen as http://www.my630i.com/viewtopic.php?f=3&t=2828). I've tried resetting to default, as well as both ACPI Suspend types (S3 STR and S1 POS). I reseated the BIOS battery earlier in my trouble shooting, which maybe have introduced the problem.

My memory might be playing with me here but I believe if I have the disc in, I get the ACPI error, and if the optical drive is empty, it just leaves me with a flashing dash or underscore.

I pulled the Win7 HD and plugged it in another of my computers and it wouldn't boot there either. Threw the recovery CD in that computer and I believe it didn't even sense the disc in at all (an old junker Dimension E510 btw).

Could this all relate to the PSU, or is there a deeper problem going on? I feel like my windows installations might have been compromised, hence trying the recovery CD, but maybe there's something I haven't seen before that's happening.

I apologize for any vagueness, there were a lot of different steps I took, and its pretty late here now, so I might have confused some results or forgotten some. Thanks in advance for any help!

EDIT: I'm pretty sure I have the up-to-date BIOS, 1.0.13 IIRC.

EDIT EDIT: Retested booting the drives. Boot order in BIOS is the Samsung 1TB with Win7, followed by OEM 300gb with XP, followed by optical and then the USB stuff. Here's the exact results.

Win7 HD, WinXP both attached, no disc in disc-drive: flashing underscore on black screen

Win7 attached, no disc in disc-drive: flashing underscore on black screen

WinXP attached, no disc in disc-drive: flashing underscore on black screen

Win7 HD, WinXP both attached, Win7 recovery disc in drive: says "Windows loading files" with white bar, then gives the ACPI error screen

WinXP attached, Win7 recovery disc in drive: gives a selection screen that lets me select Windows Setup (or Installation, I don't remember exactly) or Memory Diagnostic (using TAB), then after selecting the Setup/Installation, has "Windows loading files" with white bar, then gives the ACPI error screen

Either both hard drives got messed up, or there's something off with the BIOS or mobo. I'm now considering building a new PC but I'm worried I still won't be able to boot into the Windows drives with other new components. New PSU is scheduled to arrive Friday, will see if that changes anything.

Edit: Received same PSU, but with that, the problems persist.

Thanks in advance for the help guys! :thumbsup:

BC AdBot (Login to Remove)

 


#2 BrianBuilds

BrianBuilds
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:07:45 AM

Posted 10 July 2012 - 12:44 AM

I now suspect Bootloader/MDR (not exactly sure what they are) problems. Would they cause the BIOS ACPI problems? Could anyone guide me through repairing those? I know i previously used EASYBCD to modify boot order and such, could I also get help in repairing the BCD? I really still don't know the problem.

Please and thanks for the help! :lol:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users