Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

MBR Fraged Passed; Memory tests


  • Please log in to reply
1 reply to this topic

#1 slo412

slo412

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:06:39 AM

Posted 29 June 2012 - 05:29 AM

Ok I was asked to look at a computer for my Grandfather. It is several years old but still wrapped up. He turned it on once and it failed to boot up and he didn't do anything to fix it. That is the story I got. Using my own equipment I have tested and confirmed that everything is working up to the HDD. I swapped my laptop HDD for the one installed and was able to boot up and use the computer normally. The HDD is a Seagate Momentum 5400.5 (http://www.seagate.com/docs/pdf/datasheet/disc/ds_momentus_5400_5.pdf) PDF of manual, in case that helps. So I grabbed my windows 7 install disk to try a recovery on it. That is how I found out the Master Boot Record is toast. So I tried the auto fix in the recovery console and no joy. I got into the BIOS again and confirmed that the drive is detected I ran the memory checking tool included on the windows 7 install disk and got a clean scan. I also tried the basic bootrec.exe /fixmbr from the command prompt. Still getting the message that the drive is not a bootable drive. I don't have a USB shell that will work with this type of drive either. Honestly I think that I am just so frustrated that I cannot think of a solution. Does anyone know of a USB bootable that will perform a low level format repair the partition and over-write/repair the MBR, heck even something that will be able to repair the MBR from a bootable USB... I have already tried Seatools Diskwizard no joy there. I have considered MBRWizard but I have no experience with it. Any ideas or suggestions would be appreciated.

http://support.acer.com/acerpanam/notebook/0000/Acer/Aspire5516/Aspire5516sp2.shtml

Computer Specs.

limited info obviously since I cannot boot the drive at all.

Thanks in Advance for any help anyone can give

BC AdBot (Login to Remove)

 


#2 AustrAlien

AustrAlien

    Inquisitor


  • Members
  • 6,772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cowra NSW Australia
  • Local time:12:39 AM

Posted 29 June 2012 - 06:45 AM

Let's have a look see ...

You will need a USB hard drive or flashdrive.

:step1: Download http://unetbootin.sourceforge.net/unetbootin-xpud-windows-latest.exe
and http://noahdfear.net/downloads/bootable/xPUD/xpud-0.9.2.iso to the desktop of a working computer:
  • Insert a USB flashdrive.
  • Go to Start > My Computer > right-click on the flashdrive > choose Format > Quick format.
  • Double-click the unetbootin-xpud-windows-387.exe that you just downloaded.
  • Click Run > OK.
  • Select the DiskImage option and then click the browse button located on the right side of the text-box field.
  • Browse to and select the xpud-0.9.2.iso file that you downloaded.
  • Verify the correct drive letter is selected for your flashdrive, and then click OK.
    A small bootable Linux operating system will be installed on the flashdrive.
  • Once the files have been written to the device, you will be prompted to reboot: Do not reboot the computer.
    • Instead, just exit the UNetbootin interface (simply close the installer).
  • Remove the flashdrive from the computer.
You will use this flashdrive to boot the ailing computer from.


:step2: Boot the ailing computer with the xPUD flashdrive.
  • (You may have to configure the Boot Menu or BIOS Setup Menu to boot first from the flashdrive/USB HDD.)
    A Welcome to xPUD screen will appear.
  • Click on File.
  • Expand the mnt icon on the left (click on the little arrow beside the icon).
    • sda1, sda2 etc. ...usually correspond to your HDD partitions
    • sdb1, sdc1 is likely to correspond to a USB flashdrive, external USB hard drive etc.
      Note: It may happen that after booting to xPUD on a flashdrive and then looking for the flashdrive, you are not able to find it anywhere. If this happens, simply unplug the flashdrive, wait briefly and then re-plug it back into the system, and it should now show up.
  • Click on the folder that represents your USB drive (sdb1 ?).
  • Click Tool on the top menu, and choose Open Terminal.
  • Type the following at the hash prompt:

    dd if=/dev/sda of=mbr.bin bs=512 count=1

    • Note: Leave a space between the following:
      • dd ... the executable application used to create the backup
      • if=/dev/sda ... the device the backup is created from (the hard drive when only one HDD exists)
      • of=mbr.bin ... the backup file to create - note the lack of a path - it will be created in the directory currently open in the Terminal
      • bs=512 ... the number of bytes in the backup
      • count=1 ... says to backup just 1 sector
        It is extremely important that the if and of statements are correctly entered.
  • Press the <ENTER> key.
    After it has finished a file will be located on your USB drive named mbr.bin.
  • Go to Home > Power Off > Turn Off and remove the flashdrive as the system shuts down.

:step3: On the working computer:
  • Insert the flashdrive, and navigate to the file mbr.bin
  • Zip-up the mbr.bin file:
    • Right-click on the file and choose Send to .. > Compressed (zipped) Folder.
      A zipped folder will appear in the same location as the mbr.bin file.
  • Please attach the zipped file to your next reply.
    This will allow the MasterBootRecord of your hard drive to be checked to see whether or not it is infected &/or damaged.

Edited by AustrAlien, 29 June 2012 - 06:51 AM.

AustrAlien
Google is my friend. Make Google your friend too.

Posted Image




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users