Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Frequent Black Screen Crashes while Web Browsing, Gaming


  • Please log in to reply
13 replies to this topic

#1 Octanion

Octanion

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:05:01 PM

Posted 20 June 2012 - 11:20 AM

I have recently been experiencing frequent black screen crashes while web browsing and when launching games on my laptop.

Example 1:
Browsing through mountandblade.wikia.com
Scrolling down, Screen immediately turns black
Music from my music player is still playing
Sound finally fails after 9-10 seconds
Only way out is from a hard reboot

I have experienced this on both Firefox and IE.
Another case was when I at youtube.com, black screen crash suddenly occurs as I was typing in the search box and suggestion prompts start showing up.

Also, when launching games such as Warcraft III and Guild Wars, my laptop immediately black screen crashes.
I see the starting menu for possibly 1 frame, then the display fails.
However, I have no problem launching older games, such as HoMM 3. (I am unsure if the game failures and the web browsing failures are related.)

I am running on XP service pack 3. Windows updates have been set to automatic so I believe they are reasonably up to date.

The video card in my laptop is a ATI Mobility Radeon X1400.
I have reinstalled the graphics drivers as follows but the crashes persist:
-Uninstall drivers via Control Panel
-Reboot in safe mode and ran Driver Cleaner Pro to remove all ATI files
-Reboot and reinstall drivers, then reboot again.

I also ran a memory diagnostic tool, memtest86+ v4.20 overnight.
10 passes were completed after eight hours but no errors were detected.

I have also uninstalled Flash player as per the instructions on: http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.htm
Then reinstalled it, but to no avail.

After doing a hard reboot from such crashes, I would take a look at the Event Viewer, hoping to pick up some sort of error that corresponded to the crash. Browsing through all the categories, there were no events that matched the time of when the black screen crashes occurred. However, there is always an event on system starts after the crash. It is as follows:

The computer has rebooted from a bugcheck. The bugcheck was: 0x00000050 (0xfffa268f, 0x00000000, 0xf7487deb, 0x00000000). A dump was saved in: C:\WINDOWS\MEMORY.DMP.

The last three values within the parenthesis are always consistent, but the first value varies between the crashes. Below is another report from a similar crash:

The computer has rebooted from a bugcheck. The bugcheck was: 0x00000050 (0xffa0468f, 0x00000000, 0xf7487deb, 0x00000000). A dump was saved in: C:\WINDOWS\MEMORY.DMP.


Any help will be greatly appreciated! :)

BC AdBot (Login to Remove)

 


#2 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:09:01 AM

Posted 20 June 2012 - 11:41 AM

We need to know more about your BSODs...

Download BlueScreenView (in Zip file)

No installation required.

Unzip downloaded file and double click on BlueScreenView.exe file to run the program and When scanning is done, go to Edit > Select All.

Then go to File > Save Selected Items, and save the report as BSOD.txt.

Open BSOD.txt in Notepad, copy all content, and paste it into your next reply.

Compliments of Broni


Also:

Please perform the following, so that we can get the exact specs of your computer. This will better assist us in helping you more.

Publish a Snapshot using Speccy

The below is for those who cannot get online

Please take caution when attaching a text file to your post if you cannot copy/paste the link to your post, you will need to edit it to make sure that your Windows Key is not present.

#3 Octanion

Octanion
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:05:01 PM

Posted 22 June 2012 - 01:53 AM

I realized my system was saving full dumps instead of mini-dumps. I rectified that and proceeded to cause a couple of crashes. The first crash was from launching a game; the next three are from web browsing.
BSOD.txt as below:

==================================================
Dump File : Mini062212-03.dmp
Crash Time : 6/22/2012 2:41:51 PM
Bug Check String : PAGE_FAULT_IN_NONPAGED_AREA
Bug Check Code : 0x10000050
Parameter 1 : 0xffe0d5eb
Parameter 2 : 0x00000000
Parameter 3 : 0xf7317deb
Parameter 4 : 0x00000000
Caused By Driver : pci.sys
Caused By Address : pci.sys+deb
File Description : NT Plug and Play PCI Enumerator
Product Name : Microsoft® Windows® Operating System
Company : Microsoft Corporation
File Version : 5.1.2600.5512 (xpsp.080413-2111)
Processor : 32-bit
Crash Address : pci.sys+deb
Stack Address 1 : pci.sys+3c28
Stack Address 2 : pci.sys+323
Stack Address 3 : VIDEOPRT.SYS+11a2
Computer Name :
Full Path : C:\WINDOWS\Minidump\Mini062212-03.dmp
Processors Count : 2
Major Version : 15
Minor Version : 2600
Dump File Size : 98,304
==================================================

==================================================
Dump File : Mini062212-02.dmp
Crash Time : 6/22/2012 2:32:04 PM
Bug Check String : PAGE_FAULT_IN_NONPAGED_AREA
Bug Check Code : 0x10000050
Parameter 1 : 0xffcbbae3
Parameter 2 : 0x00000000
Parameter 3 : 0xf7317deb
Parameter 4 : 0x00000000
Caused By Driver : pci.sys
Caused By Address : pci.sys+deb
File Description : NT Plug and Play PCI Enumerator
Product Name : Microsoft® Windows® Operating System
Company : Microsoft Corporation
File Version : 5.1.2600.5512 (xpsp.080413-2111)
Processor : 32-bit
Crash Address : pci.sys+deb
Stack Address 1 : pci.sys+3c28
Stack Address 2 : pci.sys+323
Stack Address 3 : VIDEOPRT.SYS+11a2
Computer Name :
Full Path : C:\WINDOWS\Minidump\Mini062212-02.dmp
Processors Count : 2
Major Version : 15
Minor Version : 2600
Dump File Size : 98,304
==================================================

==================================================
Dump File : Mini062212-01.dmp
Crash Time : 6/22/2012 1:42:36 PM
Bug Check String : PAGE_FAULT_IN_NONPAGED_AREA
Bug Check Code : 0x10000050
Parameter 1 : 0xffc5dae3
Parameter 2 : 0x00000000
Parameter 3 : 0xf7317deb
Parameter 4 : 0x00000000
Caused By Driver : pci.sys
Caused By Address : pci.sys+deb
File Description : NT Plug and Play PCI Enumerator
Product Name : Microsoft® Windows® Operating System
Company : Microsoft Corporation
File Version : 5.1.2600.5512 (xpsp.080413-2111)
Processor : 32-bit
Crash Address : pci.sys+deb
Stack Address 1 : pci.sys+3c28
Stack Address 2 : pci.sys+323
Stack Address 3 : VIDEOPRT.SYS+11a2
Computer Name :
Full Path : C:\WINDOWS\Minidump\Mini062212-01.dmp
Processors Count : 2
Major Version : 15
Minor Version : 2600
Dump File Size : 98,304
==================================================

==================================================
Dump File : Mini062112-01.dmp
Crash Time : 6/21/2012 4:46:54 PM
Bug Check String : PAGE_FAULT_IN_NONPAGED_AREA
Bug Check Code : 0x10000050
Parameter 1 : 0xfff7cae3
Parameter 2 : 0x00000000
Parameter 3 : 0xf7317deb
Parameter 4 : 0x00000000
Caused By Driver : pci.sys
Caused By Address : pci.sys+deb
File Description : NT Plug and Play PCI Enumerator
Product Name : Microsoft® Windows® Operating System
Company : Microsoft Corporation
File Version : 5.1.2600.5512 (xpsp.080413-2111)
Processor : 32-bit
Crash Address : pci.sys+deb
Stack Address 1 : pci.sys+3c28
Stack Address 2 : pci.sys+323
Stack Address 3 : VIDEOPRT.SYS+11a2
Computer Name :
Full Path : C:\WINDOWS\Minidump\Mini062112-01.dmp
Processors Count : 2
Major Version : 15
Minor Version : 2600
Dump File Size : 98,304
==================================================

Also as requested, the Speccy snapshot of my system: http://speccy.piriform.com/results/ZH2e1240qKuOp27h26UkXOE

#4 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:09:01 AM

Posted 22 June 2012 - 11:45 AM

Have you tried making sure that all your drivers are updated?

#5 Octanion

Octanion
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:05:01 PM

Posted 22 June 2012 - 02:46 PM

I have updated my sound and display drivers as much as I am able to.

The sound driver I am currently using is Realtek High Definition Audio, dated 3/27/2012. The driver version is 5.10.0.6602
I had uninstalled the previous older driver through the control panel before I updated to this current one.

The display driver, on the other hand, is quite dated, as is the video card that I am using, ATI Mobility Radeon X1400.
The last drivers released by Toshiba, the manufacturer of this laptop, was in 2006.
I am currently using Radeon Omega Drivers v4.8.442, dated 12/5/2007, from www.omegadrivers.net This driver seems to be the one that is widely recommended by other users of the mentioned graphics card. The main reason I am using it is because I am unable to find any drivers that are more recently released.

These are the only 2 drivers that I have kept up to date. Might there be other drivers that I should take a look at?

Edited by Octanion, 22 June 2012 - 02:55 PM.


#6 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:09:01 AM

Posted 23 June 2012 - 01:30 PM

you might want to check for chipset drivers, and have you tried these: http://support.amd.com/us/gpudownload/windows/Legacy/Pages/radeonaiw_xp.aspx?type=2.4.1&product=2.4.1.3.13&lang=English

#7 Octanion

Octanion
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:05:01 PM

Posted 23 June 2012 - 02:19 PM

Thank you for the link to the ATI Legacy Display Driver v10.2
After downloading the installation package and running it, I am told that there were no drivers found that supports my graphics card. Logically, this is so since ATI Radeon X1400 was not listed under the list of supported cards.
Using Mobility Modder (from http://www.hardwareheaven.com/modtool.php), I was then able to install the drivers that came with the Legacy pack.
I am now running the Legacy drivers v10.2.

However, I am still getting the same black screen crashes as before.

Also, I am unsure of how to look for chipset drivers.

#8 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:09:01 AM

Posted 23 June 2012 - 02:33 PM

Check here: http://www.intel.com/p/en_US/support/highlights/chpsts/945m and if that doesnt solve the issue, then its time to buy another lap top.

#9 Octanion

Octanion
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:05:01 PM

Posted 26 June 2012 - 02:12 PM

The most recent drivers relevant to my chipset that I could find was: http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=20775&ProdId=816&lang=eng&OSVersion=Windows%20XP%20%20*&DownloadType=Drivers
I downloaded and installed it.
After a reboot I checked device manager to take a look at which drivers were updated. I found that these were the only devices that had updated drivers:
Intel ICH7M/U LPC Interface Controller
Intel N10/ICH7 Family PCI Express Root Port
Intel N10/ICH7 Family SMBus Controller
The drivers for these were updated to version 9.1.1.1016

I continued to experience the same black screen crashes despite the chipset driver update.
From the Blue Screen viewer, I can see that the PCI.SYS driver associated with the crash had the version number of 5.1.2600.5512 instead of the newer one. Can this be of any help to the diagnosis? I'm hoping I can leave buying a new laptop as the very last resort.


Edit: I am unable to find any drivers with a version number of 5.1.2600.5512 in my device manager. There are a handful of motherboard related devices with a version number of 5.1.2600.2180, though.

Edited by Octanion, 26 June 2012 - 02:21 PM.


#10 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:09:01 AM

Posted 26 June 2012 - 06:33 PM

Can you right click on the device in device manager then go to properties then the details tab and select hardware id's and post that?

#11 Octanion

Octanion
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:05:01 PM

Posted 27 June 2012 - 02:15 PM

The following are the hardware IDs for "Intel® 82801 PCI Bridge - 2448":
PCI\VEN_8086&DEV_2448&SUBSYS_00000000&REV_E2
PCI\VEN_8086&DEV_2448&SUBSYS_00000000
PCI\VEN_8086&DEV_2448&REV_E2
PCI\VEN_8086&DEV_2448
PCI\VEN_8086&DEV_2448&CC_060401
PCI\VEN_8086&DEV_2448&CC_0604

The following are the hardware IDs for "Intel® 82802 Firmware Hub Device":
ACPI\INT0800
*INT0800

The following are the hardware IDs for "Intel® ICH7M/U LPC Interface Controller - 27B9":
PCI\VEN_8086&DEV_27B9&SUBSYS_00000000&REV_02
PCI\VEN_8086&DEV_27B9&SUBSYS_00000000
PCI\VEN_8086&DEV_27B9&REV_02
PCI\VEN_8086&DEV_27B9
PCI\VEN_8086&DEV_27B9&CC_060100
PCI\VEN_8086&DEV_27B9&CC_0601

The following are the hardware IDs for "Intel® N10/ICH7 Family PCI Express Root Port - 27D0":
PCI\VEN_8086&DEV_27D0&SUBSYS_00000000&REV_02
PCI\VEN_8086&DEV_27D0&SUBSYS_00000000
PCI\VEN_8086&DEV_27D0&REV_02
PCI\VEN_8086&DEV_27D0
PCI\VEN_8086&DEV_27D0&CC_060400
PCI\VEN_8086&DEV_27D0&CC_0604

The following are the hardware IDs for "Intel® N10/ICH7 Family PCI Express Root Port - 27D2":
PCI\VEN_8086&DEV_27D2&SUBSYS_00000000&REV_02
PCI\VEN_8086&DEV_27D2&SUBSYS_00000000
PCI\VEN_8086&DEV_27D2&REV_02
PCI\VEN_8086&DEV_27D2
PCI\VEN_8086&DEV_27D2&CC_060400
PCI\VEN_8086&DEV_27D2&CC_0604

The following are the hardware IDs for "Intel® N10/ICH7 Family SMBus Controller - 27DA":
PCI\VEN_8086&DEV_27DA&SUBSYS_FF001179&REV_02
PCI\VEN_8086&DEV_27DA&SUBSYS_FF001179
PCI\VEN_8086&DEV_27DA&CC_0C0500
PCI\VEN_8086&DEV_27DA&CC_0C05

The following are the hardware IDs for "Mobile Intel® 945GM/GU/PM/GMS/940GML/943GML and Intel® 945GT Express Processor to DRAM Controller - 27A0":
PCI\VEN_8086&DEV_27A0&SUBSYS_00000000&REV_03
PCI\VEN_8086&DEV_27A0&SUBSYS_00000000
PCI\VEN_8086&DEV_27A0&REV_03
PCI\VEN_8086&DEV_27A0
PCI\VEN_8086&DEV_27A0&CC_060000
PCI\VEN_8086&DEV_27A0&CC_0600

The following are the hardware IDs for "Mobile Intel® 945GM/GU/PM/GMS/940GML/943GML and Intel®":
PCI\VEN_8086&DEV_27A1&SUBSYS_00000000&REV_03
PCI\VEN_8086&DEV_27A1&SUBSYS_00000000
PCI\VEN_8086&DEV_27A1&REV_03
PCI\VEN_8086&DEV_27A1
PCI\VEN_8086&DEV_27A1&CC_060400
PCI\VEN_8086&DEV_27A1&CC_0604

The following are the hardware IDs for "Motherboard Resources":
ACPI\PNP0C02
*PNP0C02

The following are the hardware IDs for "PCI Bus":
ACPI\PNP0A08
*PNP0A08

#12 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:09:01 AM

Posted 27 June 2012 - 05:27 PM

Which device above does not have the updated drivers?

#13 Octanion

Octanion
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:05:01 PM

Posted 28 June 2012 - 02:07 PM

Only the following four devices had their drivers updated:
Intel ICH7M/U LPC Interface Controller - 27B9
Intel N10/ICH7 Family PCI Express Root Port - 27D0
Intel N10/ICH7 Family PCI Express Root Port - 27D2
Intel N10/ICH7 Family SMBus Controller - 27DA

All other listed devices did not update.

#14 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:09:01 AM

Posted 28 June 2012 - 06:43 PM

Have you checked for any BIOS updates?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users