Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Automatic logon


  • Please log in to reply
9 replies to this topic

#1 jackoff

jackoff

  • Members
  • 44 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:35 PM

Posted 08 June 2012 - 12:17 PM

Previously i clean my computer from some malware.

after remove it successfully my windows has a problem.

when i turn on my computer. it is login to my account automatically without asking any password (it skips welcome screen).

i try to use command "control userpasswords2"

"user accounts" window appears. i check the the box of "Users must enter a username and password to use this computer"

then i restart computer. again my computer try to skip login password and some error shows like attach picture.

all i can do is click ok after that it will show welcome screen.

what happen to my computer? Help me please

Attached Files

  • Attached File  1.jpg   57.85KB   8 downloads


BC AdBot (Login to Remove)

 


#2 The_Outkast

The_Outkast

  • Members
  • 161 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ft. Wayne, IN
  • Local time:06:35 AM

Posted 08 June 2012 - 04:24 PM

I would start by checking the following registry key.

-Open Registry Editor (click Start, click run, type regedit, press enter)
-Browse to the following key- HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
-Look at the value for the item "AutoAdminLogon"
-This value should be set to 0, if it's set to 1, double click the name and enter a value of 0
-Restart your pc and you should be set.

#3 jackoff

jackoff
  • Topic Starter

  • Members
  • 44 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:35 PM

Posted 09 June 2012 - 10:19 AM

thankyou for your advice..

-i look at the value for the item "AutoAdminLogon" it is set to 1
so i change it to 0

-i restart my computer the first times, it goes directly to welcome screen. (so i think my problem is solved)

but after i shutdown my computer and start again (the second times). My attachment picture shows again

so i check my registry at "autoadminlogon". it is reset back to 1 again. ???? why??

Edited by jackoff, 09 June 2012 - 10:21 AM.


#4 The_Outkast

The_Outkast

  • Members
  • 161 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ft. Wayne, IN
  • Local time:06:35 AM

Posted 09 June 2012 - 10:54 AM

Look in that same registry key (HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon) and see if there is an item called DefaultPassword. If there is, right click on the item and select delete. Set the value for AutoAdminLogon back to 0. Also, expand the Winlogon key and you should see a key named AutoLogonChecked. In the right pane, make sure the value for the item (Default) is set to (value not set). To do this, double click the item and just make sure the value data field is empty. Reboot and see if the problem returns.

#5 jackoff

jackoff
  • Topic Starter

  • Members
  • 44 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:35 PM

Posted 11 June 2012 - 11:42 AM

Look in that same registry key (HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon) and see if there is an item called DefaultPassword. If there is, right click on the item and select delete. Set the value for AutoAdminLogon back to 0. Also, expand the Winlogon key and you should see a key named AutoLogonChecked. In the right pane, make sure the value for the item (Default) is set to (value not set). To do this, double click the item and just make sure the value data field is empty. Reboot and see if the problem returns.



there is no DefaultPassword in registry key (HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon)
i expand the winlogon key also key Autologonchecked is not there.

Is there somethings wrong in my registry key??

#6 The_Outkast

The_Outkast

  • Members
  • 161 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ft. Wayne, IN
  • Local time:06:35 AM

Posted 11 June 2012 - 08:28 PM

Do you have any keys listed under the Winlogon Key? If so, what are they?

#7 jackoff

jackoff
  • Topic Starter

  • Members
  • 44 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:35 PM

Posted 11 June 2012 - 10:32 PM

Here is my winlogon key

Attached Files

  • Attached File  1.jpg   223.85KB   5 downloads


#8 The_Outkast

The_Outkast

  • Members
  • 161 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ft. Wayne, IN
  • Local time:06:35 AM

Posted 12 June 2012 - 02:49 PM

This is going to be a little redundant, but do the following and let's see if your settings keep changing back.

-Click Start, and then click Run. In the Open box, type control userpasswords2, and then click OK. In the dialog box that appears, enable Users must enter a user name and password to use this computer check box, and then click OK.

-Click Start, Run and type rundll32 netplwiz.dll,ClearAutoLogon (you may not see anything happen, it's ok)

-Open Registry Editor (Regedit.exe) and navigate to: HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsNT\CurrentVersion\Winlogon, Verify that the DefaultPassword entry is not there and that AutoAdminLogon is set to 0

-Reboot, you should have to enter your password (just as you did last time you changed the registry). Once you're logged in, reboot again and see if you still have to enter your password.

#9 jackoff

jackoff
  • Topic Starter

  • Members
  • 44 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:35 PM

Posted 14 June 2012 - 09:47 PM

This is going to be a little redundant, but do the following and let's see if your settings keep changing back.

-Click Start, and then click Run. In the Open box, type control userpasswords2, and then click OK. In the dialog box that appears, enable Users must enter a user name and password to use this computer check box, and then click OK.

-Click Start, Run and type rundll32 netplwiz.dll,ClearAutoLogon (you may not see anything happen, it's ok)

-Open Registry Editor (Regedit.exe) and navigate to: HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsNT\CurrentVersion\Winlogon, Verify that the DefaultPassword entry is not there and that AutoAdminLogon is set to 0

-Reboot, you should have to enter your password (just as you did last time you changed the registry). Once you're logged in, reboot again and see if you still have to enter your password.



i follow your suggestion first i check "Users must enter a user name and password to use this computer"
i type "rundll32 netplwiz.dll,ClearAutoLogon" -i type it exactly in quote.it gives me error message Attached File  dll.jpg   25.3KB   0 downloads
i set "AutoadminLogon to 0"

i reboot computer five or six times. to make sure that everythings is ok...
eventhough it gives me error message but it's seem everything is OK...... Now...
no more lonon box message annoying me anymore just boot straight to welcome screen ^.^
Thankyou for your kindly help.

#10 The_Outkast

The_Outkast

  • Members
  • 161 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ft. Wayne, IN
  • Local time:06:35 AM

Posted 15 June 2012 - 08:56 AM

Great, glad to hear it's working properly now. :thumbup2:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users