Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

The Recycle Bin on C:\ is corrupt or invalid.


  • Please log in to reply
3 replies to this topic

#1 The Piano Guy

The Piano Guy

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:05:04 AM

Posted 05 June 2012 - 03:58 PM

I have a couple of computers running Windows XP Home that state "The Recycle Bin on C:\ is corrupt or invalid. Do you want to empty the Recycle Bin for this drive?" when the user tries to delete a file.

I have the latest service pack which includes this: http://support.microsoft.com/kb/297760

This worked temporarily, but the problem came back: http://www.kellys-korner-xp.com/regs_edits/restorerecyclebin.reg

Emptying the recycle bin also makes the problem go away, but then it comes back a few days later.

I've tried rd /s c:\recycler and a reboot but as usual the problem came back a few days later.

I heard some viruses mess with the recycle bin but scans with AVG, Housecall, and Malwarebytes turned up clean, and the computers have no other symptoms.

I heard about a corrupt info2 file but that doesn't apply to us because we use NTFS, not FAT32.

We have some machines with the same hardware/software that are not having the problem. On the affected computers, memt86 and chkdsk report no errors.

The software we use is quite usual. Besides Windows XP, we use Microsoft Office, Adobe Creative Suite, Firefox, Thunderbird, and Dymo LabelWriter. We are not using any third-party undelete utility.

If anyone has some advice, I'd appreciate it. Thanks :)

Edited by The Piano Guy, 05 June 2012 - 04:00 PM.


BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 56,284 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:07:04 AM

Posted 05 June 2012 - 04:17 PM

I would try:

a. Running the sfc /scannow command

How To Use Sfc.exe To Repair System Files - http://www.bleepingcomputer.com/forums/topic43051.html

b. Followed by running chkdsk /r.

Louis

#3 Larry D. Lawrence II

Larry D. Lawrence II

  • Members
  • 48 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Evansville, IN
  • Local time:06:04 AM

Posted 05 June 2012 - 04:19 PM

My thought would be trying to run SFC and see what it finds. Most issues that I come accross like this are solved this way, besides it beats the alternitive of a wipe and reload any day.


Link to SFC procedure.
http://www.bleepingcomputer.com/forums/topic43051.html
Larry D. Lawrence II
MCSE, MCP,ACMT, ACTC
Dell, HP, Toshiba, Apple, Lenovo, and IBM Certified Technician

#4 The Piano Guy

The Piano Guy
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:05:04 AM

Posted 10 June 2012 - 02:19 PM

Thanks; I'll give it a shot. I'm not physically near the computer (I have VNC access to it) so will try it next time I'm at that office.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users