Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

'iphlpsvc.dll' is now configuring the network. network configuration lock is held by another application.


  • Please log in to reply
No replies to this topic

#1 tla2k12

tla2k12

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:06:24 PM

Posted 02 June 2012 - 06:47 AM

Hi. I have no more ideas on what to try next. Any help greatly appreciated.

My laptop is running Windows 7 Professional 32bit and is fully patched. The Ethernet adapter (Marvell Yukon 88E8055) is enabled and the wireless adapter (Intel PRO/Wireless 3945ABG) disabled (via software and the hardware switch). Symantec Endpoint Protection provides AV/security (via group policy). It is highly likely the problem was self inflicted and not caused by a virus / malware.

I use the cisco VPN client and wanted to upgrade it (a reinstall may have been sufficient but as I was going to the bother I thought I would upgrade) as I was having some annoying timeouts when using the client immediately after logging into my desktop.

I started by removing the existing (old version 5.0.05.0290). During the removal the screen went black and the laptop was not responding; ie I couldnt get the screen to wake up. I ended up powering off by holding the power button for 5 secs. On reboot, it appeared that the old vpnclient (5.0.05.0290) had been removed and everything else was functioning as normal. So I tried to install the new version (5.0.07.0410).

The vpn setup program gets as far as "Installing Network Components" and produces error "Error 27854. The network configuration lock is held by another application. Close all applications and run Setup again. If this message re-appears after closing all applications, reboot then re-try the install (the application holding the install lock may be hung).". The install is then rolled back.

I noticed that if I try to access the LAN card network properties (ie IPv4 settings) I get the error: "Some of the controls on this property sheet are disabled because one or more other Network proprty sheets are already open. To use these controls, close all these property sheets then reopen this one".

I tried closing all applications, rebooting and installing again but got the same error. I tried a safe mode boot but couldn't install in safe mode. I modified the registry to allow safe mode installs with networking but got the same error. I used msconfig to disable all non-windows provided software on boot and got the same error. I disabled Symantec Endpoint (as much as I could) and got the same error.

I did *lots* of Googling and found lots of references to this type of issue but no good answers. Many of the solutions seemed to involve reinstalling Windows - not a good option for me.

Some of the Google results indicated that the Deterministic Network Enhancer (DNE) part of the VPN client may be the problem. I found a link to DNE and downloaded winfix.exe and dneupdate.msi (32 bit) (the msi content was created 15/4/2012 07:11). Running winfix produced an error indicating it couldn't access the network resources (sorry, I don't have a copy of the exact message). Running dneupdate.msi (32 bit) also produced an error "Another application is holding the Network Configuration Lock....".

Some of the Google results indicated removing network adapters might help so, as I couldn't remove the LAN adapter (Marvell Yukon 88E8055), I updated the driver to the latest version (11.45.4.3) and tried to install again with the same results. I deleted all the additional network interfaces I could find (VMware, mobile phone modem and other VPN client interfaces). There is one virtual adapter I cannot remove - "Fujitsu IPCOM SSL-VPN Virtual LAN Adapter". When removing the Fujitsu VPN adapter software it gave some more clues: "iphlpsvc.dll is holding the network configuration lock" and "Install queue is trying to configure the network". Could the IPCOM virtual interface be causing the issue?

winfix.exe now worked as did dneupdate.msi (32 bit). Trying to install the vpn client in normal boot mode still gives me the same error as before "Error 27854. The network configuration lock is held by another application. "... . I also sometimes get "Error 1722. There is a problem with this windows installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor". I went into device manager and found I could uninstall the Fujitsu IPCOM network device / drivers so I uninstalled it and all I have left is the LAN and Wireless adapters.

Note that I can now access the LAN adapter IPv4 properties in safe mode without getting the error about another network properties window being open. I still get the error in a normal mode boot.

I tried using sysinternals procmon to see if I could find the lock but gave up due to having no idea where to look.

I tried installing the vpn adapter in safe mode again and get as far as "Installing Cisco Systems Virtual Adapter" followed by a long pause (several minutes even though the install bar says 4 seconds remain) followed by Error 1722 again. According to the install log, this is:

Action 12:34:37: CsCaExe_VAInstall. Installing Cisco Systems Virtual Adapter...
MSI (s) (A8:F4) [12:34:37:151]: Executing op: CustomActionSchedule(Action=CsCaExe_VAInstall,ActionType=3090,Source=C:\Program Files\Cisco Systems\VPN Client\VAInstaller.exe,Target=nopopup i "C:\Program Files\Cisco Systems\VPN Client\Setup\netcvirta.inf" CS_VirtA,)

The full log files are about 1MB so I can't upload them here. I suspect there is actually nothing wrong with the installer and this is the lock issue again.

I suspect Windows is misreporting that the lock is held because it thinks something is in the "Install queue" trying to configure a network component but have no idea how to clear it. Is there some way I can reset or circumvent this lock to allow the install to complete and access to the adapter network properties via the GUI?

Help! Thanks.

BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users