Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Black Screen after NVIDIA Driver Update


  • Please log in to reply
1 reply to this topic

#1 Coal143

Coal143

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:04:26 PM

Posted 26 May 2012 - 02:34 AM

Hello Everyone!,
I'm Coal143 and a friend of mine has suggested i post my problem on this website after we both came up with nothing despite working on it half a day.

Two days ago, i updated my NVIDIA Drivers to the latest (http://www.nvidia.com/object/notebook-win7-winvista-64bit-301.42-whql-driver.html) Half way through the installation process, the computer screen turned black. Now i didn't think much of it at first and i had to go on my afternoon exercise so i left it there. A few hours later when i came back my screen was still black so i shut my computer down with the power button and restarted it. Everything was working fine the rest of the day. I shut down the computer when i was about to go to sleep, i did see the computer installing a windows update on shutdown, but again thought nothing of it and went to sleep. The next day, after i entered my password and logged on, the computer showed my desktop at a very low resolution for about half a second and then the screen went black. Several restarts later and nothing had changed. I tried a few suggested options i got from searching around on my old laptop but none of them worked. So i booted into safemode and did a system restore. Everything worked fine from then on, like nothing had changed. I noticed that the restore point was set before a "Critical Update" and thought it was mentioned the windows update, So i set windows update to not update unless i told it to. Today, however, The same thing happened. When i logged in, i got a glimpse of a poor resolutioned desktop and then everything went black. I tried system restoring twice before the restore point itself disappeared, no change. I booted up in safe mode and uninstalled my visual driver (what i now think is causing the problem). I can now boot normally fine, so long as i don't have a visual driver installed. However, immediately after i log in, the computer auto-installs the "latest" visual driver and asks me to restart to finish the installation, i can choose restart later, keeping me here. Restarting will just give me the black screen again. Even if i unplug the cable, disable wireless (which i don't even have!) No matter what i do, it automatically installs a driver leaving my plan of installing an older version crushed. If anyone would be able to help, i promise lots of hugs and kisses.

BC AdBot (Login to Remove)

 


#2 JColt

JColt

  • Members
  • 30 posts
  • OFFLINE
  •  
  • Local time:03:26 AM

Posted 26 May 2012 - 06:30 PM

Did you try installing drivers in safe mode? Use previous or beta driver if you do.
http://www.nvidia.com/Download/Find.aspx?lang=en-us




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users