Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

windows update is not working


  • Please log in to reply
15 replies to this topic

#1 jerry1967

jerry1967

  • Members
  • 67 posts
  • OFFLINE
  •  
  • Local time:07:22 AM

Posted 09 November 2004 - 03:59 PM

is anybody else having trouble with windows update? when i go there and click on windows update it goes blank. if anybody knows how to correct this will you please let me know?

BC AdBot (Login to Remove)

 


#2 Grinler

Grinler

    Lawrence Abrams


  • Admin
  • 43,640 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:08:22 AM

Posted 09 November 2004 - 04:05 PM

Nope..no problems here..


Please run two online virus scans:

http://housecall.antivirus.com/
http://www.pandasoftware.com/activescan/

Then let us know if its working better and what the scans found.

#3 jerry1967

jerry1967
  • Topic Starter

  • Members
  • 67 posts
  • OFFLINE
  •  
  • Local time:07:22 AM

Posted 09 November 2004 - 05:32 PM

i ran these scanners and nothing came up. any suggestions?

#4 Grinler

Grinler

    Lawrence Abrams


  • Admin
  • 43,640 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:08:22 AM

Posted 09 November 2004 - 05:36 PM

Create a directory on your hardrive, to save HijackThis.exe, called c:\hijackthis. This is a mandatory step, for the backup and restore functions, of HijackThis, to be able to work.

Download the latest version, from here.

Read the pinned post in the HJT forum, here

Then, run a log, and post it in the HJT forum. Do not fix anything, yet.
A member, of the HJT Team, will help you out.
Please, be patient, these people are volunteers. They will help you out, as soon as possible.

#5 jerry1967

jerry1967
  • Topic Starter

  • Members
  • 67 posts
  • OFFLINE
  •  
  • Local time:07:22 AM

Posted 09 November 2004 - 11:20 PM

Logfile of HijackThis v1.98.2
Scan saved at 11:17:56 PM, on 11/9/2004
Platform: Windows XP SP1 (WinNT 5.01.2600)
MSIE: Internet Explorer v6.00 SP1 (6.00.2800.1106)

Running processes:
C:\WINDOWS\System32\smss.exe
C:\WINDOWS\system32\csrss.exe
C:\WINDOWS\system32\winlogon.exe
C:\WINDOWS\system32\services.exe
C:\WINDOWS\system32\lsass.exe
C:\WINDOWS\system32\svchost.exe
C:\WINDOWS\System32\svchost.exe
C:\WINDOWS\System32\svchost.exe
C:\WINDOWS\System32\svchost.exe
C:\WINDOWS\system32\LEXBCES.EXE
C:\WINDOWS\system32\spoolsv.exe
C:\WINDOWS\system32\LEXPPS.EXE
C:\WINDOWS\System32\alg.exe
C:\PROGRA~1\COMMON~1\aol\ACS\AOLacsd.exe
C:\WINDOWS\system32\cisvc.exe
C:\WINDOWS\System32\CTsvcCDA.exe
C:\Program Files\Common Files\Microsoft Shared\VS7Debug\mdm.exe
C:\WINDOWS\Explorer.EXE
C:\WINDOWS\System32\nvsvc32.exe
C:\WINDOWS\System32\svchost.exe
C:\WINDOWS\wanmpsvc.exe
C:\WINDOWS\System32\MsPMSPSv.exe
C:\WINDOWS\System32\DSentry.exe
C:\Program Files\Common Files\Dell\EUSW\Support.exe
C:\PROGRA~1\mcafee.com\agent\mcagent.exe
C:\PROGRA~1\mcafee.com\vso\mcvsescn.exe
C:\WINDOWS\BCMSMMSG.exe
C:\Program Files\Common Files\Real\Update_OB\realsched.exe
C:\WINDOWS\System32\ctfmon.exe
C:\jerrys\Spy Sweeper\SpySweeper.exe
C:\Program Files\SpywareGuard\sgmain.exe
C:\Program Files\SpywareGuard\sgbhp.exe
c:\PROGRA~1\mcafee.com\vso\mcvsshld.exe
c:\PROGRA~1\mcafee.com\vso\mcvsrte.exe
c:\PROGRA~1\mcafee.com\vso\mcshield.exe
C:\WINDOWS\system32\cidaemon.exe
C:\WINDOWS\system32\cidaemon.exe
C:\Program Files\Dell\Support\bin\ClientApplicationFrameWork.exe
C:\Program Files\America Online 9.0b\waol.exe
C:\Program Files\America Online 9.0b\shellmon.exe
C:\Program Files\Common Files\Aol\aoltpspd.exe
C:\Program Files\Internet Explorer\iexplore.exe
C:\jerrys\HijackThis.exe

O2 - BHO: AcroIEHlprObj Class - {06849E9F-C8D7-4D59-B87D-784B7D6BE0B3} - C:\Program Files\Adobe\Acrobat 5.0\Reader\ActiveX\AcroIEHelper.ocx
O2 - BHO: (no name) - {243B17DE-77C7-46BF-B94B-0B5F309A0E64} - C:\Program Files\Microsoft Money\System\mnyside.dll
O2 - BHO: SpywareGuard Download Protection - {4A368E80-174F-4872-96B5-0B27DDD11DB2} - C:\Program Files\SpywareGuard\dlprotect.dll
O3 - Toolbar: McAfee VirusScan - {BA52B914-B692-46c4-B683-905236F6F655} - c:\progra~1\mcafee.com\vso\mcvsshl.dll
O3 - Toolbar: &Radio - {8E718888-423F-11D2-876E-00A0C9082467} - C:\WINDOWS\System32\msdxm.ocx
O4 - HKLM\..\Run: [NvCplDaemon] RUNDLL32.EXE C:\WINDOWS\System32\NvCpl.dll,NvStartup
O4 - HKLM\..\Run: [DVDSentry] C:\WINDOWS\System32\DSentry.exe
O4 - HKLM\..\Run: [MCUpdateExe] C:\PROGRA~1\mcafee.com\agent\McUpdate.exe
O4 - HKLM\..\Run: [DwlClient] C:\Program Files\Common Files\Dell\EUSW\Support.exe
O4 - HKLM\..\Run: [VSOCheckTask] "c:\PROGRA~1\mcafee.com\vso\mcmnhdlr.exe" /checktask
O4 - HKLM\..\Run: [MCAgentExe] c:\PROGRA~1\mcafee.com\agent\mcagent.exe
O4 - HKLM\..\Run: [VirusScan Online] "c:\PROGRA~1\mcafee.com\vso\mcvsshld.exe"
O4 - HKLM\..\Run: [nwiz] nwiz.exe /install
O4 - HKLM\..\Run: [BCMSMMSG] BCMSMMSG.exe
O4 - HKLM\..\Run: [TkBellExe] "C:\Program Files\Common Files\Real\Update_OB\realsched.exe" -osboot
O4 - HKLM\..\Run: [CleanUp] C:\PROGRA~1\McAfee.com\Shared\mcappins.exe /v=3 /cleanup
O4 - HKCU\..\Run: [ctfmon.exe] C:\WINDOWS\System32\ctfmon.exe
O4 - HKCU\..\Run: [SpySweeper] "C:\jerrys\Spy Sweeper\SpySweeper.exe" /0
O4 - Startup: SpywareGuard.lnk = C:\Program Files\SpywareGuard\sgmain.exe
O8 - Extra context menu item: &AOL Toolbar search - res://C:\Program Files\AOL Toolbar\toolbar.dll/SEARCH.HTML
O8 - Extra context menu item: E&xport to Microsoft Excel - res://C:\PROGRA~1\MICROS~4\Office10\EXCEL.EXE/3000
O9 - Extra button: Messenger - {4528BBE0-4E08-11D5-AD55-00010333D0AD} - C:\Program Files\Yahoo!\Messenger\yhexbmes0411.dll
O9 - Extra 'Tools' menuitem: Yahoo! Messenger - {4528BBE0-4E08-11D5-AD55-00010333D0AD} - C:\Program Files\Yahoo!\Messenger\yhexbmes0411.dll
O9 - Extra button: AIM - {AC9E2541-2814-11d5-BC6D-00B0D0A1DE45} - C:\Program Files\AIM\aim.exe
O9 - Extra button: Real.com - {CD67F990-D8E9-11d2-98FE-00C0F0318AFE} - C:\WINDOWS\System32\Shdocvw.dll
O12 - Plugin for .spop: C:\Program Files\Internet Explorer\Plugins\NPDocBox.dll
O16 - DPF: {74D05D43-3236-11D4-BDCD-00C04F9A3B61} (HouseCall Control) - http://a840.g.akamai.net/7/840/537/2004061...all/xscan53.cab
O16 - DPF: {7D1E9C49-BD6A-11D3-87A8-009027A35D73} (Yahoo! Audio UI1) - http://chat.yahoo.com/cab/yacsui.cab
O16 - DPF: {9A9307A0-7DA4-4DAF-B042-5009F29E09E1} (ActiveScan Installer Class) - http://www.pandasoftware.com/activescan/as5/asinst.cab
O16 - DPF: {E504EE6E-47C6-11D5-B8AB-00D0B78F3D48} (Yahoo! Webcam Viewer Wrapper) - http://chat.yahoo.com/cab/yvwrctl.cab
O17 - HKLM\System\CCS\Services\Tcpip\..\{7F452424-6E70-4E2A-B123-8E2B47979662}: NameServer = 205.188.146.146

#6 Grinler

Grinler

    Lawrence Abrams


  • Admin
  • 43,640 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:08:22 AM

Posted 10 November 2004 - 10:34 AM

That looks clean.

So when you go to www.windowsupdate.com and then what do you do that causes the blank page to show up?

#7 Bear

Bear

  • Members
  • 342 posts
  • OFFLINE
  •  
  • Location:South East Texas
  • Local time:07:22 AM

Posted 10 November 2004 - 01:47 PM

One of my clients had a simular problem, please click Start, click Run, type services.msc & click Ok. In the services console make sure the cryptographic service is started.

Posted Image
Posted Image


My System Specs


Comptia A+, Network + & MCP certified.

#8 jerry1967

jerry1967
  • Topic Starter

  • Members
  • 67 posts
  • OFFLINE
  •  
  • Local time:07:22 AM

Posted 10 November 2004 - 04:16 PM

ok ;the cryptographic service was started, when i go to the help and support i click on windows update and then i t says it is connecting but then the screen goes all white. i did get to the update by going to the website. so i figure the problem is in the help and support connection.

#9 Grinler

Grinler

    Lawrence Abrams


  • Admin
  • 43,640 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:08:22 AM

Posted 10 November 2004 - 04:23 PM

Click on start, then run, and type helpctr -regserver and press the ok button. See if thats better

#10 jerry1967

jerry1967
  • Topic Starter

  • Members
  • 67 posts
  • OFFLINE
  •  
  • Local time:07:22 AM

Posted 10 November 2004 - 07:42 PM

I typed it just like you stated -- nothing happened at all. The box just disappeared.

#11 Grinler

Grinler

    Lawrence Abrams


  • Admin
  • 43,640 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:08:22 AM

Posted 10 November 2004 - 10:26 PM

Thats what was supposed to happen. Does windows update from help and support work now?

My help and support on my machine does not work at all..so im somewhat in the same boat as you

#12 jerry1967

jerry1967
  • Topic Starter

  • Members
  • 67 posts
  • OFFLINE
  •  
  • Local time:07:22 AM

Posted 11 November 2004 - 12:13 AM

no it isn't working now but i can get the windows update from the website. so the problem must be in the connection between help and support and the windows update site.

#13 Grinler

Grinler

    Lawrence Abrams


  • Admin
  • 43,640 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:08:22 AM

Posted 11 November 2004 - 04:13 PM

Not sure. Helkp and Support is notoriously problematic. I would just go directly via the browser

#14 Jaybird934

Jaybird934

  • Members
  • 110 posts
  • OFFLINE
  •  
  • Local time:08:22 AM

Posted 16 January 2005 - 10:17 PM

Jerry, I think I have your solution. At this time I should point out that I AM NOT an admin or trained bleeping.com person. I simply found your post while trying to find the solution to the same problem myself, which I soon did - but not on these boards.

Firstly, I went here http://www.microsoft.com/DOWNLOADS/results...eeText=vbscript
and got the Windows script 5.6 (search result 1 or 2, depending on your operating system) This should enable you to avoid the blank screen, but you'll now have an error message.

Second, to rid yourself of the "unable to connect" (or something to that affect) message, follow these steps to re-register some DLL files on your computer.

1. Click Start, and then click Run.
2. In the Open box, type cmd, and then click OK. (windows 98 type "command" - Then type CD\windows\system)
3. At the command prompt, type the following lines and press ENTER after each line:

regsvr32 softpub.dll
regsvr32 wintrust.dll
regsvr32 initpki.dll
regsvr32 dssenh.dll
regsvr32 rsaenh.dll
regsvr32 gpkcsp.dll
regsvr32 sccbase.dll
regsvr32 slbcsp.dll
regsvr32 cryptdlg.dll

(the windows 98 computer I'm fixing didn't have a few of those, but it still worked)

4. Click OK when you receive the message that DllRegisterServer in FileName succeeded.
5. Type exit.

(I got these steps from Microsoft's website in this KB article on "ssl secured" sites) :
http://support.microsoft.com/default.aspx?...en-us;813444#13

Perhaps someone like Grinler could back me up on this, but I think there is very little risk in applying the new script or re-registering the files. Since this worked for me, and was pretty difficult to find info on, I thought I should share with you/others who may have this problem.

regards, Jaybird

#15 jerry1967

jerry1967
  • Topic Starter

  • Members
  • 67 posts
  • OFFLINE
  •  
  • Local time:07:22 AM

Posted 16 January 2005 - 11:00 PM

thank you i will try it-no it didn not work for me but thanks for leting me know about this. if you have any other ideas please let me know.

Edited by jerry1967, 17 January 2005 - 11:08 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users