Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Connect laptop and desktop


  • Please log in to reply
10 replies to this topic

#1 SyZy

SyZy

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:10:23 PM

Posted 15 May 2012 - 06:37 AM

I have a Toshiba laptop, which runs Win 7, and a desktop with XP. The modem/router I use has one wire, I think its called an Ethernet cable, that runs from the modem to the desktop CPU. There's another slot for USB, but I've lost the USB cable.

What I want to do is connect the laptop and desktop so that I can transfer large files. I tried taking the cable out of the modem and plugging it into the laptop (with the other end in the desktop CPU), but 7 just detects an unknown network and nothing else. The laptop has inbuilt stuff. Its documentation says: 10/100 Ethernet, Wi-Fi Wireless networking (802.11b/g/n). The modem's not wireless, and neither is the desktop.

So how do I set up a network to connect the two computers?

Edit:
The modem's a Huawei MT 882
http://www.slax.org/modules/screenshots/2/2866_big.png

Edited by SyZy, 15 May 2012 - 09:16 AM.


BC AdBot (Login to Remove)

 


#2 coxchris

coxchris

  • Members
  • 1,151 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Atwater
  • Local time:08:23 PM

Posted 15 May 2012 - 09:50 AM

Syzy,

Welcome to Bleeping computer

In that picture of your modem you can have one client only for now

You can plug in one end of that cable to the Ethernet port the big square port and connect the other end to the same slot
so your setup is now

Modem>>>>Clent

Here howe you connect to it http://help.talktalk.co.uk/app/answers/detail/a_id/1614/~/setting-up-your-huawei-smartax-mt882-router

Now for the wireless you need to buy a wireless Router

This is a screen shout of a wireless router http://www.google.com/products/catalog?hl=en&q=wireless+router&ix=sea&bav=on.2,or.r_gc.r_pw.r_qf.,cf.osb&biw=1920&bih=955&um=1&ie=UTF-8&tbm=shop&cid=1414783312094816160&sa=X&ei=xWuyT_mWIYXkiALgg4HeAw&ved=0CIICEPMCMAQ

This how your network is setup by a wirless router

Modem>>Wirless Router>>Windows 7 and Laptop wireless

http://www.amazon.co.uk/Netgear-Wireless-N-300-Router-Modem/dp/B003FS40KU/ref=sr_1_12?ie=UTF8&qid=1337093568&sr=8-12 in UK
http://www.amazon.com/Netgear-WNR2000-N300-Wireless-Router/dp/B001AZP8EW/ref=sr_1_7?ie=UTF8&qid=1337093737&sr=8-7 in USA

I dont know what stores to pick from.

Edited by coxchris, 15 May 2012 - 09:56 AM.

AA in Computer Networking Technology

BS in Information Technology 

Comptia A+, Project+, L+

Renewable:  N+,S+

CIW Web Design Specialist, JavaScript Specialist,  Database Design Specialist 

LPIC-1, SUSE 


#3 SyZy

SyZy
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:10:23 PM

Posted 15 May 2012 - 09:58 AM

I'm not buying anything.

Isn't it possible to connect one end of the Ethernet cable to the desktop and the other to the laptop and establish a connection?

#4 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,092 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:11:23 PM

Posted 15 May 2012 - 02:16 PM

You can connect both computers together without the modem using an Adhoc connection. However this does not share the internet it only allows you to transfer files between computers. To connect to the internet you will have to plug the Ethernet cable back into the modem.
Adhoc Network Using a Crossover Cable or Ethernet cable. Windows 7



Before buying a crossover cable, check your network adapter on the windows 7 Computer (If you need help checking your adapter please follow this threadand post back the information requested). Some newer network adapters automatically "cross over" when they detect that they are connected directly to another network adapter using a regular Ethernet cable.

Ignore the Brackets ( [ ] ) these are statements I have added or edited from the original document.

To connect two computers with a crossover cable


  • Plug each end of the crossover cable [or standard Ethernet Cable] into a network port on the back of each computer.
  • [On the computer] that is running [Windows 7], do the following:
    Open Network and Sharing Center by clicking the Start button , clicking Control Panel, clicking Network and Internet, and then clicking Network and Sharing Center.
  • In the network map at the top of Network and Sharing Center, double-click the Unidentified network‍ icon. (If you have more than one network, this icon will be labeled Multiple networks.)
  • If network discovery and file sharing are turned off, in Network, click the Information bar containing the following message: "Network discovery and file sharing are turned off. Network computers and devices are not visible. Click to change...," and then click Turn on network discovery and file sharing. If you are prompted for an administrator password or confirmation, type the password or provide confirmation.
  • In the Network discovery and file sharing dialog box, select one of the following options: [No, make the network that I am connected to a private network]
[This] option is usually the best choice because it only affects the network that you are connected to.Icons for both computers should now be visible in the Network window. Double-click each computer icon to share printers and other resources.


Note
If one of the computers is running Windows XP, it can take some time for that computer to appear in the Network window. You might need to move both computers to the same workgroup. You can do that by changing the workgroup on either computer. To change a workgroup, see
Join or create a workgroup. You might also need to turn on file and printer sharing on the computer running Windows XP.


If you are unable to see the computers in the network window adjust the Windows 7 Network and Sharing settings to work with Older OS's Go to Control Panel > Network and Internet > Network and Sharing Center > Change Advanced Sharing Settings (side panel). Make sure Network Discovery, File and Printer Sharing, and Public Folder Sharing are all set to "on" and Password Protected Sharing is set to "off".




Credit
Microsoft Microsoft Tech Net

Edited by Sneakycyber, 15 May 2012 - 02:17 PM.

Chad Mockensturm 

Systems and Network Engineer

Certified CompTia Network +, A +


#5 SyZy

SyZy
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:10:23 PM

Posted 16 May 2012 - 12:02 PM

Thanks a lot SneakyCyber. Got it working.

Actually I booted into Windows 7 in the desktop, but the fact that you said the Ethernet cable can be used as a crossover cable made me work it out. There are still a few problems, like I can access the laptop from the desktop but not the other way round, and the shared folder on the other partitions on the laptop are still not accessible (they show up but can't be opened). Also, when I was using XP on the desktop, and ran the diagnostic tool on 7 in the laptop, it said the "Local Area Connection" doesn't have a valid IP configuration. Also, it shows up as a public network. But, still it works, and that's great! Thanks again! :)

Edited by SyZy, 16 May 2012 - 12:04 PM.


#6 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,092 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:11:23 PM

Posted 20 May 2012 - 08:19 PM

What Version of XP do you have? Home Edition or Pro?

Chad Mockensturm 

Systems and Network Engineer

Certified CompTia Network +, A +


#7 SyZy

SyZy
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:10:23 PM

Posted 24 May 2012 - 08:46 AM

Sorry for the late reply. Its XP Pro SP3.

At present, I am connecting from to the 7 in the laptop by using the 7 in the desktop. Even then, and even after sharing the other partitions in 7 (in the laptop), I can only access the public folders in the laptop. So I have to copy the files from the desktop to the public folders of the laptop (C:) and then later copy them to the other partitions.

#8 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,092 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:11:23 PM

Posted 27 May 2012 - 11:38 PM

Sorry I missed the email its been a bit crazy around here. First lets make sure you have simple file.sharing turned off. Click this link FixIt By Microsoft

Edited by Sneakycyber, 27 May 2012 - 11:41 PM.

Chad Mockensturm 

Systems and Network Engineer

Certified CompTia Network +, A +


#9 SyZy

SyZy
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:10:23 PM

Posted 28 May 2012 - 10:06 AM

If you mean Folder Options > View > Use Simple File Sharing (recommended), its already turned off. The change can be seen in the folder properties dialog box.

#10 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,092 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:11:23 PM

Posted 28 May 2012 - 10:19 AM

When you right click on the folder, select sharing and security then permissions is the everyone group selected, and given full control?

Chad Mockensturm 

Systems and Network Engineer

Certified CompTia Network +, A +


#11 SyZy

SyZy
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:10:23 PM

Posted 28 May 2012 - 11:47 AM

Sorry I'm not at home right now so I'll check and get back later, only tomorrow. But as far as I remember, it is set with full permissions for everyone.

Edit: yes, its full permissions for everyone. Actually, only XP has the option of using simple file sharing, which I've disabled, while in 7, there's "Use Sharing Wizard (Recommended)", which is selected.

When I share the partition E: in the laptop, a symbol with two question marks comes up in the drive icon. Then when I try to open any folder which I've shared other than the common My Pictures, My Music folders, I get the message

Windows cannot access \\(name)\e
You do not have permission to access \\(name)\e. Contact your network administrator to request access.

Earlier, I couldn't access the desktop's hard disk from the laptop either, but then I tinkered a bit, and added guest to the partition of the desktop, and now I can access the desktop partition from the laptop.

Edited by SyZy, 29 May 2012 - 10:49 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users