Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Help! Automatic Update Option tick boxes greyed out


  • Please log in to reply
16 replies to this topic

#1 DrMikeJ

DrMikeJ

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:06:50 AM

Posted 09 May 2012 - 02:58 AM

I have just reinstalled Windows XP Professional after a Trojan Attack which could not be removed. On the Automatic Updates under Security Center via the Control Panel I have chosen "Notify me but don't automatically download or install them"
However when I click the tray notification icon to bring up the window "Choose updates to download" the tick boxes are greyed out, but with a tick inside them - allowing me no choice but to download the updates which are notified (or not - but leaving the notification icon in the system tray awaiting attention).
Can anyone assist is restoring these tick boxes?

BC AdBot (Login to Remove)

 


#2 noknojon

noknojon

  • Banned
  • 10,871 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:09:50 PM

Posted 09 May 2012 - 03:14 AM

I have just reinstalled Windows XP Professional after a Trojan Attack which could not be removed

Hello -
From the statement above, do you think the problem may still exist, or have you had help removing it ? ?

Please answer this fully prior to continuing with other guides -

Thank You -
Edited due to corrupted post -

Edited by noknojon, 09 May 2012 - 03:15 AM.


#3 DrMikeJ

DrMikeJ
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:06:50 AM

Posted 09 May 2012 - 04:13 AM

I somehow managed to get a Zero Access Rootkit Trojan. AVG 2012 (Free) then was going berserk giving all manner of files which were being infected with Crypt.AQLW (& variant names) every few seconds. I ran all manner of Trojan/Rootkit removers; Malawarebytes, AVG remove Zero Access, Symatec Fix Zero Access, Panda Yorkyt, avastMBR, and TDSSKiller (Always disbaling AVG First). AVG then stopped reporting the Trojan. I ran scans under AVG, Super Anti Spyware, Spybot, and Malawarebytes, all giving me the all clear. The system behaved normally. So I deleted all the various reports, thinking all was well.

I had an old copy of ComboFix (from a good number of years ago - I can't remember when, but it was when Rootkits began to be a problem, so I must have downloaded it "in case of need"). I thought ok one last check so I ran it untutored (never read any instructions to the contrary!) and it offered to update (accepted) and after running it, it reported this;
"You are infected with Rootkit.ZeroAccess! It has inserted itself into the tcp/ip stack. This is a particularly difficult infection. If for any reason that you’re unable to connect to the internet after running ComboFix, reboot once and see if that fixes it. If it's not fixed, run ComboFix one more time". I have removed ComboFix with the uninstall command.

Having read that you can never be sure, that you have completely got rid of a rootkit – I then went for the “nuclear option” and rebooted with my XP Professional Installation Disk SP2 – opted for a full format – and thus completely wiped the Disk. XP installed like a dream. It is a newborn system.

I then set (via Control Panel/Security Centre) the Update Options to “Notify me but don’t automatically download or install them”. As expected the Notification icon came up in the system tray, “Updates are ready to download etc” clicked on that, the Window comes up “Choose updates to download” – but alas the tick boxes are greyed out, with a tick in them – not allowing me to reject any updates.
I went on the MS update website where it lists updates but with no ability to remove any from the list – so it is the same problem!

Any help in resolving this will be appreciated.

#4 Guest_Xircal_*

Guest_Xircal_*

  • Guests
  • OFFLINE
  •  

Posted 09 May 2012 - 04:30 AM

Why don't you simply disable automatic updates altogether and update manually via the Windows Update site? That's what I do and I find it much easier since I can then choose what to install. Microsoft's Patch Tuesday takes place on the second Tuesday of every month, so just make a note of that in your calendar.

Edited by Xircal, 09 May 2012 - 04:37 AM.


#5 DrMikeJ

DrMikeJ
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  

Posted 09 May 2012 - 04:33 AM

XP Professional SP2

#6 DrMikeJ

DrMikeJ
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:06:50 AM

Posted 09 May 2012 - 04:42 AM

I guess it will be nice to solve this issue - which just might be one of admin rights - although I am running as an administrator (& the only user account). Obvioulsy there is something not right with the system!

#7 Guest_Xircal_*

Guest_Xircal_*

  • Guests
  • OFFLINE
  •  

Posted 09 May 2012 - 04:48 AM

XP Professional SP2

Sorry, I suddenly saw that you mentioned you had the Pro version in your previous post.

But like I mentioned before, it's much easier to update manually. Just keep an eye on the calendar for the second Tuesday in every month because that's when Microsoft releases the latest updates. If you live in Europe, check on the following Wednesday since Europe is 9 hours ahead of Microsoft's location in Redmond, so you won't see any updates if you check on a Tuesday morning.

Last but not least, if you reformatted, don't forget to install SP3. It's well worthwhile creating an SP3 installation disc so that you can use that whenever required rather than having to download it from the web every time. Instructions here: http://www.winsupersite.com/article/windows-xp2/slipstreaming-windows-xp-with-service-pack-3-sp3-128464

#8 DrMikeJ

DrMikeJ
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:06:50 AM

Posted 09 May 2012 - 05:00 AM

I did create a SP3 Disk - but alas when I came to run it - some of the files had corrupted - so I was left with using the original SP2 Disk! I will have a go at creating an SP3 Disk in case I have to do a reinstall again! Thand Xircal - I will use the link as the original instructions have gone with my fresh install!

I would still like to correct the problem - so if there is anyone around who can shed light on the issue I would be grateful.

#9 noknojon

noknojon

  • Banned
  • 10,871 posts
  • OFFLINE
  •  
  • Gender:Not Telling

Posted 09 May 2012 - 05:36 AM

Click Start, select Run and type: Services.msc
Press Enter
Locate the - "Automatic Update"
Make sure the service is not disabled and started.

"The Windows Update Service is not available" and all of the check boxes and
drop-down menus are greyed out. Automatic Update Service is missing from the
services.msc list.
Can happen if the wuaueng.dll file is not registered.

Register the file wuaueng.dll:
Click Start, select Run
Type: regsvr32 wuaueng.dll
Press OK.

If all else fails:
Windows Update Greyed Out - Restore (Line 179)
http://www.kellys-korner-xp.com/xp_tweaks.htm

#10 Guest_Xircal_*

Guest_Xircal_*

  • Guests
  • OFFLINE
  •  

Posted 09 May 2012 - 05:36 AM

OK, do the following then.

  • Go to Start, then Run, type gpedit.msc to open the Group Policy Editor. (If you don't have "Run" on the Start menu, hit Windows logo key + R instead)
  • Expand the following: Computer Administration | Administrative Templates | Windows Components.
  • Open Windows Updates and then in the right hand pane, double click "Configure Automatic Updates".
  • Click the "Explain" tab and decide how you want to receive Automatic Updates and then change the setting in the first tab to "Enabled"
To undo the setting, in the first tab, change it back to "Not configured".

#11 DrMikeJ

DrMikeJ
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:06:50 AM

Posted 09 May 2012 - 06:20 AM

Thanks for the help - I did all of the above - and still the problem exists! I can access the update service - that is not a problem - it is the fact that I cannot refuse updates - its all or none!

#12 Guest_Xircal_*

Guest_Xircal_*

  • Guests
  • OFFLINE
  •  

Posted 09 May 2012 - 06:52 AM

Thanks for the help - I did all of the above - and still the problem exists! I can access the update service - that is not a problem - it is the fact that I cannot refuse updates - its all or none!

Try adding Wuau.Admin as described in Microsoft KB328010

#13 DrMikeJ

DrMikeJ
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:09:50 PM

Posted 09 May 2012 - 07:16 AM

I followed the steps and arrived at advice you already kindly gave;

OK, do the following then.

  • Go to Start, then Run, type gpedit.msc to open the Group Policy Editor. (If you don't have "Run" on the Start menu, hit Windows logo key + R instead)
  • Expand the following: Computer Administration | Administrative Templates | Windows Components.
  • Open Windows Updates and then in the right hand pane, double click "Configure Automatic Updates".
  • Click the "Explain" tab and decide how you want to receive Automatic Updates and then change the setting in the first tab to "Enabled"
To undo the setting, in the first tab, change it back to "Not configured".


It is still a mystery!

#14 Guest_Xircal_*

Guest_Xircal_*

  • Guests
  • OFFLINE
  •  

Posted 09 May 2012 - 07:44 AM

So adding "Wuau.Admin" didn't do any good?

#15 DrMikeJ

DrMikeJ
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  

Posted 09 May 2012 - 08:06 AM

it was alreaqdy there!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users