Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

YouTube videos embedded in Facebook are not playing when in HTTPS


  • Please log in to reply
18 replies to this topic

#1 Alvas Rawuther

Alvas Rawuther

  • Members
  • 356 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Mumbai, India.
  • Local time:03:31 AM

Posted 04 May 2012 - 04:09 AM

All the YouTube videos embedded in Facebook do not play when in HTTPS. When I click play, the video just disappears and it leaves blank white space. While when not using a secure connection, everything works pleasantly well.

Is there any way to fix it, play videos, even when in HTTPS?

Browsers - Firefox, Chrome, Opera & any browser that I tried this on.
SYSTEM SPECS.
Windows 7 Ultimate SP1 | Intel Core 2 Duo E7500 @ 2.93GHz | 4.00 GB Dual-Channel DDR2 @ 333MHz RAM | 488 GB WD SATA HDD | 1024MB ATI Radeon HD 4350 | No real-time antivirus | MBAM on-demand | Windows 7's Built-in Firewall |

BC AdBot (Login to Remove)

 


#2 frankp316

frankp316

  • Members
  • 2,677 posts
  • OFFLINE
  •  
  • Local time:05:01 PM

Posted 04 May 2012 - 04:55 AM

What if you try to play it on Youtube or is the problem just on Facebook? If it's just on Facebook, my guess is you need to change some sort of setting within Facebook. I'm not on Facebook so I don't know what that would be.

#3 Alvas Rawuther

Alvas Rawuther
  • Topic Starter

  • Members
  • 356 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Mumbai, India.
  • Local time:03:31 AM

Posted 05 May 2012 - 03:50 AM

What if you try to play it on Youtube or is the problem just on Facebook? If it's just on Facebook, my guess is you need to change some sort of setting within Facebook. I'm not on Facebook so I don't know what that would be.

Just on facebook. Setting it back to not using a secure connection fixes the problem. But that is not what I want to do.
SYSTEM SPECS.
Windows 7 Ultimate SP1 | Intel Core 2 Duo E7500 @ 2.93GHz | 4.00 GB Dual-Channel DDR2 @ 333MHz RAM | 488 GB WD SATA HDD | 1024MB ATI Radeon HD 4350 | No real-time antivirus | MBAM on-demand | Windows 7's Built-in Firewall |

#4 frankp316

frankp316

  • Members
  • 2,677 posts
  • OFFLINE
  •  
  • Local time:05:01 PM

Posted 05 May 2012 - 04:33 AM

That's why I'm not on Facebook.

#5 Guest_Xircal_*

Guest_Xircal_*

  • Guests
  • OFFLINE
  •  

Posted 05 May 2012 - 07:12 AM

Here's the Facebook Troubleshooting site.

#6 Alvas Rawuther

Alvas Rawuther
  • Topic Starter

  • Members
  • 356 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Mumbai, India.

Posted 07 May 2012 - 11:35 AM

That's why I'm not on Facebook.

What's wrong with you?
Thank you.

Here's the Facebook Troubleshooting site.

I tried that. It only says that I should use the latest flash player - which I do.

Thanks a lot for at least trying to help though.

Any more help from anyone, so that I can get this problem fixed?
SYSTEM SPECS.
Windows 7 Ultimate SP1 | Intel Core 2 Duo E7500 @ 2.93GHz | 4.00 GB Dual-Channel DDR2 @ 333MHz RAM | 488 GB WD SATA HDD | 1024MB ATI Radeon HD 4350 | No real-time antivirus | MBAM on-demand | Windows 7's Built-in Firewall |

#7 computerxpds

computerxpds

    Bleepin' Comp


  • Moderator
  • 4,488 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:03:31 AM

Posted 07 May 2012 - 12:00 PM

Hello,

Something's may not work on the secured connection system that Facebook offers. So if it works when you turn that off but not when it is on then there really is nothing you can do but see if Facebook can fix it on their end, which most likely wont get you very far (based on my own experience with Facebook support). So see here: http://www.facebook.com/help/suggestions/
sigcomp.png 
If I have replied to a topic and you reply and I haven't gotten back to you within 48 hours (2 days) then send me a P.M.
Some important links: BC Forum Rules | Misplaced Malware Logs | BC Tutorials | BC Downloads |
Follow BleepingComputer on: Facebook! | Twitter! | Google+| Come join us on the BleepingComputer Live Chat on Discord too! |

#8 Guest_Xircal_*

Guest_Xircal_*

  • Guests
  • OFFLINE
  •  

Posted 07 May 2012 - 12:44 PM

What I suggest you do here is to open Google and then use the site parameter to isolate the problem on facebook. I took a brief look myself and there are quite a few users with the same problem, but some of them can see the video in https while others can't.

So in this particular case, copy/paste the following string in the bold font into Google's search field: site:facebook.com the video you requested could not be loaded

You'll only get results which comprise of other users with the same problem and only on facebook. Hopefully, one of the results will contain the fix.

EDIT: Just thought of something. Try disabling Flash Hardware Acceleration.

Edited by Xircal, 07 May 2012 - 01:17 PM.


#9 Alvas Rawuther

Alvas Rawuther
  • Topic Starter

  • Members
  • 356 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Mumbai, India.
  • Local time:06:01 PM

Posted 08 May 2012 - 06:10 AM

Hello,

Something's may not work on the secured connection system that Facebook offers. So if it works when you turn that off but not when it is on then there really is nothing you can do but see if Facebook can fix it on their end, which most likely wont get you very far (based on my own experience with Facebook support). So see here: http://www.facebook.com/help/suggestions/

I just reported the problem to them as you said and also posted on their community help forums.
Thank you.


What I suggest you do here is to open Google and then use the site parameter to isolate the problem on facebook. I took a brief look myself and there are quite a few users with the same problem, but some of them can see the video in https while others can't.

So in this particular case, copy/paste the following string in the bold font into Google's search field: site:facebook.com the video you requested could not be loaded

You'll only get results which comprise of other users with the same problem and only on facebook. Hopefully, one of the results will contain the fix.

EDIT: Just thought of something. Try disabling Flash Hardware Acceleration.

I've tried and found no fix so far. And disabling flash hardware acceleration doesn't seem to work. And the video doesn't even get loaded. When I right-click on a facebook video after clicking play, all I get is this -
Posted Image

(I disabled hardware acceleration by right-clicking>settings on a video on youtube but as seen above, it doesn't help)
Thanks.

Edited by Alvas Rawuther, 08 May 2012 - 09:07 AM.

SYSTEM SPECS.
Windows 7 Ultimate SP1 | Intel Core 2 Duo E7500 @ 2.93GHz | 4.00 GB Dual-Channel DDR2 @ 333MHz RAM | 488 GB WD SATA HDD | 1024MB ATI Radeon HD 4350 | No real-time antivirus | MBAM on-demand | Windows 7's Built-in Firewall |

#10 Guest_Xircal_*

Guest_Xircal_*

  • Guests
  • OFFLINE
  •  

Posted 08 May 2012 - 06:33 AM

OK, try this instead.

  • Go to Windows Control Panel and the double click "Flash Player".
  • In the menu which opens, click the "Advanced" tab.
  • In the menu at the top called "Browser data and settings" click the "Delete All" button.
Close the menu and then try and play a video again on an SSL facebook page.

If that doesn't work, I suggest starting Firefox in Safe Mode to determine if an add-on is blocking flash. Do that as follows.

  • If you're using the layout with the oblong orange Firefox button top left, hit ALT to toggle the text links on.
  • Click "Help" | "Restart with add-ons disabled".
  • In the next menu which appears, click "Continue in Safe Mode" without checkmarking any of the boxes.
When Firefox restarts, all your add-ons will be disabled, but plugins such as Flash will remain enabled. Go to Facebook SSL and see if it makes any difference.

If they play properly in Safe Mode, then one of your add-ons is the culprit. You then have to repeat the same steps, but checkmark the top box which called "Disable all Add-ons". Then click the button at the bottom called "Make changes and restart".

After that, it's simply a case of re-enabling them one by one until the problem recurs. Then you'll know which one is the culprit.

#11 Alvas Rawuther

Alvas Rawuther
  • Topic Starter

  • Members
  • 356 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Mumbai, India.

Posted 08 May 2012 - 09:18 AM

OK, try this instead.

  • Go to Windows Control Panel and the double click "Flash Player".
  • In the menu which opens, click the "Advanced" tab.
  • In the menu at the top called "Browser data and settings" click the "Delete All" button.
Close the menu and then try and play a video again on an SSL facebook page.

If that doesn't work, I suggest starting Firefox in Safe Mode to determine if an add-on is blocking flash. Do that as follows.

  • If you're using the layout with the oblong orange Firefox button top left, hit ALT to toggle the text links on.
  • Click "Help" | "Restart with add-ons disabled".
  • In the next menu which appears, click "Continue in Safe Mode" without checkmarking any of the boxes.
When Firefox restarts, all your add-ons will be disabled, but plugins such as Flash will remain enabled. Go to Facebook SSL and see if it makes any difference.

If they play properly in Safe Mode, then one of your add-ons is the culprit. You then have to repeat the same steps, but checkmark the top box which called "Disable all Add-ons". Then click the button at the bottom called "Make changes and restart".

After that, it's simply a case of re-enabling them one by one until the problem recurs. Then you'll know which one is the culprit.

Nope, doing none of what you said makes the videos play properly until I disable HTTPS.

Edited by Alvas Rawuther, 08 May 2012 - 09:19 AM.

SYSTEM SPECS.
Windows 7 Ultimate SP1 | Intel Core 2 Duo E7500 @ 2.93GHz | 4.00 GB Dual-Channel DDR2 @ 333MHz RAM | 488 GB WD SATA HDD | 1024MB ATI Radeon HD 4350 | No real-time antivirus | MBAM on-demand | Windows 7's Built-in Firewall |

#12 Guest_Xircal_*

Guest_Xircal_*

  • Guests
  • OFFLINE
  •  

Posted 08 May 2012 - 10:20 AM

I'm wondering if it might have something to do with Adobe. According to that article, ....content accessed via HTTP may not access data from a HTTPS location.

I'll check with one of the Adobe guys for you and see what they have to say.


I've just come across this article concerning what happens when you view an https connection of facebook, but then switch to http. Apparently, facebook disables https in your account settings. See: Facebook's crude https workaround

That would imply that you have to re-enable the safe settings in order to view https content again.

Edited by Xircal, 08 May 2012 - 10:32 AM.


#13 frankp316

frankp316

  • Members
  • 2,677 posts
  • OFFLINE
  •  
  • Local time:03:31 AM

Posted 08 May 2012 - 11:40 AM

He knows about that already but he doesn't want to do it because it's a security risk. Facebook's biggest problem is it is too easy to get infected and they haven't done enough to rectify that. And that's why I stay away from Facebook. So I understand his problem but it depends on Facebook smartening up and doing more to keep users protected. Good luck with that.

#14 Alvas Rawuther

Alvas Rawuther
  • Topic Starter

  • Members
  • 356 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Mumbai, India.

Posted 08 May 2012 - 11:51 AM

@Xircal - Thanks but I know that like frankp316 said. Anyway, looks like until someone over here or me or someone from facebook finds a workaround or fixes this problem - I'll have to use an http connection. Since I can't afford not being able to view videos in my stream. Thanks a lot for your help so far.

@frankp316 - Yeah, right.

BTW, I'm not really connected to any other computers and sharing files with them so I'm not really in a network. I use cable broadband and have my firewall setting as public for it. So, how much really is the risk if I start using an http(non-secure, unencrypted) connection for facebook. And would it really matter? Since before facebook introduced this feature, I and everyone else used an unencrypted http connection, no?

Thanks. :)
SYSTEM SPECS.
Windows 7 Ultimate SP1 | Intel Core 2 Duo E7500 @ 2.93GHz | 4.00 GB Dual-Channel DDR2 @ 333MHz RAM | 488 GB WD SATA HDD | 1024MB ATI Radeon HD 4350 | No real-time antivirus | MBAM on-demand | Windows 7's Built-in Firewall |

#15 Guest_Xircal_*

Guest_Xircal_*

  • Guests
  • OFFLINE
  •  

Posted 08 May 2012 - 02:19 PM

Sophos has a good Facebook security guide which is well worth a read: Sophos Facebook Best Practices

Also, if your OS is either Vista or Windows 7, the next version of Flash will include a sandbox for Firefox: Flash 11.3 includes Protected Mode for Firefox Unfortunately though, Protected Mode won't be available for Windows XP users.

It's currently in its third BETA stage if you want to give it a go: Flash 11.3 BETA

If I come across a fix for your problem though, I'll add it to this thread.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users