Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Server Service not able to start


  • Please log in to reply
13 replies to this topic

#1 mcfee

mcfee

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:10:52 PM

Posted 02 May 2012 - 11:24 AM

Hello,

Following the removal of some malware (http://www.bleepingcomputer.com/forums/topic448225.html), I have not been able to enable my Server Service in Windows 7. I was advised to post this here.

This means I cannot share files, use bonjour services, vnc etc.

I have encountered Error 1068: The dependency or group failed when I enabled the server service in services.msc .

I have already tried the following (and none worked):
  • Enabling in safe mode
  • Enabling all startup services in msconfig
  • Modifying the registries in folders: Ndisuio, EapHost, and Dhcp (with instructions specified on another site)
  • Checking the firewall

What can I try? Thanks!

BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 56,540 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:03:52 PM

Posted 02 May 2012 - 04:39 PM

Well...I would try running the sfc /scannow command, in an effort to repair possibly damaged system files.

How To Use Sfc.exe To Repair System Files - http://www.bleepingcomputer.com/forums/topic43051.html

Louis

#3 mcfee

mcfee
  • Topic Starter

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:10:52 PM

Posted 03 May 2012 - 04:39 AM

Just ran sfc.exe /scannow now and it all seems ok-

"Windows Resource Protection did not find any integrity violations"

What next?

#4 narenxp

narenxp

  • BC Advisor
  • 16,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:04:52 PM

Posted 03 May 2012 - 05:03 AM

Download

FSS

Checkmark all the boxes

Click on "Scan".
Please copy and paste the log to your reply.

&

Download

mini toolbox

Checkmark following box:

List last 10 Event Viewer log

Click Go and post the result.

#5 mcfee

mcfee
  • Topic Starter

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:10:52 PM

Posted 03 May 2012 - 05:44 AM

Not the priority, but system restore also doesnt work. I never use anyway so not a big issue.

FSS:

Farbar Service Scanner Version: 30-04-2012 01
Ran by User1 (administrator) on 03-05-2012 at 12:41:09
Running from "C:\Users\User1\Desktop"
Microsoft Windows 7 Ultimate Service Pack 1 (X64)
Boot Mode: Normal
****************************************************************

Internet Services:
============

Connection Status:
==============
Localhost is accessible.
LAN connected.
Google IP is accessible.
Yahoo IP is accessible.


Windows Firewall:
=============

Firewall Disabled Policy:
==================


System Restore:
============

System Restore Disabled Policy:
========================


Action Center:
============

Windows Update:
============

Windows Autoupdate Disabled Policy:
============================


Windows Defender:
==============

File Check:
========
C:\Windows\System32\nsisvc.dll => MD5 is legit
C:\Windows\System32\drivers\nsiproxy.sys => MD5 is legit
C:\Windows\System32\dhcpcore.dll => MD5 is legit
C:\Windows\System32\drivers\afd.sys
[2010-11-21 05:24] - [2010-11-21 05:24] - 0499712 ____A (Microsoft Corporation) D31DC7A16DEA4A9BAF179F3D6FBDB38C

C:\Windows\System32\drivers\tdx.sys => MD5 is legit
C:\Windows\System32\Drivers\tcpip.sys
[2010-11-21 05:24] - [2010-11-21 05:24] - 1924480 ____A (Microsoft Corporation) 509383E505C973ED7534A06B3D19688D

C:\Windows\System32\dnsrslvr.dll
[2010-11-21 05:24] - [2010-11-21 05:24] - 0183296 ____A (Microsoft Corporation) CD55F5355D8F55D44C9F4ED875705BD6

C:\Windows\System32\mpssvc.dll => MD5 is legit
C:\Windows\System32\bfe.dll => MD5 is legit
C:\Windows\System32\drivers\mpsdrv.sys => MD5 is legit
C:\Windows\System32\SDRSVC.dll => MD5 is legit
C:\Windows\System32\vssvc.exe => MD5 is legit
C:\Windows\System32\wscsvc.dll => MD5 is legit
C:\Windows\System32\wbem\WMIsvc.dll => MD5 is legit
C:\Windows\System32\wuaueng.dll => MD5 is legit
C:\Windows\System32\qmgr.dll => MD5 is legit
C:\Windows\System32\es.dll => MD5 is legit
C:\Windows\System32\cryptsvc.dll => MD5 is legit
C:\Program Files\Windows Defender\MpSvc.dll => MD5 is legit
C:\Windows\System32\svchost.exe => MD5 is legit
C:\Windows\System32\rpcss.dll => MD5 is legit


**** End of log ****


Mini toolbox
MiniToolBox by Farbar Version: 18-01-2012
Ran by Yianni (administrator) on 03-05-2012 at 12:43:45
Microsoft Windows 7 Ultimate Service Pack 1 (X64)
Boot Mode: Normal
***************************************************************************

========================= Event log errors: ===============================

Application errors:
==================
Error: (05/03/2012 00:26:34 PM) (Source: Microsoft-Windows-CAPI2) (User: )
Description: Failed extract of third-party root list from auto update cab at: <http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/authrootstl.cab> with error: The data is invalid.
.

Error: (05/03/2012 00:23:30 PM) (Source: Microsoft-Windows-CAPI2) (User: )
Description: Failed extract of third-party root list from auto update cab at: <http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/authrootstl.cab> with error: The data is invalid.
.

Error: (05/03/2012 00:23:30 PM) (Source: Microsoft-Windows-CAPI2) (User: )
Description: Failed extract of third-party root list from auto update cab at: <http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/authrootstl.cab> with error: The data is invalid.
.

Error: (05/03/2012 00:23:30 PM) (Source: Microsoft-Windows-CAPI2) (User: )
Description: Failed extract of third-party root list from auto update cab at: <http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/authrootstl.cab> with error: The data is invalid.
.

Error: (05/03/2012 00:23:30 PM) (Source: Microsoft-Windows-CAPI2) (User: )
Description: Failed extract of third-party root list from auto update cab at: <http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/authrootstl.cab> with error: The data is invalid.
.

Error: (05/03/2012 00:23:30 PM) (Source: Microsoft-Windows-CAPI2) (User: )
Description: Failed extract of third-party root list from auto update cab at: <http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/authrootstl.cab> with error: The data is invalid.
.

Error: (05/03/2012 00:23:30 PM) (Source: Microsoft-Windows-CAPI2) (User: )
Description: Failed extract of third-party root list from auto update cab at: <http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/authrootstl.cab> with error: The data is invalid.
.

Error: (05/03/2012 00:23:30 PM) (Source: Microsoft-Windows-CAPI2) (User: )
Description: Failed extract of third-party root list from auto update cab at: <http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/authrootstl.cab> with error: The data is invalid.
.

Error: (05/03/2012 00:23:30 PM) (Source: Microsoft-Windows-CAPI2) (User: )
Description: Failed extract of third-party root list from auto update cab at: <http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/authrootstl.cab> with error: The data is invalid.
.

Error: (05/03/2012 00:23:30 PM) (Source: Microsoft-Windows-CAPI2) (User: )
Description: Failed extract of third-party root list from auto update cab at: <http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/authrootstl.cab> with error: The data is invalid.
.


System errors:
=============
Error: (05/03/2012 10:58:58 AM) (Source: Service Control Manager) (User: )
Description: The Soluto PCGenome Core Service service failed to start due to the following error:
%%1053

Error: (05/03/2012 10:58:58 AM) (Source: Service Control Manager) (User: )
Description: A timeout was reached (30000 milliseconds) while waiting for the Soluto PCGenome Core Service service to connect.

Error: (05/03/2012 10:58:27 AM) (Source: Service Control Manager) (User: )
Description: The Internet Connection Sharing (ICS) service depends on the Remote Access Connection Manager service which failed to start because of the following error:
%%1058

Error: (05/03/2012 10:58:24 AM) (Source: Service Control Manager) (User: )
Description: The NEWDRIVER service failed to start due to the following error:
%%2

Error: (05/03/2012 10:58:00 AM) (Source: Service Control Manager) (User: )
Description: The Computer Browser service depends on the Server service which failed to start because of the following error:
%%1068

Error: (05/03/2012 10:57:59 AM) (Source: Service Control Manager) (User: )
Description: The Server service depends on the Security Accounts Manager service which failed to start because of the following error:
%%1058

Error: (05/03/2012 00:19:08 AM) (Source: VDS Basic Provider) (User: )
Description: Unexpected failure. Error code: D@01010004

Error: (05/03/2012 00:19:08 AM) (Source: VDS Basic Provider) (User: )
Description: Unexpected failure. Error code: D@01010004

Error: (05/03/2012 00:19:08 AM) (Source: VDS Basic Provider) (User: )
Description: Unexpected failure. Error code: D@01010004

Error: (05/03/2012 00:18:03 AM) (Source: Service Control Manager) (User: )
Description: The Soluto PCGenome Core Service service failed to start due to the following error:
%%1053


Microsoft Office Sessions:
=========================
Error: (05/03/2012 00:26:34 PM) (Source: Microsoft-Windows-CAPI2)(User: )
Description: http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/authrootstl.cabThe data is invalid.

Error: (05/03/2012 00:23:30 PM) (Source: Microsoft-Windows-CAPI2)(User: )
Description: http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/authrootstl.cabThe data is invalid.

Error: (05/03/2012 00:23:30 PM) (Source: Microsoft-Windows-CAPI2)(User: )
Description: http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/authrootstl.cabThe data is invalid.

Error: (05/03/2012 00:23:30 PM) (Source: Microsoft-Windows-CAPI2)(User: )
Description: http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/authrootstl.cabThe data is invalid.

Error: (05/03/2012 00:23:30 PM) (Source: Microsoft-Windows-CAPI2)(User: )
Description: http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/authrootstl.cabThe data is invalid.

Error: (05/03/2012 00:23:30 PM) (Source: Microsoft-Windows-CAPI2)(User: )
Description: http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/authrootstl.cabThe data is invalid.

Error: (05/03/2012 00:23:30 PM) (Source: Microsoft-Windows-CAPI2)(User: )
Description: http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/authrootstl.cabThe data is invalid.

Error: (05/03/2012 00:23:30 PM) (Source: Microsoft-Windows-CAPI2)(User: )
Description: http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/authrootstl.cabThe data is invalid.

Error: (05/03/2012 00:23:30 PM) (Source: Microsoft-Windows-CAPI2)(User: )
Description: http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/authrootstl.cabThe data is invalid.

Error: (05/03/2012 00:23:30 PM) (Source: Microsoft-Windows-CAPI2)(User: )
Description: http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/authrootstl.cabThe data is invalid.


**** End of log ****

#6 narenxp

narenxp

  • BC Advisor
  • 16,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:04:52 PM

Posted 03 May 2012 - 06:01 AM

The Server service depends on the Security Accounts Manager service which failed to start because of the following error:
%%1058


Go to services

Right click on remote procedure call service-start it
Right click on security accounts manager service-start it

Do you receive any errors now?

Edited by narenxp, 03 May 2012 - 06:01 AM.


#7 mcfee

mcfee
  • Topic Starter

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:10:52 PM

Posted 03 May 2012 - 07:42 AM

Security accounts manager was the one in services.msc. I also had to enable it in the startup services (msconfig)

Thanks for the help!

Did any of the info help you out with my system restore problems? I have a feeling this also related to my auto-backup software never working (O&O Auto backup program), this correct?

#8 narenxp

narenxp

  • BC Advisor
  • 16,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:04:52 PM

Posted 03 May 2012 - 08:13 AM

Did any of the info help you out with my system restore problems? I have a feeling this also related to my auto-backup software never working (O&O Auto backup program), this correct?

what error code does system restore generate?

What is the status of volume shadow copy service? Is it started?

#9 mcfee

mcfee
  • Topic Starter

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:10:52 PM

Posted 03 May 2012 - 08:25 AM

Volume shadow copy service is started, and no specific error code to tell you with system restore. O&O Autoback eror says "Last process defective. An invalid parameter was passed to a service or..." (cant read the rest).

#10 narenxp

narenxp

  • BC Advisor
  • 16,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:04:52 PM

Posted 03 May 2012 - 10:31 AM

O&O Autoback eror says "Last process defective. An invalid parameter was passed to a service or..." (cant read the rest).

Do you mean the O&O autobackup software? Did you try reinstalling it?

#11 mcfee

mcfee
  • Topic Starter

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:10:52 PM

Posted 03 May 2012 - 11:24 AM

Yes, have tried re-instal, changing the backup device and folders- none worked. Can we link this to the same problem as the System Restore issue? For some reason I though fixing the system restore would fix both...

#12 mcfee

mcfee
  • Topic Starter

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:10:52 PM

Posted 03 May 2012 - 11:45 AM

Ahhhh solved!

I was scrolling through the list of disabled services, and noticed the "MICROSOFT software shadow copy provider" was disabled. Enabling it got System restore & O&O backup working sucessfully!

#13 narenxp

narenxp

  • BC Advisor
  • 16,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:04:52 PM

Posted 03 May 2012 - 12:53 PM

Thanks for sharing the solution :thumbup2:

#14 hammoux

hammoux

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:09:52 PM

Posted 23 August 2015 - 03:24 PM

The Server service depends on the Security Accounts Manager service which failed to start because of the following error:
%%1058


Go to services

Right click on remote procedure call service-start it
Right click on security accounts manager service-start it

Do you receive any errors now?

thanks , that worked for me






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users