Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

unknown rootkit/malware, scans keep coming back clean


  • This topic is locked This topic is locked
16 replies to this topic

#1 Ribo3

Ribo3

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:08:36 PM

Posted 28 April 2012 - 04:38 PM

I have run several scanners (MalwareBytes, SAS, rkill, Sophos A/V and A/R, Rootkit Repeal, GMER, TDSS Killer, etc). Originally I found and removed some problems, mainly via MBAM. All scans come back clean now but I know something is on here because of some weird behavior. I can't install direct X, it fails with an error stating that the cabinet files are corrupt. Everytime I start IE it says that it is not the default browser. One of the scanners (I think CatchMe) came back saying that the C: drive was not present.

Other than that it is running well. I don't see any browser or search redirects. It doesn't seem to be bogged down. I ran system file checker and it just goes away eventually, I don't get a message that it did or did not repair any files.

There are some weird things in the GMER log, but I don't know what they mean. I included that below as ark.txt

Hopefully you guys can help.


.
DDS (Ver_2011-08-26.01) - NTFSx86
Internet Explorer: 8.0.6001.18702
Run by Garrett at 15:49:09 on 2012-04-28
Microsoft Windows XP Home Edition 5.1.2600.3.1252.1.1033.18.1023.509 [GMT -5:00]
.
.
============== Running Processes ===============
.
C:\WINDOWS\system32\svchost.exe -k DcomLaunch
svchost.exe
C:\WINDOWS\System32\svchost.exe -k netsvcs
svchost.exe
C:\WINDOWS\system32\spoolsv.exe
svchost.exe
C:\Program Files\SUPERAntiSpyware\SASCORE.EXE
C:\Program Files\Common Files\Apple\Mobile Device Support\AppleMobileDeviceService.exe
C:\Program Files\Diskeeper Corporation\Diskeeper\DkService.exe
C:\Documents and Settings\All Users\Application Data\EPSON\EPW!3 SSRP\E_S40ST7.EXE
C:\Documents and Settings\All Users\Application Data\EPSON\EPW!3 SSRP\E_S40RP7.EXE
C:\WINDOWS\System32\svchost.exe -k HTTPFilter
C:\Program Files\Java\jre6\bin\jqs.exe
C:\WINDOWS\system32\PnkBstrA.exe
C:\WINDOWS\system32\svchost.exe -k imgsvc
C:\Program Files\TomTom HOME 2\TomTomHOMEService.exe
C:\Program Files\Common Files\Sony Shared\VAIO Entertainment Platform\VCSW\VCSW.exe
C:\WINDOWS\system32\MsPMSPSv.exe
C:\WINDOWS\system32\wbem\wmiapsrv.exe
C:\WINDOWS\explorer.exe
C:\Program Files\internet explorer\iexplore.exe
C:\Program Files\internet explorer\iexplore.exe
C:\WINDOWS\system32\ctfmon.exe
c:\program files\mapquest toolbar\mapquesttbServer.exe
C:\Program Files\internet explorer\iexplore.exe
C:\Documents and Settings\Garrett\Local Settings\Temporary Internet Files\Content.IE5\42IEF6G1\Defogger[1].exe
.
============== Pseudo HJT Report ===============
.
uSearchMigratedDefaultURL = hxxp://www.google.com/search?q={searchTerms}&sourceid=ie7&rls=com.microsoft:en-US&ie=utf8&oe=utf8
uStart Page = hxxp://oc-startpage.aol.com
uInternet Connection Wizard,ShellNext = iexplore
uSearchURL,(Default) = hxxp://search.yahoo.com
uURLSearchHooks: MapQuest Toolbar Search Class: {2558d83c-097c-4cf1-9163-ce5ecc36ace2} - c:\program files\mapquest toolbar\mapquesttb.dll
mURLSearchHooks: MapQuest Toolbar Search Class: {2558d83c-097c-4cf1-9163-ce5ecc36ace2} - c:\program files\mapquest toolbar\mapquesttb.dll
BHO: MRI_DISABLED - No File
BHO: IEVkbdBHO - No File
BHO: Adobe PDF Link Helper: {18df081c-e8ad-4283-a596-fa578c2ebdc3} - c:\program files\common files\adobe\acrobat\activex\AcroIEHelperShim.dll
BHO: MapQuest Toolbar Loader: {bd3fd433-147a-482e-a192-614f26e2310c} - c:\program files\mapquest toolbar\mapquesttb.dll
TB: MapQuest Toolbar: {9302e698-7e00-43ab-b867-c6e759bc2ada} - c:\program files\mapquest toolbar\mapquesttb.dll
EB: MRI_DISABLED - No File
uRun: [H/PC Connection Agent] "c:\program files\microsoft activesync\wcescomm.exe"
uRun: [TomTomHOME.exe] "c:\program files\tomtom home 2\TomTomHOMERunner.exe"
uRun: [Steam] "c:\program files\steam\Steam.exe" -silent
uRun: [SUPERAntiSpyware] c:\program files\superantispyware\SUPERAntiSpyware.exe
uRun: [ctfmon.exe] c:\windows\system32\ctfmon.exe
mRun: [QuickTime Task] "c:\program files\quicktime\QTTask.exe" -atboottime
mRun: [iTunesHelper] "c:\program files\itunes\iTunesHelper.exe"
mRun: [Adobe ARM] "c:\program files\common files\adobe\arm\1.0\AdobeARM.exe"
IE: {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - {CAFEEFAC-0016-0000-0030-ABCDEFFEDCBC} - c:\program files\java\jre6\bin\npjpi160_30.dll
DPF: {02CF1781-EA91-4FA5-A200-646E8241987C} - hxxp://esupport.sony.com/VaioInfo.CAB
DPF: {8AD9C840-044E-11D1-B3E9-00805F499D93} - hxxp://java.sun.com/update/1.6.0/jinstall-1_6_0_30-windows-i586.cab
DPF: {CAFEEFAC-0016-0000-0030-ABCDEFFEDCBA} - hxxp://java.sun.com/update/1.6.0/jinstall-1_6_0_30-windows-i586.cab
DPF: {CAFEEFAC-FFFF-FFFF-FFFF-ABCDEFFEDCBA} - hxxp://java.sun.com/update/1.6.0/jinstall-1_6_0_30-windows-i586.cab
TCP: DhcpNameServer = 10.0.1.1
TCP: Interfaces\{69CC3030-A4CD-4940-ADAD-F7D9A39D3B16} : DhcpNameServer = 10.0.1.1
TCP: Interfaces\{85E5CBD6-1030-4023-B925-3DC49E577D9A} : DhcpNameServer = 10.0.0.1
TCP: Interfaces\{D48A1920-F295-4748-876D-81B66FD30EDC} : DhcpNameServer = 10.0.0.1
TCP: Interfaces\{DFDA6BEA-2A4F-4F68-A022-391AB6B062F8} : DhcpNameServer = 10.0.0.1
Notify: !SASWinLogon - c:\program files\superantispyware\SASWINLO.DLL
Notify: AtiExtEvent - Ati2evxx.dll
Notify: igfxcui - igfxsrvc.dll
SSODL: WPDShServiceObj - {AAA288BA-9A4C-45B0-95D7-94D524869DB5} - c:\windows\system32\WPDShServiceObj.dll
SEH: SABShellExecuteHook Class: {5ae067d3-9afb-48e0-853a-ebb7f4a000da} - c:\program files\superantispyware\SASSEH.DLL
.
============= SERVICES / DRIVERS ===============
.
R1 SASDIFSV;SASDIFSV;c:\program files\superantispyware\sasdifsv.sys [2011-7-22 12880]
R1 SASKUTIL;SASKUTIL;c:\program files\superantispyware\SASKUTIL.SYS [2011-7-12 67664]
R2 !SASCORE;SAS Core Service;c:\program files\superantispyware\SASCore.exe [2011-8-11 116608]
R2 TomTomHOMEService;TomTomHOMEService;c:\program files\tomtom home 2\TomTomHOMEService.exe [2010-8-24 92008]
S2 gupdate;Google Update Service (gupdate);c:\program files\google\update\GoogleUpdate.exe [2012-4-20 136176]
S2 MBAMService;MBAMService;c:\program files\malwarebytes' anti-malware\mbamservice.exe [2012-4-20 654408]
S3 AdobeFlashPlayerUpdateSvc;Adobe Flash Player Update Service;c:\windows\system32\macromed\flash\FlashPlayerUpdateService.exe [2012-4-20 253088]
S3 APR;APR;\??\c:\program files\gamersfirst\knight online\apr.sys --> c:\program files\gamersfirst\knight online\APR.sys [?]
S3 gupdatem;Google Update Service (gupdatem);c:\program files\google\update\GoogleUpdate.exe [2012-4-20 136176]
S3 MBAMProtector;MBAMProtector;c:\windows\system32\drivers\mbam.sys [2012-4-20 22344]
S3 MEMSWEEP2;MEMSWEEP2;\??\c:\windows\system32\17d.tmp --> c:\windows\system32\17D.tmp [?]
S3 MFE_RR;MFE_RR;\??\c:\docume~1\garrett\locals~1\temp\mfe_rr.sys --> c:\docume~1\garrett\locals~1\temp\mfe_rr.sys [?]
S3 ZD1211BU(Atheros);Atheros ZD1211B IEEE 802.11 Wireless LAN Driver (USB)(Atheros);c:\windows\system32\drivers\ZD1211BU.sys [2010-4-22 722432]
.
=============== Created Last 30 ================
.
2012-04-28 20:36:19 -------- d-----w- c:\documents and settings\garrett\local settings\application data\MapQuest Toolbar
2012-04-28 03:49:21 -------- d-----w- c:\program files\MapQuest Toolbar
2012-04-28 03:49:21 -------- d-----w- c:\documents and settings\all users\application data\MapQuest Toolbar
2012-04-28 03:49:09 -------- d-----w- c:\program files\common files\Software Update Utility
2012-04-28 03:38:55 -------- d-----w- c:\program files\IZArc
2012-04-28 03:38:55 -------- d-----w- c:\documents and settings\garrett\application data\OpenCandy
2012-04-25 05:47:07 2682 ----a-w- C:\cc_20120425_004705.reg
2012-04-25 05:10:53 94480 ----a-w- c:\windows\system32\drivers\tmcomm.sys
2012-04-25 04:25:50 10854 ----a-w- C:\cc_20120424_232548.reg
2012-04-22 05:07:46 -------- d-----w- c:\documents and settings\all users\application data\Sophos
2012-04-22 04:58:56 73728 ----a-r- c:\documents and settings\garrett\application data\microsoft\installer\{b829e117-d072-41ea-9606-9826a38d34c1}\SVRTgui.exe1_810EDD9E2F0A4E2BACF86673C38D9F48.exe
2012-04-22 04:58:56 73728 ----a-r- c:\documents and settings\garrett\application data\microsoft\installer\{b829e117-d072-41ea-9606-9826a38d34c1}\SVRTgui.exe_810EDD9E2F0A4E2BACF86673C38D9F48.exe
2012-04-22 04:58:56 73728 ----a-r- c:\documents and settings\garrett\application data\microsoft\installer\{b829e117-d072-41ea-9606-9826a38d34c1}\ARPPRODUCTICON.exe
2012-04-22 04:57:54 -------- d-----w- c:\program files\Sophos
2012-04-22 03:07:43 -------- d-sha-r- C:\cmdcons
2012-04-22 02:29:11 98816 ----a-w- c:\windows\sed.exe
2012-04-22 02:29:11 518144 ----a-w- c:\windows\SWREG.exe
2012-04-22 02:29:11 256000 ----a-w- c:\windows\PEV.exe
2012-04-22 02:29:11 208896 ----a-w- c:\windows\MBR.exe
2012-04-21 05:40:46 116224 -c--a-w- c:\windows\system32\dllcache\xrxwiadr.dll
2012-04-21 05:40:43 23040 -c--a-w- c:\windows\system32\dllcache\xrxwbtmp.dll
2012-04-21 05:40:41 18944 -c--a-w- c:\windows\system32\dllcache\xrxscnui.dll
2012-04-21 05:40:38 27648 -c--a-w- c:\windows\system32\dllcache\xrxftplt.exe
2012-04-21 05:40:34 4608 -c--a-w- c:\windows\system32\dllcache\xrxflnch.exe
2012-04-21 05:40:28 99865 -c--a-w- c:\windows\system32\dllcache\xlog.exe
2012-04-21 05:40:24 16970 -c--a-w- c:\windows\system32\dllcache\xem336n5.sys
2012-04-21 05:40:21 19455 -c--a-w- c:\windows\system32\dllcache\wvchntxx.sys
2012-04-21 05:40:15 12063 -c--a-w- c:\windows\system32\dllcache\wsiintxx.sys
2012-04-21 05:40:13 8192 -c--a-w- c:\windows\system32\dllcache\wshirda.dll
2012-04-21 05:38:55 11775 -c--a-w- c:\windows\system32\dllcache\wadv05nt.sys
2012-04-21 05:37:57 113762 -c--a-w- c:\windows\system32\dllcache\usrpda.sys
2012-04-21 05:36:57 50176 -c--a-w- c:\windows\system32\dllcache\umaxp60.dll
2012-04-21 05:35:58 31744 -c--a-w- c:\windows\system32\dllcache\tp4.dll
2012-04-21 05:34:57 172768 -c--a-w- c:\windows\system32\dllcache\t2r4disp.dll
2012-04-21 05:33:49 48736 -c--a-w- c:\windows\system32\dllcache\srwlnd5.sys
2012-04-21 05:32:57 12288 -c--a-w- c:\windows\system32\dllcache\EXCH_smtpctrs.dll
2012-04-21 05:31:57 50432 -c--a-w- c:\windows\system32\dllcache\sisv.sys
2012-04-21 05:30:59 17664 -c--a-w- c:\windows\system32\dllcache\sermouse.sys
2012-04-21 05:29:57 41216 -c--a-w- c:\windows\system32\dllcache\s3mt3d.sys
2012-04-21 05:28:42 19584 -c--a-w- c:\windows\system32\dllcache\rasirda.sys
2012-04-21 05:27:58 112574 -c--a-w- c:\windows\system32\dllcache\ptserlp.sys
2012-04-21 05:26:59 27904 -c--a-w- c:\windows\system32\dllcache\perm2.sys
2012-04-21 05:25:59 31872 -c--a-w- c:\windows\system32\dllcache\ovce.sys
2012-04-21 05:24:55 87040 -c--a-w- c:\windows\system32\dllcache\nm6wdm.sys
2012-04-21 05:23:58 128000 -c--a-w- c:\windows\system32\dllcache\n100325.sys
2012-04-21 05:23:55 52255 -c--a-w- c:\windows\system32\dllcache\n1000nt5.sys
2012-04-21 05:23:52 75520 -c--a-w- c:\windows\system32\dllcache\mxport.sys
2012-04-21 05:23:50 7168 -c--a-w- c:\windows\system32\dllcache\mxport.dll
2012-04-21 05:23:47 19968 -c--a-w- c:\windows\system32\dllcache\mxnic.sys
2012-04-21 05:23:44 19968 -c--a-w- c:\windows\system32\dllcache\mxicfg.dll
2012-04-21 05:23:41 21888 -c--a-w- c:\windows\system32\dllcache\mxcard.sys
2012-04-21 05:23:37 103296 -c--a-w- c:\windows\system32\dllcache\mtxvideo.sys
2012-04-21 05:23:25 49024 -c--a-w- c:\windows\system32\dllcache\mstape.sys
2012-04-21 05:23:19 12416 -c--a-w- c:\windows\system32\dllcache\msriffwv.sys
2012-04-21 05:23:10 2944 -c--a-w- c:\windows\system32\dllcache\msmpu401.sys
2012-04-21 05:23:07 22016 -c--a-w- c:\windows\system32\dllcache\msircomm.sys
2012-04-21 05:21:58 7424 -c--a-w- c:\windows\system32\dllcache\mammoth.sys
2012-04-21 05:20:59 37376 -c--a-w- c:\windows\system32\dllcache\kousd.dll
2012-04-21 05:19:34 372824 -c--a-w- c:\windows\system32\dllcache\iconf32.dll
2012-04-21 05:18:59 702845 -c--a-w- c:\windows\system32\dllcache\i81xdnt5.dll
2012-04-21 05:17:59 324608 -c--a-w- c:\windows\system32\dllcache\hpojwia.dll
2012-04-21 05:16:58 320384 -c--a-w- c:\windows\system32\dllcache\g200m.sys
2012-04-21 05:15:59 595647 -c--a-w- c:\windows\system32\dllcache\es56cvmp.sys
2012-04-21 05:14:59 26698 -c--a-w- c:\windows\system32\dllcache\dlh5xnd5.sys
2012-04-21 05:13:59 3712 -c--a-w- c:\windows\system32\dllcache\ctljystk.sys
2012-04-21 05:12:59 32256 -c--a-w- c:\windows\system32\dllcache\brmfrsmg.exe
2012-04-21 05:11:50 66048 -c--a-w- c:\windows\system32\dllcache\s3legacy.dll
2012-04-21 04:55:15 418464 ----a-w- c:\windows\system32\FlashPlayerApp.exe
2012-04-21 04:46:56 -------- d-----w- c:\windows\msdownld.tmp
2012-04-21 04:20:50 -------- d-----w- c:\program files\CrossLoop
2012-04-21 04:12:09 -------- d-----w- c:\documents and settings\garrett\application data\Auslogics
2012-04-21 04:12:05 -------- d-----w- c:\program files\Auslogics
2012-04-21 04:05:31 3614 ----a-w- C:\cc_20120420_230530.reg
2012-04-21 04:04:38 657434 ----a-w- C:\cc_20120420_230431.reg
2012-04-21 03:14:01 -------- d-----w- c:\documents and settings\garrett\local settings\application data\Temp
2012-04-21 02:24:36 -------- d-----w- c:\documents and settings\garrett\application data\Malwarebytes
2012-04-21 02:08:42 -------- d-----w- c:\program files\AVAST Software
2012-04-21 02:08:42 -------- d-----w- c:\documents and settings\all users\application data\AVAST Software
2012-04-21 02:06:08 -------- d-----w- c:\documents and settings\all users\application data\Malwarebytes
2012-04-21 02:06:05 22344 ----a-w- c:\windows\system32\drivers\mbam.sys
2012-04-21 02:06:05 -------- d-----w- c:\program files\Malwarebytes' Anti-Malware
2012-04-21 02:05:34 -------- d-----w- c:\program files\CCleaner
2012-04-21 02:04:02 -------- d-----w- c:\documents and settings\garrett\application data\SUPERAntiSpyware.com
2012-04-21 02:03:17 -------- d-----w- c:\program files\SUPERAntiSpyware
2012-04-21 02:03:17 -------- d-----w- c:\documents and settings\all users\application data\SUPERAntiSpyware.com
2012-04-04 05:53:56 182160 ----a-w- c:\program files\internet explorer\plugins\nppdf32.dll
.
==================== Find3M ====================
.
2012-04-21 04:55:15 70304 -c--a-w- c:\windows\system32\FlashPlayerCPLApp.cpl
2012-03-01 11:01:32 916992 ----a-w- c:\windows\system32\wininet.dll
2012-03-01 11:01:32 43520 ----a-w- c:\windows\system32\licmgr10.dll
2012-03-01 11:01:32 1469440 ------w- c:\windows\system32\inetcpl.cpl
2012-02-29 14:10:16 177664 ----a-w- c:\windows\system32\wintrust.dll
2012-02-29 14:10:16 148480 ----a-w- c:\windows\system32\imagehlp.dll
2012-02-29 12:17:40 385024 ----a-w- c:\windows\system32\html.iec
2012-02-03 09:22:18 1860096 ----a-w- c:\windows\system32\win32k.sys
.
============= FINISH: 15:49:28.96 ===============

Attached Files



BC AdBot (Login to Remove)

 


#2 nasdaq

nasdaq

  • Malware Response Team
  • 38,753 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Montreal, QC. Canada
  • Local time:09:36 PM

Posted 03 May 2012 - 09:37 AM

Hello, Welcome to BleepingComputer.
I'm nasdaq and will be helping you.

If you can please print this topic it will make it easier for you to follow the instructions and complete all of the necessary steps.
===

Everytime I start IE it says that it is not the default browser.

Go to Menu Tools > Internet Options > Programs tab.
Change the settings under "Default Browser"

===

Please download ComboFix from one of these locations:

Link 1
Link 2

* IMPORTANT !!! Save ComboFix.exe to your Desktop

  • Disable your Anti-Virus and Anti-Spyware applications, usually via a right click on the System Tray icon. They may otherwise interfere with our tools
  • Double click on ComboFix.exe & follow the prompts.
  • As part of it's process, ComboFix will check to see if the Microsoft Windows Recovery Console is installed. With malware infections being as they are today, it's strongly recommended to have this pre-installed on your machine before doing any malware removal. It will allow you to boot up into a special recovery/repair mode that will allow us to more easily help you should your computer have a problem after an attempted removal of malware.
  • Follow the prompts to allow ComboFix to download and install the Microsoft Windows Recovery Console, and when prompted, agree to the End-User License Agreement to install the Microsoft Windows Recovery Console.
  • Some Rookit infection may damage your boot sector. The Windows Recovery Console may be needed to restore it. Do not bypass this installation. You may regret it.

**Please note: If the Microsoft Windows Recovery Console is already installed, ComboFix will continue it's malware removal procedures.

Posted Image


Once the Microsoft Windows Recovery Console is installed using ComboFix, you should see the following message:

Posted Image

Click on Yes, to continue scanning for malware.

When finished, it shall produce a log for you. Please include the C:\ComboFix.txt in your next reply.

Note: If you have difficulty properly disabling your protection programs, refer to this link --> http://www.bleepingcomputer.com/forums/topic114351.html

Do not mouse click ComboFix's window while it's running. That may cause it to stall
===

Third party programs if not up to date can be an open door for an infection

Please run this security check for my review.

Download Security Check by screen317 from here.
  • Save it to your Desktop.
  • Double click SecurityCheck.exe and follow the onscreen instructions inside of the black box.
  • A Notepad document should open automatically called checkup.txt; please post the contents of that document.
===

#3 Ribo3

Ribo3
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:08:36 PM

Posted 03 May 2012 - 01:19 PM

Ok, thanks for the reply. I did both steps that you asked. Here are noteworthy comments.

Recovery console is installed.

ComboFix displayed a message that it had detected the presence of rootkit activity and needed to reboot the machine. I let it reboot and then finish running and then it created the log posted below.

IE still said that it was not the default browser.

Security Check checkup.txt is also posted below.

Let me know if I need to do anything else.

Attached Files



#4 nasdaq

nasdaq

  • Malware Response Team
  • 38,753 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Montreal, QC. Canada
  • Local time:09:36 PM

Posted 04 May 2012 - 08:05 AM

Open notepad and copy/paste the text in the quote box below into it:

Driver::
APR
MEMSWEEP2
MFE_RR

ClearJavaCache::


Save this as CFScript.txt on your desktop.

Posted Image

Referring to the picture above, drag CFScript into ComboFix.exe
Then post the resultant log.
===

Secure your system by updating 3rd party programs.

Your version of Java is outdated and needs to be updated to take advantage of fixes that have eliminated security vulnerabilities.

Check your present version and update as recommended.
https://www.java.com/en/download/installed.jsp

If present remove the old version(s) of Java using the Add/Remove Programs applet.


Java™ 6 Update 30


===

Critical vulnerabilities have been identified in Adobe Flash Player 10.3.183.10 and earlier versions... being exploited in the wild in active targeted attacks...

Get the latest Flash Player

On the top of the page you will be given an opportunity to download the version for your operating system.
Make sure you select appropriate version.

You will also have an option to install the Free! McAfee Security Scan Plus Un-check the box if you are NOT using McAfee's virus protection software.

For the users of Internet Explorer download version 11.
Flash Player 11 (64 bit)
Flash Player 11 (32 bit)
===

Concerning DirectX

Have you seen the Microsoft page?
Did your try to download and run the installer?

If still unable to install what error message do you get while trying?
Post it if you can.

Post the ComboFix log for my review.

#5 Ribo3

Ribo3
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:08:36 PM

Posted 05 May 2012 - 11:47 PM

Ok did, what you said.

First time I ran ComboFix with the script it told me that a new version of CF was available and do I want to download it. I said yes, it downloaded it and did the same thing it did before. Gave the warning that Rootkit Activity was detected and that it needed to reboot. So I let it. That log is posted below as Log1.

I wasn't sure about the upgrade thing working with the script thing so I went ahead and downloaded the new version of CF myself and then ran it again with the script. same warning and reboot. That log is posted below as Log2.

As for DirectX, yes I have seen the Microsoft Page (and many others). The MS page is where I got the installation package. I have tried every solution to that that I can find. Including checking the crypto graphic services and delete them temporary installer files with no success.

If it was just the DirectX problem I would think I had some configuration setting or system file hosed up. But the warning from IE everytime I reboot about it not being the default. that is what bugs me.

Can you see anything in the logs? I also attached a screen shot of the direct X error message.

Attached Files



#6 nasdaq

nasdaq

  • Malware Response Team
  • 38,753 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Montreal, QC. Canada
  • Local time:09:36 PM

Posted 06 May 2012 - 09:34 AM

Delete these .reg files and keep them in your recycle bin.
I'm not sure what they are.
Could they be generated each time you try to install DirectX?

2012-05-02 04:05 . 2012-05-02 04:05 6472 ----a-w- C:\cc_20120501_230551.reg
2012-04-25 05:47 . 2012-04-25 05:47 2682 ----a-w- C:\cc_20120425_004705.reg
2012-04-25 04:25 . 2012-04-25 04:25 10854 ----a-w- C:\cc_20120424_232548.reg
2012-04-21 04:05 . 2012-04-21 04:05 3614 ----a-w- C:\cc_20120420_230530.reg
2012-04-21 04:04 . 2012-04-21 04:05 657434 ----a-w- C:\cc_20120420_230431.reg
===


I know you have tried many thing to get DirectX to install but did you try the fix on this page?
I mean registring the files?
http://answers.microsoft.com/en-us/windows/forum/windows_other-windows_update/a-cabinet-file-necessary-for-installation-cannot/9b007762-f6be-4837-928d-59a98378e465
===

These lines in our ComboFix could be an issue.

disk not found C:\
.
please note that you need administrator rights to perform deep scan


Right click on the ComboFix.exe and run as and administrator.
If the remark is still present in the new log run this tool.

Please download this ListPart.exe to a folder of you choice. Select the proper tool for your system.

For x86 (x32) bit systems please download Listparts
For x64 bit systems please download Listparts64
Run the tool as an Administrator , click Scan and copy and post the log (Result.txt) in your next reply.

#7 Ribo3

Ribo3
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:08:36 PM

Posted 06 May 2012 - 10:50 AM

Those registry files are CCleaner backup files. I can delete them though No big deal.

I have tried the DLL unreg and reg solution. Didn't work.

I saw the line about the C: drive too. I think I tried to run GMER or CatchMe or something before and saw that same line. I thought that was concerning as well.

There is a version of DiskKeeper installed on this system. Could that cause a problem?

I'll post the ListPart log as soon as I can.

Thanks

#8 nasdaq

nasdaq

  • Malware Response Team
  • 38,753 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Montreal, QC. Canada
  • Local time:09:36 PM

Posted 06 May 2012 - 12:21 PM

I would like to see the partitions on your drive.

Run the Listpart tool I previously requested.
===

Lets see what .cab files are present on your computer.

Please download SystemLook from one of the links below and save it to your Desktop.
Download Mirror #1
Download Mirror #2


If your operating system is 64 bit download this tool:
SystemLook_x64.exe
  • Double-click SystemLook.exe to run it.
  • Copy and paste the content of the following bold text into the main textfield:


    :filefind
    *.cab

  • Click the Look button to start the scan.
  • When finished, a notepad window will open with the results of the scan. Please post this log in your next reply.
Note: The log can also be found on your Desktop entitled SystemLook.txt

#9 Ribo3

Ribo3
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:08:36 PM

Posted 06 May 2012 - 12:26 PM

Here is the list part log and new combofix log.

This is 32 bit XP home with only one user, so I don't have the Run as administrator option. I can do a "Run As" then select current user and uncheck the box to Protect operating system files or whatever it says. So I did that on this run of CF.

I'll do the other step in a second.

Attached Files



#10 Ribo3

Ribo3
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:08:36 PM

Posted 06 May 2012 - 12:36 PM

systemlook log

#11 Ribo3

Ribo3
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:08:36 PM

Posted 06 May 2012 - 12:38 PM

systemlook log

Attached Files



#12 nasdaq

nasdaq

  • Malware Response Team
  • 38,753 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Montreal, QC. Canada
  • Local time:09:36 PM

Posted 06 May 2012 - 01:12 PM

Your last run of ComboFix shows that the user32.dll in the user profile was desinfected.

Infected copy of c:\windows\system32\user32.dll was found and disinfected
Restored copy from - c:\windows\ERDNT\cache\user32.dll


Did that change anything?


C:\Program Files\Steam\steamapps\common\just cause 2 demo\directX\APR2007_xinput_x86.cab --a---- 53294 bytes [05:00 05/02/2012] [05:01 05/02/2012] 6B1663466CB4CDB8AD779BCADE31999D
C:\Program Files\Steam\steamapps\common\just cause 2 demo\directX\Aug2009_d3dx10_42_x86.cab --a---- 192131 bytes [05:31 05/02/2012] [05:33 05/02/2012] 9874FEE186CE25DB85BA38B072763257
C:\Program Files\Steam\steamapps\common\just cause 2 demo\directX\dxdllreg_x86.cab --a---- 44440 bytes [04:56 05/02/2012] [04:56 05/02/2012] FCFAF7BB73CC636FB619289BFB0058CE
C:\Program Files\Steam\steamapps\common\just cause 2 demo\directX\dxupdate.cab --a---- 95637 bytes [05:33 05/02/2012] [05:36 05/02/2012] E52ED09FBDFBB180315362C1341E0664

These are the .cab files recently downloaded. Delete them and keep them in your recycle bin until this is working.
===

I'm not an expert in DirectX but I know that there is a tool to diagnoze the program.
It may help in identifying the problem.


Could you post some of the DxDiag output? To get it, do this:

* Run dxdiag
* When it's done, click on the "Save all information" button
* Open the file DxDiag.txt (created on the desktop by default)
* Copy the part from start to halfway through "Display Devices" (make sure you include the driver version part!)
* Paste it into a new post
p.s.
Please inclose your post in a Code box. Do not attach it.

#13 Ribo3

Ribo3
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:08:36 PM

Posted 06 May 2012 - 08:48 PM

OK, things are looking good.

I had seen that userinit line in the CF logs before and thought it would mean something but then I was still having trouble.

I was really putting DirectX on the back-burner and wanted to make sure the PC was completely disinfected. The IE pop-ups about not being the default browser were bothering me. THOSE POP-UPS SEEM TO BE GONE!!! Maybe CF finally got it.

So then I went on to DirectX and worked through that link on answers.microsoft.com again. This time I was able to get it to work. The fix was to delete all the cab files in the system32\directx\dxwebsetup folder but I had to follow fatboie's suggestion pretty far down the page to "unhide" that folder. After that DirectX installed successfully.

So it appears now that all the problems are solved. I appreciate your assistance.

Last question. What AV software do you personally recommend? Any of the free versions? (Avast, Avira or AVG)

#14 nasdaq

nasdaq

  • Malware Response Team
  • 38,753 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Montreal, QC. Canada
  • Local time:09:36 PM

Posted 07 May 2012 - 08:50 AM

Last question. What AV software do you personally recommend? Any of the free versions? (Avast, Avira or AVG)


Any one of them is good.
The principle is to keep it up to date.
Install only one of them.

===

Time for some housekeeping

The following will implement some cleanup procedures as well as reset System Restore points:

Click Start > Run and copy/paste the following bold text into the Run box and click OK:

ComboFix /Uninstall
===

Delete the other tools we used.

#15 Ribo3

Ribo3
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:08:36 PM

Posted 09 May 2012 - 09:58 AM

Done with the uninstall of CF and have new AV software installed. Everything seems to be working well now.

One last follow up comment...

It appears that the last run of CF got whatever it was on my system but I am not sure if it was the updated version of CF that got it or if it was because I updated the other software on the system. I had just done an upgrade of Java from 6.28 to 6.30 and also updated Adobe Flash and Reader.

Possibly updating those programs allowed CF to find and fix the infection.

Just wanted to stress that to anyone else it may benefit.

Thanks to nasdaq for reminding of that.

I still wonder if DiskKeeper wasn't causeing some of the strange behavior from CF and GMER. Oh well, it's working now so I'm not messing with anything else.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users