Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Lenovo Y430 touchpad/mouse not working


  • Please log in to reply
2 replies to this topic

#1 thefeintinggoat

thefeintinggoat

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:10:21 PM

Posted 27 April 2012 - 10:06 PM

Hi all. I hope I'm posting this in the right place.

I'm using Windows Vista Home Premium Version 6.0, (Build 6602: SP 2) on a Lenovo Y430 laptop.

Bit of an odd problem that started when I tried to start up a game of Diablo 2, a program which was already installed on the computer. Clicking on just the icon was unresponsive, and after a few times, I put the disc in and tried to uninstall and reinstall (the program hadn't been used in some time, and well, I'm not really sure what I was thinking doing that). I wasn't able to find the CD key, so I canned the reinstall, and then about 7-8 errors popped up saying something along the lines of there could only be one instance of Diablo 2 running at a time.
It was either during this, or perhaps during the install portion (I don't remember) that my mouse stopped working. I could hover over things, even click them, but the cursor wasn't displaying. It's a touchpad kind, not a ball kind, if that makes any difference.

So, first thing I tried was to update the mouse drivers through the device manager. Nothing changed. Second was to uninstall and reinstall the drivers (I rebooted between the two). Nothing happened after this. And after either the first or second reboot, I couldn't even hover over things and click them. Tried a system restore, and this seemed to hang, so I did a hard reboot (not the wisest idea, I'm aware). The chkdsk fixed some things (was going too fast for me to jot down) and rebooted as normal, only this time in safe mode. Mouse was not functioning at this time. I managed to complete a system restore in safe mode to a period several months before, to alleviate any possible problems, and everything seems normal except the mouse does not work.

So, I'm out of ideas.
When the power save turns the display off, touching the mouse will not bring it back up, so I'm thinking it doesn't even recognize it. The keyboard is functional. When I go into the device manager, I see two options, a "HID-compliant mouse" and a "PS/2 Compatible Mouse." I have no idea what was there before I inserted the Diablo 2 disc. I'm not sure where to get any more information on the mouse device itself beyond what's below.

PS/2 Compatible Mouse
Microsoft, "plugged into PS/2 Mouse port," driver date 6/21/06, driver version 6.0.6001.18000, signed by microsoft windows.

HID-compliant Mouse
Microsoft, "on Microsoft eHome infrared transceiver," driver date 6/21/06, driver version 6.0.6001.18000, signed by microsoft windows.

I have tried updating each individually, uninstalling and reinstalling each individually, and uninstalling both and reinstalling both. No combination I can put together seems to work. When I look at both in the device manager, it states they are working properly.

Any and all help would be appreciated, and thank you in advance.

BC AdBot (Login to Remove)

 


#2 thefeintinggoat

thefeintinggoat
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:10:21 PM

Posted 28 April 2012 - 08:03 AM

D'oh! Don't I feel silly. Was just a matter of finding the right function key. Thought it was f6, but apparently it was f8.

Problem resolved.

#3 hamluis

hamluis

    Moderator


  • Moderator
  • 55,874 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:10:21 PM

Posted 28 April 2012 - 11:48 AM

Thanks for letting us know...happy computing :).

Louis




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users