Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Cpu Pegs At 100%


  • Please log in to reply
11 replies to this topic

#1 Albert Frankenstein

Albert Frankenstein

  • Members
  • 2,707 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Michigan, USA
  • Local time:02:16 PM

Posted 24 February 2006 - 03:25 PM

Hi ya all!

I have a laptop, XP Home, 2.0 GHz, 512 MB RAM. This computer works well, except when I play DVDs. It usually works well for a few minutes, but then the DVD starts to act jumpy, freezing, starting, etc. I noticed the CPU is pegged out at 100% when this is happening, and sometimes I see that the DVD playing software is using approx. 50% and then Explorer is using the other 50%. Or sometimes I have seen the DVD software at 85% and task manager at 15%.

So far I have scanned for malware and came up empty, except for cookies. I have uninstalled the DVD software (WinDVD 4.0) and installed a newer version (WinDVD 5.0) and have the same results. This machine more than meets the minimum requirements for the software.

This happens everytime I play a DVD on this machine.

Don't know if this is really an XP problem, but I am not sure, and that is the point. I need some help. Thanks!
ALBERT FRANKENSTEIN
I'M SO SMART IT'S SCARY!


Currently home chillin' with the fam and my two dogs!


BC AdBot (Login to Remove)

 


#2 River_Rat

River_Rat

  • Members
  • 773 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:SW Oklahoma - USA
  • Local time:01:16 PM

Posted 24 February 2006 - 11:10 PM

Hello Albert
Does it do this with every DVD you try???
Does it play music CD's alright???
How old & used is your ROM Drive???
Are your Video Drivers up-to-date???
Check for Chipset Driver updates for your MB.

#3 Enthusiast

Enthusiast

  • Members
  • 5,898 posts
  • OFFLINE
  •  
  • Location:Florida, USA
  • Local time:01:16 PM

Posted 25 February 2006 - 12:32 AM

What kind of video card does the computer have (integrated with no ram of its own or ?), and does anything abberrent show up in the device manager?

If it's integrated graphics set the bios to limit how much system ram it can use.

#4 Albert Frankenstein

Albert Frankenstein
  • Topic Starter

  • Members
  • 2,707 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Michigan, USA
  • Local time:02:16 PM

Posted 25 February 2006 - 06:48 AM

Does it do this with every DVD you try???
Yes.
Does it play music CD's alright???
No, actually it doesn't. The sound is jumpy. But the cpu never gets above 65% even though it does not sound smooth at all.
How old & used is your ROM Drive???
This Sony Vaio computer is a couple of years old.
Are your Video Drivers up-to-date???
Yes. There actually is a video driver update available that is supposed to fix three known issues, none are related to my issue, but I updated it anyway. No difference.
Check for Chipset Driver updates for your MB.
None available.
What kind of video card does the computer have (integrated with no ram of its own or ?), and does anything abberrent show up in the device manager?
Well, it's a laptop so it is intregrated. The only 'abberrent' thing I see in the device manager is that the secondary IDE channel is set up for PIO transfer mode and cannot be changed to DMA mode. The primary channel is set to Ultra DMA mode 5. (there is one device on each channel, so I am guessing that the HD is on the primary - DMA mode- and the DVD player is on the secondary channel - PIO mode.)
If it's integrated graphics set the bios to limit how much system ram it can use.? I don't see anything in the bios that will allow me to adjust this. It is a pretty simple bios. I did reset to default settings. No difference.

A couple of other things I have tried as I am stabbing in the dark:
  • I know that some programs don't work right with SP2 installed, so I uninstalled SP2. No difference.
  • Sony offers a MS hotfix for SP1 for computers whose CPUs peg out at 100%, so I installed the hotfix. No difference. (I really didn't think it would work as this hotfix is a part of SP2).
  • I changed the video settings to 16 color (from 32 color). No difference.
  • I ran a cleaning disk in the CD/DVD drive (I told you I was stabbing in the dark :thumbsup:)
  • I also stopped all other programs from running while playing DVD's, but no difference.
Again, it will play a video just fine for about a minute or so, then the problems start.

Thanks for all of your ideas so far.

Edited by Albert Frankenstein, 25 February 2006 - 06:55 AM.

ALBERT FRANKENSTEIN
I'M SO SMART IT'S SCARY!


Currently home chillin' with the fam and my two dogs!


#5 River_Rat

River_Rat

  • Members
  • 773 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:SW Oklahoma - USA
  • Local time:01:16 PM

Posted 25 February 2006 - 09:16 AM

Here ya go Albert:

See:
http://www.michna.com/kb/WxDMA.htm

#6 Albert Frankenstein

Albert Frankenstein
  • Topic Starter

  • Members
  • 2,707 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Michigan, USA
  • Local time:02:16 PM

Posted 25 February 2006 - 10:23 AM

Thanks so much, River Rat! That was a great fix. Now the secondary channel is in Ultra DMA mode again!

However, my problems persist. Here is a screenshot showing the CPU usage over the first minute or so of playing a DVD:

Posted Image


ALBERT FRANKENSTEIN
I'M SO SMART IT'S SCARY!


Currently home chillin' with the fam and my two dogs!


#7 River_Rat

River_Rat

  • Members
  • 773 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:SW Oklahoma - USA
  • Local time:01:16 PM

Posted 25 February 2006 - 10:53 AM

Did you pay close attention to this section & still no joy...???

The trap
Windows contains a trap in which quite a few computers seem to get caught sooner or later. The trap was described in a Web article whose link no longer works (and also in another one mentioned below):

The crucial paragraphs are:

PIO mode is enabled by default in the following situations:
...
For repeated DMA errors. Windows XP will turn off DMA mode for a device after encountering certain errors during data transfer operations. If more that six DMA transfer timeouts occur, Windows will turn off DMA and use only PIO mode on that device.

In this case, the user cannot turn on DMA for this device. The only option for the user who wants to enable DMA mode is to uninstall and reinstall the device.

Windows XP downgrades the Ultra DMA transfer mode after receiving more than six CRC errors. Whenever possible, the operating system will step down one UDMA mode at a time (from UDMA mode 4 to UDMA mode 3, and so on).
...

Of course, drive firmware being quite complex and certainly containing programming defects of its own, it is not all that difficult to produce such errors. In my case a scratched DVD and later also an unreadable (overburned) CD did the trick, got the drive to choke and Windows to disable DMA for good. Later my hard disk hiccupped just once and also went back to PIO for good.

I had been using my laptop for DVD viewing for years, until I inserted a borrowed and heavily scratched DVD. The player and apparently even the DVD drive choked on it, and when I finally got the DVD to play, I found that playing was jerky and processor load was 100%, roughly half of which was system overhead.

This indicated that the drive had reverted from the usual UDMA (Ultra Direct Memory Access) mode 2 to PIO (Programmed Input Output) mode. No amount of resetting or changing the relevant registry parameters from 1 (try DMA) to 2 (force DMA) helped. Stubbornly the drive kept using PIO mode, and Windows even changed these settings back to 0 (use PIO only).

The following text will refer to the secondary IDE port because that is more often affected, but essentially the same also holds for the primary IDE port, to which the main hard disk is connected in most computers.

Before you begin to work on the problem, log on as Administrator or as a user with administrator rights.



#8 Albert Frankenstein

Albert Frankenstein
  • Topic Starter

  • Members
  • 2,707 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Michigan, USA
  • Local time:02:16 PM

Posted 25 February 2006 - 03:05 PM

Yes, River Rat I read the article and then applied the downloadable fix, and it appeared to have worked in the sense that the secondary IDE channel was now working in Ultra DMA mode again, at least according to the device manager. But the problem persisted. (unless I am missing something in the article and don't understand what you are asking)

I found this Microsoft KB article: http://support.microsoft.com/kb/817472/en-us

And I followed the advice of uninstalling the secondary IDE channel from the device mangaer, rebooting, allowing XP to reinstall the secondary IDE channel and DVD drive. Rebooted. Then when I played another DVD the CPU usage did not get above 36% for about 5 minutes or so and it appeared it was resolved. But then it drifted right back up to 100% and got jerky again.

I stopped the DVD, looked in device manager and it is still saying the secondary IDE controller is in Ultra DMA mode. Hmmmmmmmm <scatches head>

Other things I have tried in the meantime: I reinstalled SP2 from a disk. And I ran a sfc /scannow just in case. No difference.

EDIT - ADDITIONAL INFO: I am coming to the conclusion that I have a hardware issue now. Reason being, I have tried everything in the article that River Rat supplied as well as the Microsoft KB article and I continue to have issues. The pieces of hardware at issue here are the DVD drive, the cable, the motherboard. I do not have another DVD drive that will fit this machine so I can't test it that way. Not really sure where to go with this now. ???

Edited by Albert Frankenstein, 25 February 2006 - 03:38 PM.

ALBERT FRANKENSTEIN
I'M SO SMART IT'S SCARY!


Currently home chillin' with the fam and my two dogs!


#9 River_Rat

River_Rat

  • Members
  • 773 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:SW Oklahoma - USA
  • Local time:01:16 PM

Posted 25 February 2006 - 04:05 PM

No not saying anything special.
Only thing you might try is the registry edit and let Windows recreate the values.

Check Your IDE Port Mode
First check what mode your secondary IDE port is currently working in. Go to Device Manager: right-click on My Computer, select Properties, click on the Hardware tag, click on the Device Manager button, click on the plus sign to the left of IDE ATA/ATAPI Controller, double-click on the secondary IDE channel, click on Extended Settings and check whether it is set to DMA when available. Directly underneath that setting is a grey field that shows the actual working mode of your IDE channel. You want the highest possible DMA or Ultra DMA mode there, and you definitely don't want PIO mode.

Normally you don't have to use the registry editor for this, because the normal settings are also available through the properties dialog for the IDE port, but if you want to look at it anyway, the parameter for the secondary IDE port can be found through regedit.exe at

HKEY_LOCAL_MACHINE\HARDWARE\DEVICEMAP\Scsi\Scsi Port 1

It is named Scsi only for historic reasons. Scsi Port 0 is the primary IDE port, to which presumably your hard disk is connected.

After trying various remedies—in vain—I found the abovementioned article and went to work again. I uninstalled the DVD drive in Device Manager and rebooted, but that did not help either.

So I searched for more and better information, then I went on and did the following.

Re-enable DMA using the Registry Editor
My thanks go to my fellow MVP Alexander Grigoriev who taught me this method.

Run REGEDIT. Go to the following key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}

It has subkeys like 0000, 0001, 0002, etc. Normally 0001 is the primary IDE channel, 0002 the secondary, but other numbers can occur under certain circumstances. You have to go through these subkeys and check the DriverDesc value until you find the proper IDE channel.

Delete MasterIdDataChecksum or SlaveIdDataChecksum, depending on whether the device in question is attached as master or slave, but it can't actually hurt to delete both. Reboot. The drive DMA capabilities will be redetected.

2006-01-19 – Horst Schülke wrote that it is sufficient to empty the content of these values. But you can also delete the values entirely. Windows will automatically recreate them anyway, with new content.

Open Device Manager again and check whether the device is now actually using DMA mode. If so, congratulations, you've made it (at least until the next time Windows disables DMA).

2005-10-24 – Tomáš Souček wrote, if this doesn't work, check also the dword value MasterDeviceTimingModeAllowed, whose default value is hex 0xFFFFFFFF. If you have a much smaller value, you can try to set it back to its default and reboot for a test.



#10 Albert Frankenstein

Albert Frankenstein
  • Topic Starter

  • Members
  • 2,707 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Michigan, USA
  • Local time:02:16 PM

Posted 25 February 2006 - 04:47 PM

Only thing you might try is the registry edit and let Windows recreate the values.

Yeah, I did all of that. ??? - again, leaning towards hardware.
ALBERT FRANKENSTEIN
I'M SO SMART IT'S SCARY!


Currently home chillin' with the fam and my two dogs!


#11 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,091 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:02:16 PM

Posted 25 February 2006 - 07:36 PM

Did you try disabling any "special" settings in your display (particularly hardware acceleration)?
My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.

#12 Albert Frankenstein

Albert Frankenstein
  • Topic Starter

  • Members
  • 2,707 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Michigan, USA
  • Local time:02:16 PM

Posted 28 February 2006 - 12:59 PM

Did you try disabling any "special" settings in your display (particularly hardware acceleration)?

Thanks for that idea. Yes, I did slow it down a couple of notches, and that did help some.

I can play for about 5 minutes or so before problems start, then I have to shut down the program, restart the program and get another 5 minutes, etc.

Thanks a lot for all of your help! I will just accept this the way it is until I can get a replacement DVD player for it and hope that takes care of the issue.
ALBERT FRANKENSTEIN
I'M SO SMART IT'S SCARY!


Currently home chillin' with the fam and my two dogs!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users