Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

stubborn screen res, ubuntu 10.04


  • Please log in to reply
16 replies to this topic

#1 Alpsoandso

Alpsoandso

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Local time:12:26 PM

Posted 23 April 2012 - 01:51 PM

I had a problem a while ago getting the screen resolution to where I like it. I had to manually install the nvidia driver. Ubuntu would not allow me to go (absolutely no option for) over 800x600 if I remember correctly, possibly lower.
I have a nvidia gtx 550 ti graphic card.
On my other computer, with a nvidia 6600 gt I have had no problems what so ever with 10.04 and the display. I do not know why.

My problem.... I am able to boot into x. it always comes up 800x600 and "auto" for the refresh rate. I have to go into System/preferences/nvidia x server settings and change the res to 1024x768 85 hz.
A few times I went in as root (sudo nvidia-settings) and changed the settings to 1024x768 85 hz. I saved the new settings several times as root to xorg.conf (either merge checked or not checked) but every time, if I log out or shut down then log back in again, it is back to 800x600 and "auto" in the nvidia-settings.

I tried to edit the xorg.conf file and removed all but the first resolution from " Option "metamodes" "1024x768_85 +0+0; 1024x768 +0+0; nvidia-auto-select +0+0""
shortening it to Option "metamodes" "1024x768_85 +0+0
but that did not work either. So I changed it back.

Is there another file besides xorg.conf I have to edit?

What do I have to do to get this fixed?

BTW, not a noob, I can do some simple stuff and follow simple explicit instructions (how I managed to install the nvidia drivers manually, step by step off a web page), but that's about it.

I have attached my xorg.conf....
Thanks.

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 295.33 (buildmeister@swio-display-x86-rhel47-08.nvidia.com) Sat Mar 17 15:58:15 PDT 2012


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"

# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "ViewSonic A71f+"
HorizSync 30.0 - 72.0
VertRefresh 50.0 - 160.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GTX 550 Ti"
EndSection

Section "Screen"

# Removed Option "metamodes" "1024x768_85 +0+0; nvidia-auto-select +0+0"
# Removed Option "metamodes" "1024x768 +0+0; 1024x768_85 +0+0; nvidia-auto-select +0+0"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "TwinViewXineramaInfoOrder" "CRT-1"
Option "metamodes" "1024x768_85 +0+0; 1024x768 +0+0; nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

BC AdBot (Login to Remove)

 


#2 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:08:26 PM

Posted 23 April 2012 - 02:08 PM

You shouldn't have had to install the driver manually, you need to enable the restricted mode drivers:

Please see this site for more information: http://www.psychocats.net/ubuntu/nvidia

Upon successful installation, it will set everything up.

#3 Alpsoandso

Alpsoandso
  • Topic Starter

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Local time:12:26 PM

Posted 23 April 2012 - 04:11 PM

This was EXACTLY my effort for a good 1/2 a day.
It did not work.
I do not remember exactly what was wrong but I think the graphic card was not detected or no options were available to choose from. On my other computer this is working 100% and is completely idiot proof. Not so on my newer 64 bit system where it did not function.

So... I installed manually. Progress was made but there remains a problem.
I would rather move forward than go back and try to repair something that should have worked but did not. I was getting extremely upset and frustrated with a feature that should have worked but was not doing what it was supposed to.
Installing the drivers manually was relatively easy in comparison to my efforts with fixing the original problem.

So... why is it getting reset to 800x600 every login?

#4 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:08:26 PM

Posted 23 April 2012 - 05:41 PM

When you enabled the nVidia Card, how did you do and did you also enable the restricted content? I have never had an issue caused like this, maybe your ubuntu installation is corrupted.

#5 Alpsoandso

Alpsoandso
  • Topic Starter

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Local time:12:26 PM

Posted 24 April 2012 - 10:09 AM

That you have not ever had an issue like this is not the problem and does not mean that the (ubuntu/linux) system is perfect.

I am not going to remember how I enabled the card after 3 weeks. I followed step by step from a web page.
As far as a broken install.... from ubuntu's own webpage I quote

"Sometimes using the drivers in the Ubuntu repositories is not the best option. Here are some reasons to install the NVIDIA restricted drivers manually:

your card is too new, and is not supported by the Ubuntu provided binary packages.
bugs are present in provided packages that are fixed in later drivers not yet distributed by Ubuntu.
newer drivers provide a new feature not yet available in the Ubuntu packages. "

My card is likely too new.

I came across another person commenting that there are a lot of issues with new nvidia cards and ubuntu, I'd love to quote from that as well but I do not save every link I visit.

The system boots up to a login screen at 1024x768, EXACTLY what I want. When I login it switches to 800x600 which is what I do NOT want.
WHY is it switching resolution? I would expect it would be a simple matter to resolve for a knowledgable person.

#6 Alpsoandso

Alpsoandso
  • Topic Starter

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Local time:12:26 PM

Posted 24 April 2012 - 10:31 AM

I found some of my notes, I did something along these lines....

sudo apt-get update
sudo apt-get install build-essential gcc-4.5 g++-4.5 libxi-dev libxmu-dev freeglut3-dev
sudo apt-get install linux-headers-'2.6.32-40-generic'
sudo nvidia-installer --uninstall
sudo apt-get remove --purge nvidia-*

sudo gedit /etc/modprobe.d/blacklist.conf
add lines:

blacklist vga16fb
blacklist rivafb
blacklist rivatv
blacklist nouveau
blacklist lbm-nouveau
blacklist nvidiafb
blacklist nvidia-173
blacklist nvidia-96

and save.

Download Newest Nvidia drivers (nvidia-Linux-x86_64-295.33.run

shut down xorg (do not remember how I did it, maybe sudo service gdm stop.

mark the nvidia file as executable
sudo chmod a+x NVIDIA-Linux-x86-270.41.19.run

install
sh nvidia-Linux-x86_64-295.33.run

sudo gdm start

open up the nvidia settings. set screen to 1024x768.
but it won't stay 1024x768, every time I log in it is back to 800x600, even after writing to xorg.conf. The login screen is 1024x768, but after I log in it goes 800x600.

I understand that nouveau and the nvidia drivers do not get along. I do not recall what steps I took to uninstall or disable nouveau.

Can someone help?

#7 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:08:26 PM

Posted 24 April 2012 - 11:17 AM

If your screen is not saving to your selected login then something is wrong with your profile:

Here is the process to enable GeForce Drivers:

https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia?action=show&redirect=RestrictedDrivers%2FNVIDIA

That worked for me and my GTX 580

Also do you recall what website you were at, because they may have gave you the wrong information.

#8 Alpsoandso

Alpsoandso
  • Topic Starter

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Local time:12:26 PM

Posted 27 April 2012 - 09:46 PM

I tried this bleeping method several times. It does not work. It comes up with no choices. It is empty. No options are shown. etc....

Hence the manual install of the drivers!

Thanks

#9 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:08:26 PM

Posted 27 April 2012 - 10:09 PM

Is xorg.conf readable by you?

#10 Alpsoandso

Alpsoandso
  • Topic Starter

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Local time:12:26 PM

Posted 28 April 2012 - 11:20 PM

Yes it is readable by me.

Maybe I can help you to help me....
It is in the first post of this thread.

Edited by Alpsoandso, 28 April 2012 - 11:27 PM.


#11 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:08:26 PM

Posted 29 April 2012 - 12:17 PM

Can you do a ls -la | grep xorg.conf and paste the contents of what the output?

In order to edit the xorg.conf file you need to be super user or root.

#12 Alpsoandso

Alpsoandso
  • Topic Starter

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Local time:12:26 PM

Posted 01 May 2012 - 02:08 AM

I tried to do as you asked.
I typed in

ls -la | grep xorg.conf

exactly as printed above, non-root. It generated nothing, I got another cursor prompt. I ran it as root. and got a permision denied. I tried this twice. Same result bothe times.
I cut and pasted the results...

alp@Sabretooth:~$ ls -la | grep xorg.conf
alp@Sabretooth:~$ sudo ls -la | grep xorg.conf
ls: cannot access .gvfs: Permission denied
alp@Sabretooth:~$ ls -la | grep xorg.conf
alp@Sabretooth:~$ sudo ls -la | grep xorg.conf
ls: cannot access .gvfs: Permission denied
alp@Sabretooth:~$

Strange.
Perhaps I am using the wrong pipe symbol. I do not do this often enough to remember. Is it the

|
\

key just over the enter key?


Someone else I am communicating with suggested I generate a nvidia-bug-report.log.gz file and send it to him. It is 75 KB long. Will this be of use to you? If so, how would I attach it , or should I un-gz it and then past it into a new post?


Alp

#13 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:08:26 PM

Posted 01 May 2012 - 02:23 AM

It would appear, that your permissions are not adequate enough to read the file. That is why you are unable to change the resolution.

total 96
drwxr-xr-x 10 root root 4096 2012-04-10 17:40 .
drwxr-xr-x 145 root root 12288 2012-05-01 19:11 ..
drwxr-xr-x 2 root root 4096 2011-10-30 20:32 app-defaults
drwxr-xr-x 2 root root 4096 2012-04-10 17:39 cursors
-rw-r--r-- 1 root root 13 2012-04-10 17:40 default-display-manager
drwxr-xr-x 4 root root 4096 2011-04-25 23:01 fonts
-rw-r--r-- 1 root root 17394 2010-02-19 00:02 rgb.txt
lrwxrwxrwx 1 root root 13 2011-09-27 23:34 X -> /usr/bin/Xorg
drwxr-xr-x 3 root root 4096 2011-10-26 01:52 xinit
drwxr-xr-x 2 root root 4096 2011-02-08 13:27 xkb
-rw-r--r-- 1 root root 117 2011-10-26 01:59 xorg.conf
-rw-r--r-- 1 root root 117 2011-10-26 01:59 xorg.conf.dist-upgrade-201110252159
-rwxr-xr-x 1 root root 709 2010-11-02 21:17 Xreset
drwxr-xr-x 2 root root 4096 2012-02-04 08:13 Xreset.d
drwxr-xr-x 2 root root 4096 2012-02-04 08:13 Xresources
-rwxr-xr-x 1 root root 3730 2010-12-02 03:34 Xsession
drwxr-xr-x 2 root root 4096 2012-03-09 20:04 Xsession.d
-rw-r--r-- 1 root root 265 2010-02-19 00:02 Xsession.options
-rw-r--r-- 1 root root 601 2011-04-25 22:55 Xwrapper.config

Edited by cryptodan, 01 May 2012 - 02:21 PM.


#14 Alpsoandso

Alpsoandso
  • Topic Starter

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Local time:12:26 PM

Posted 03 May 2012 - 12:32 AM

I have no problem reading or editing xorg.conf. It is that ls/grep command I was asked to type in that gave no results.

here is it is...
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 295.33 (buildmeister@swio-display-x86-rhel47-08.nvidia.com) Sat Mar 17 15:58:15 PDT 2012


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"

# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "ViewSonic A71f+"
HorizSync 30.0 - 72.0
VertRefresh 50.0 - 160.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GTX 550 Ti"
EndSection

Section "Screen"

# Removed Option "metamodes" "1024x768_85 +0+0; nvidia-auto-select +0+0"
# Removed Option "metamodes" "1024x768 +0+0; 1024x768_85 +0+0; nvidia-auto-select +0+0"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "TwinViewXineramaInfoOrder" "CRT-1"
Option "metamodes" "1024x768_85 +0+0; 1024x768 +0+0; nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

I've been in the file yesterday in fact, I renamed the backup I made to replace the current file that I had changed.
It doesn't matter any more.
I have given up with this issue.

#15 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:08:26 PM

Posted 03 May 2012 - 05:35 AM

Can you please perform a

ls -la /etc/X11/ >> /home/username/x11.txt

then copy the output. The reason you can edit it, is because you have to be root to make changes to it other wise you wont be-able too.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users