Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Laptop video drivers


  • Please log in to reply
1 reply to this topic

#1 Julia-the-PCGP

Julia-the-PCGP

  • Members
  • 38 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Streatham Hill
  • Local time:03:36 AM

Posted 11 April 2012 - 03:26 AM

Good morning everyone,

I need to reinstall the video drivers on this laptop as they had become corrupt and the screen wasn't displaying correctly. However, they're not reinstalling automatically and Sony's website doesn't seem to contain them, only a video driver update program for some obscure feature I don't recognise.

I have identified the video card used Nvidia GForce 8400M GT, but when I download these drivers from them directly, it says they're not compatible with the laptop - and their auto detect feature can't identify the drivers needed.

Please can you provide me with a link to download the correct drivers needed for this model of laptop.

Thanks in advance.

Regards,
Julia

BC AdBot (Login to Remove)

 


#2 Julia-the-PCGP

Julia-the-PCGP
  • Topic Starter

  • Members
  • 38 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Streatham Hill
  • Local time:03:36 AM

Posted 11 April 2012 - 05:57 AM

Hi again everyone,

I'm delighted to say that I found the video drivers on the Sony website, so I've managed to reinstall them and the laptop is working perfectly again.

I hadn't realised that the pre-installed drivers were right at the bottom of the screen under "Preinstalled Vista drivers". At the top I saw what I believed were the drivers available, and I simply didn't scroll right down to the bottom.

I will be giving some feedback to Sony on this section of the website because I feel that the layout is poorly thought out - placing a "latest downloads" section at the top, showing options for XP, Vista and 7, would make most visitors (including me on this occasion!), immediately click on Vista which is the pre-installed OS - without realising that I actually need to click on "Preinstalled Drivers and Utilities".

I don't understand why the "latest downloads" menu is even there as Vista is the pre-installed OS. If I designed the site, I'd remove it altogher !

Anyway I'm delighted that I managed to resolve my own query on this occasion. It's always reassuring to know that excellent forums like this are available when I get stuck or have a query.


Regards,
Julia




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users