Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Cannot boot windows 7 after installing opensuse 12.1 on dual boot


  • Please log in to reply
2 replies to this topic

#1 mrpush

mrpush

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:01:36 AM

Posted 06 April 2012 - 01:17 AM

Hi!

I installed opensuse 12.1 on dual boot along with my other windows 7 installation. Installation of opensuse is successful and i can use it. But when I tried to use windows 7 on grub, it says bootmgr is missing. I've already encountered this problem a long time ago so i tried to use bootrec /fixmbr, bootrec /rebuildbcd and bootrec /fixboot in the recovery console in the windows 7 DVD. Rebuildbcd and fixboot did not work and it said something like it cannot find my windows installation. I also tried bootrec /scanos, it returned a windows installation on D:\Windows but my windows is in drive C. I think this has something to do with me messing up the active partition in disk management a month ago but i already fixed it by setting the active partition to the system reserved partition. Only fixmbr is successful, but now i can't boot on any OS because it says: Missing operating system.

I also tried bcdboot C:\Windows but it failed with a message that goes like: Failure when attempting to copy boot information...

Oh, and I also tried changing my /boot/grub/menu.lst settings but still, it didn't work.

I just need to boot in my windows OS please..

Can anyone enlighten me?

Thanks!

BC AdBot (Login to Remove)

 


#2 noknojon

noknojon

  • Banned
  • 10,871 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:03:36 AM

Posted 06 April 2012 - 04:51 AM

Hello -
:step1: Uninstall opensuse 12.1 first - See if your Windows O/S will boot -
:step2: Reinstall opensuse 12.1 again, and then see if your Windows O/S will now boot -

If it will not boot please stop trying to alter your registry as this may also be causing the problem :)

:exclame: Just an idea -

#3 boyans

boyans

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:36 PM

Posted 06 April 2012 - 05:20 AM

1. Run Startup Repair 3 consecutive times with rebooting after each run. This should fix Win 7 booting.

2. Download and install and run "ext2fsd" v0.50 (and up). This will allow you to read/write ext2/3/4 partitions. Map your OpenSuse partition to Windows drive and copy file

"/boot/grub/boot.img" to say c:\boot.img.

3. Download install and run Visual BCD Editor. Create Boot sector loader. Change ApplicationDevice to C: and ApplicationPath to \boot.img.

Rename the loader to say "OpenSuse".

Now you will have a dual boot under control of Windows 7 bootmgr.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users