Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

McAfee firewall is blocking Internet access


  • Please log in to reply
4 replies to this topic

#1 WantAWorkingComputer

WantAWorkingComputer

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:08:47 AM

Posted 01 April 2012 - 04:59 PM

Recently, my Windows Vista desktop computer became infected. I ran Malwarebytes, which found some trojans, but I still could not get an Internet connection on the desktop. My wireless network, however, was working, so we could get online with a laptop and Ipad. But when I try to go online from the desktop, I get "server not found" errors. This happened with Firefox, IE, and Safari. When I ping sites like Yahoo.com, I get no response.

I called my ISP, and they had me do various tests (such as ipconfig /renew and ipconfig /release), and in the end determined that it was the McAfee firewall. When I turned it off, I could get a connection again. When I turned it back on, I had the same problems.

I don't want to surf the web without a firewall. How can I solve the underlying problem?

Thank you for any assistance.

BC AdBot (Login to Remove)

 


#2 narenxp

narenxp

  • BC Advisor
  • 16,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:08:47 AM

Posted 01 April 2012 - 10:50 PM

Turn off net guard in mcafee firewall settings.

Open McAfee Security Center
Click on "Web and Email Protection"
Click on "Firewall"
Click "Net Guard"
Uncheck the box beside "Turn on Net Guard"


This works even if reinstalling mcafee fails to solve the issue.

good luck

#3 WantAWorkingComputer

WantAWorkingComputer
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:08:47 AM

Posted 02 April 2012 - 09:27 AM

Thank you for the advice. I tried turning off Net Guard, but that did not solve the problem. Any other ideas?

Thank you again.

#4 WantAWorkingComputer

WantAWorkingComputer
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:08:47 AM

Posted 02 April 2012 - 10:07 AM

I found something on a McAfee forum that said to go to Firewall then Ports and System Services and turn on port 80. That seems to have worked.

#5 narenxp

narenxp

  • BC Advisor
  • 16,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:08:47 AM

Posted 02 April 2012 - 10:20 AM

Thanks for letting us know the solution :thumbup2:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users