Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Touchpad stopped working


  • Please log in to reply
3 replies to this topic

#1 davesuper21

davesuper21

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:07:32 PM

Posted 31 March 2012 - 08:58 PM

Hi,this is my problem,i think ive tried everything to fix this to my knowledge,I got this laptop from a friend, emachine W4605,running windows Xp pro Sp3,all drivers are installed,i have restored most of it and reinstalled windows.Everything works great and the touchpad worked like it should, i was using it for a few weeks after being restored.One day i just got done using laptop and turned it off,few days later turned it back on and the touchpad did not work.This model has indicator lights right below the touchpad buttons witch is part of the device itself witch shows wifi power caps scroll lock etc,these lights were still on so i know it had power to the device itself.Ive spent the last week trouble shooting this before it came down to posting on forms.So this is what i found out touchpad was working lights worked,next touchpad stop working,lights worked,reinstalled drivers many different ones,none worked,switched out cable tried a new one,didnt work,fliped cable both ways,didnt work.

Now the lights are not on!I have another identical plamrest with same touchpad witch was the original one that came with laptop did same test with it.Now even that one, the lights dont work or the touchpad,So i have this feeling that both these touchpads do work,but there just not getting power!When i got this laptop i turned it on with all original parts and touchpad and everything worked,so i know the old touchpad is good.After restoring with newer parts everything did work!

I spent many hours and days studying this issue almost every google site lol! its not the Fn F7 tried that,I would really like to fix this its one of those things that is not going to beat me!lol,Im Open for any ideas cause im out of them,its all coming down to,touchpad is now not getting any power or lights would be on,witch leaves me wondering why it stopped working before the lights stopped telling me now no power at all!

Well there it is,this is truly a brain teaser for me,if anyone can give me some ideas Thank you so much!

P.s. This is my first posting on this website so i hope i did ok!lol

BC AdBot (Login to Remove)

 


#2 davesuper21

davesuper21
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:07:32 PM

Posted 10 April 2012 - 02:51 PM

Taking any ideas please.I don`t want to replace the motherboard.If it worked before i think i can get it to work again i just need some ideas!

#3 davesuper21

davesuper21
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:07:32 PM

Posted 09 May 2012 - 11:05 AM

04/26/11 :hysterical: OMG I FIXED IT! LOL!!!

Well after weeks of giving up thinking it was down to the motherboard port for the touchpad.I took this computer apart few times and the cable that connects the touchpad, that i mentioned before.I tried flipping it end to end and everything!On the cable each end has your golden tabs that go in the slot connecting the touch pad device.On the other side of each end there is a blue protection strip so when i put it in i thought cause the bottom on the keyboard is all metal,so the blue plastic part goes up..Well it doesn't it goes facing the motherboard and the gold tabs are facing up.Witch is why it got confused in the first place it didn't seem right to have the connecters exposed facing away from the MB.

Everything works great again all the lights and touchpad / buttons work,i cant believe thats what it was,the good thing is i trouble shot every other possibility,so there is nothing worng there.Hope this helps anyone with this problem this topic full of ideas,I think most of the time it will be a software issue but hardware dose go out.Im just so happy i didn't go spend any money,i was going to look one more time then some reason i was looking at those blue tabs and tried flipping it .lol Thanks all! To the next problem...thats funny cause i just had my desktop power supply and video go out on me :hysterical: ....

#4 davesuper21

davesuper21
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:07:32 PM

Posted 09 May 2012 - 11:16 AM

So i must flipped the cable wrong when i was working on other parts in between using the computer that would explain why it was working then stopped over those 2 days i must of opened up my cpu to do something else lol.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users