Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

search.live.com


  • Please log in to reply
18 replies to this topic

#1 earlforfar

earlforfar

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:04:46 PM

Posted 29 March 2012 - 08:32 PM

Despite all attempts am unable to get IE8 accept Google as default search engine. Live Search cannot be removed from its position as default provider. There seem to be a number of entries in registry that may be causing a redirect

BC AdBot (Login to Remove)

 


#2 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:09:46 PM

Posted 29 March 2012 - 08:36 PM

What are you being redirected to when you do searches?

#3 earlforfar

earlforfar
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:04:46 PM

Posted 29 March 2012 - 09:41 PM

Cryptodan - thanks for your interest - my searches are not actually redirected I am just being forced to manually change the displayed search provider in order to proceed with a search. This can be extremely annoying as any semiautomated sign on to a website gets interrupted by the following..............

After starting IE8 it comes up with the correct search provider, however after 10-15 secs a text block appears in centre screen containing following -

""A program on your computer has corrupted your default search provider setting for Internet Explorer.
Internet Explorer has reset this setting to your original search provider, Live Search (search.live.com).
Internet Explorer will now open Search Settings, where you can change this setting or install more search providers.""

If I close box or click ok I then get the "Manage Add-ons" screen which correctly shows Google - enabled and Live Search - Default - Disabled. It will not let me set Google as default consequently i continue to go through the exercise every time I or a program starts IE8

#4 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:09:46 PM

Posted 29 March 2012 - 09:58 PM

Can you take a screenshot of this?

#5 earlforfar

earlforfar
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:04:46 PM

Posted 30 March 2012 - 09:17 PM

Well you learn something every day. Image Shack has the three screenshots:
http://imageshack.us/photo/my-images/405/livesearch1.png/
http://imageshack.us/photo/my-images/688/livesearch2.png/
http://imageshack.us/photo/my-images/341/livesearch3.png/
Hope you can see them ok and they help

#6 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:09:46 PM

Posted 30 March 2012 - 09:33 PM

What happens if you remove the google search by setting bing to default then reinstalling gogole search?

What version of Windows?

#7 earlforfar

earlforfar
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:04:46 PM

Posted 30 March 2012 - 11:24 PM

Version of Windows is XP home SP3.
OK - I enabled Live Search (Bing ?), disabled google and deleted from list of search providers in Manage Add-ons. Restarted computer but there was no change in action. IE8 initial screen displayed google home page and displayed Live Search in box top right. In 10-15 secs the corrupted search provider box appears mid screen and if you click ok or close box you get the manage add-ons screen. This screen now displays only Live Search - Default - enabled. No mention of Google.
Using the IE8, tools, Internet options I can make the home page Google, MSN, Bing or whatever however the search defaults always to Live Search and screen shots 2 & 3 continue to plague operation. I cannot manage add-ons, I cannot add any other search provider and make it the default.

#8 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:09:46 PM

Posted 30 March 2012 - 11:54 PM

Go to the advanced tab in internet options and select reset.

#9 earlforfar

earlforfar
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:04:46 PM

Posted 31 March 2012 - 06:35 AM

OK - did reset
It changed the default website to MSN but there was no change in the Search provider box. i.e. still Live Search default disabled and Bing enabled but can't be made default. We continue to go through screen shot 2 & 3 each time we start IE8

#10 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:09:46 PM

Posted 31 March 2012 - 01:10 PM

You may want to try this fix out: http://answers.microsoft.com/en-us/ie/forum/ie8-windows_vista/i-receive-a-message-stating-i-have-corrupted/910e74cf-9dce-4a63-ab16-c6bd2c6ad2b3

REGEDIT WARNING Only edit the below key, and prior to doing so please back up your registry using ERUNT.

Edit Your registry Key:

Make sure IE 8 is closed then navigate to registry key: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Add a new “Expandable String value” inside the above mentioned key with a value name of “AppData” and a value data of %USERPROFILE%Application Data

Reopen IE 8 and see if you still get the error message.

Shazam

#11 earlforfar

earlforfar
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:04:46 PM

Posted 31 March 2012 - 11:59 PM

OK – I downloaded ERUNT and backed up the registry. The App Data expandable String value already existed so reviewed the microsoft link. I did a search on the registry for the word “search” and found a few references to search.live.com so that combined with other peoples efforts as outlined in the link made a few changes in the registry bearing in mind I do have the backup.
HKCU\Software\Microsoft\Internet Explorer\SearchScopes contained two keys; {0633EE93-D776-472f-A0FF-E1416B8B2E3A} for live search and
{E00A7EAB-E390-41BB-AEBA-4F28BF5009A5} for google.
The Search Scopes folder called for default to {0633EE93-D776-472f-A0FF-E1416B8B2E3A} ie. live search.
I substituted the google key and deleted only the Live search key. This fixed the Live Search default and gave me google as default however it continued to display the corrupted box followed by Manage Add-Ons.
I went back into registry deleted all other \Internet Explorer\SearchScopes keys from HKLM & HKU. Now I no longer get SS2 the corrupted screen but it still brings up SS3 the Manage add-ons. The manage add ons shows only google and it’s correctly tagged as default. However if I add another provider Bing for instance I cannot make it the default Google is now locked in.

#12 earlforfar

earlforfar
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:04:46 PM

Posted 01 April 2012 - 03:03 PM

It didn't last I am back to the same as when we started.

#13 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:09:46 PM

Posted 01 April 2012 - 03:46 PM

I would give this a try: Microsoft Fix It for IE

#14 earlforfar

earlforfar
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:04:46 PM

Posted 02 April 2012 - 05:58 PM

Nothing in there for IE8/XPsp3

#15 earlforfar

earlforfar
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:04:46 PM

Posted 02 April 2012 - 10:57 PM

Interesting observation:
If I go to this topic directly from Outlook Express via the reply notification link, neither of the popup windows appear. If I then select Google from the Search options I get the Google home page and am now browsing without any interference. I can also get an interference free boot if I right click the icon and select "start without add-ons" I get a yellow warning bar notification that I IE8 is running with add-ons disabled. I close that bar and select Google from search options.
In other words the popup interference only occurs if I boot the browser via the desktop icon.
However I still can't delete Live Search or make any other provider the default.

Edited by earlforfar, 02 April 2012 - 10:58 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users