Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows Defender stopped updating and working


  • Please log in to reply
5 replies to this topic

#1 dfumagalli

dfumagalli

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:04:20 AM

Posted 19 March 2012 - 07:22 AM

Hello,

Win 7 professional 64 SP1 all patches applied till today.

Some days ago I got a Definitions Update, like many others before.
But this time it failed to apply with an numeric code.

Since I don't have MS Security Essentials (never installed it for what I can recall) and just have free Avira, Spyware Blaster and Malware Bytes, it should not be disabled or something.

After reading a number of posts on the MS forums I tried manually starting the defender service, which failed with error 126 (could not find its mpsvc.dll DLL).
I noticed the required DLL, along with a couple others, was in Program Files, while the registry entry for it was set to %ProgramFiles (86)%\Windows Defender\mpsvc.dll.

Not willing to fiddle with the registry, I just applied a .reg fix others on the MS support forums found useful to fix this issue with.

But it did not help. The definitions update indeed worked but now the defender service won't start at all and shows as disabled (trying to start it does nothing, no error, no Windows logs in events viewer.

What I get now is: "<Impossibile leggere la descrizione. Codice di errore: 1168 >" which translated is "Unable to read the description. Error code:1168"

for executable path C:\Windows\System32\svchost.exe -k secsvcs

The %ProgramFiles (86)% and %ProgramFiles% are (correctly) located in E:

I already ran the command line MS utility that scans the system files and also the MS 310MB general fix-it-all patch whose name I don't remember now.


Best regards,
Dario

BC AdBot (Login to Remove)

 


#2 Guest_Xircal_*

Guest_Xircal_*

  • Guests
  • OFFLINE
  •  

Posted 19 March 2012 - 10:31 AM

Like Internet Explorer, Windows Defender is integrated into Windows 7 and you cannot remove it. But it shouldn't be relied upon to protect your system and since you're using Malwarebytes, the best thing to do is to disable it.

I've seen instances though whereby the "Tools" menu in Windows Defender is greyed out so that you cannot access it. If that's the case in your own case as well, click the Start button and then type: services.msc in the search field at the bottom of the menu to load it. Click the link to run it, then find "Windows Defender" in the list, double click it and change the "Startup Type" to "Disabled". You'll need to reboot to complete the command.

#3 Allan

Allan

  • BC Advisor
  • 8,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey

Posted 19 March 2012 - 10:53 AM

Windows Defender is a waste of resources and not nearly as good as MalwareBytes or Super AntiSpyware. I suggest you follow the instructions above to disable the Windows Defender service.

#4 Union_Thug

Union_Thug

    Bleeps with the fishes...


  • Members
  • 2,355 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:is everything
  • Local time:11:20 PM

Posted 19 March 2012 - 11:30 AM

Windows Defender is a waste of resources and not nearly as good as MalwareBytes or Super AntiSpyware. I suggest you follow the instructions above to disable the Windows Defender service.


Ditto.

#5 dfumagalli

dfumagalli
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:11:20 PM

Posted 19 March 2012 - 11:33 AM

Ok, thank you for the replies above.

I'd preferred to have it still available (just turned off, but by my choice not because it's broken), at least to not keep getting those creepy red "update failed" windows whenever they release new definition updates.

Anyway I fiddled with the registry more and got it starting. Now I can set it on manual or something and not get update failed errors any more.

Edited by dfumagalli, 19 March 2012 - 06:40 PM.


#6 CBvapor

CBvapor

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Florida
  • Local time:04:20 AM

Posted 21 March 2012 - 08:20 PM



Hi I'm CB and I'm new here and they want me to make a post so I will. Nice to find well run forums, so hello to all!
To give the whole story, Defender did waste resources, but it got into 7 and they could not get it to run effectively, it let to much slide by,
and they where in a hurry so it's still there. I tried it and it says it will run manually if you press here, but it won't. I even tried it through services and it just won't run.

I use Microsoft Security Essentials and I was surprised , I also run Malwarebytes and Commodo Firewall and anti virus. They all seem to get along fine. Not like some I tried.
also have Bitdefender site checker.

CB




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users