Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


DNS working, but not for browsers.

  • Please log in to reply
No replies to this topic

#1 00goat


  • Members
  • 1 posts
  • Local time:08:13 PM

Posted 10 March 2012 - 09:48 PM

This woman wanted parental controls on her granddaughter's laptop (Win 7 x64, was a christmas present, mcafee installed and working). I went the opendns route for the parental control, and everything was great except that they had installed some sketchy looking "Action Alert Internet Parenting" junk (note, this isn't the dongle you'll see in searches for that, it's just a piece of software). Grandma had managed not only to forget the password for it, but had supplied an incorrect email address, making it impossible to do anything about the password. I ended up removing it by knocking out its main registry entries, then reinstalling it with a new password and doing a proper uninstall.

So what I have now is a situation where DNS doesn't work, specifically in the browser(s). I know the action alert junk had an LSP installed... it's no longer there, and I would think that netsh winsock reset should've fixed a problem of that sort anyway. Here's what I've done, and this is on my home network I'm speaking to you from, so it's not a network/internet issue.

Symptom: Cannot visit any website in a browser (tried firefox and IE, chrome won't install b/c the stub they give you can't find a source).
-- DNS *does* work. I can ping google, and ftp to ftp.mozilla.org from the command line. McAfee software is able to update itself with no problem, and windows update works fine.
-- The browsers *do* work. I can take the IP I get from pinging google and put it in the browser and search google just fine.

So of course I've been all over the internet on this, tried about a million things, including but not limited to:
-- ipconfig /flushdns
-- net start/stop dns
-- netsh winsock reset
-- netsh int ip reset
-- I've scanned it for anything malicious (mbam, mcafee)
-- uninstalled toolbars
-- switched DNS servers (isp, opendns, google)
-- multiple browsers

I've been over internet options with a fine toothed comb, dug through HJT logs for internet explorer modifications, pretty much done everything I've learned from years of removing viruses and other filth, and I've got nothing. It's utterly infuriating to be looking at a reinstall to fix a 3 month old computer that hasn't even been infected yet.

Any help would be greatly appreciated.

BC AdBot (Login to Remove)


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users