Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Remote Desktop from Win7 to Windows Server 2008


  • Please log in to reply
10 replies to this topic

#1 Jason S

Jason S

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:05:38 AM

Posted 27 February 2012 - 12:50 AM

I set up Windows Server 2008 on one of my old builds, and connected it to the internet at my parents house. I got remote desktop working between my laptop and the server while connected to my parents network, and then followed THIS TUTORIAL so that i could have access to remote desktop for my server when i went outside of my network. I followed the tutorial as closely as i could, but it wasn't written specifically with windows server 2008 in mind. There were a few steps in the tutorial that i was unable to complete, but for the most part it seemed as if i had done everything that i needed to do in order to get things working.

As i mentioned, i got remote desktop between my laptop (win7) and my server (Server08) using local internet and using the local IP address (192.168.1.115). I opened port 3389 on my router, and checked the my servers registry to make sure that port 3389 was the correct port to forward.

Unfortunately when i try to connect using remote desktop outside of the network, using externalip:3389, the connection does not go through. I don't get an error message like i do when i try to connect to any random address, but it just takes a really long time trying to connect, and eventually times out.

Any suggestions are greatly appreciated!

Many thanks,
Jason

BC AdBot (Login to Remove)

 


#2 akoch

akoch

  • Members
  • 56 posts
  • OFFLINE
  •  
  • Local time:05:38 AM

Posted 27 February 2012 - 01:27 PM

Did you specify what local IP you're forwarding 3389 to?

********************************
FAKE ROUTER CONFIG PAGE
********************************

Name Protocol Port IP
RDP TCP 3389 192.168.1.100



^^Hopefully that helps you.

#3 Jason S

Jason S
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:05:38 AM

Posted 28 February 2012 - 01:21 PM

I did specify within the router what IP port 3389 should forward to. Here is a step by step of what I have done so far:

  • Install Windows Server 2008 on my old Computer.
  • Connected the Server to my Home network, and confirmed that it had a static local IP and Internet access.
  • Allowed Remote Desktop connections on my server (Control Panel -> System -> Remote Settings -> Remote -> "Allow connection from any version of remote desktop" -> Select Users)
  • I was prompted to specify users that would be accessing the server via remote desktop, but couldn't figure out what i needed to input, so I left the Remote Desktop Users box empty
  • Used another computer on my home network to access the Server via Remote Desktop. I WAS able to connect using the Local IP address.
  • Entered my routers IP address into internet explorer, and enabled port 3389 "TCP" to forward to my servers internal IP.
  • Went to Starbucks (outside of my home network) and attempted to remote connect to my server using my servers public IP. (This attempt Failed)

It may be worth noting, when i went outside of the network to connect to my server remotely,I accidentally tried to connect to my server using my servers internal IP. I was given a failure to connect error straight away. However, when i used <publicIP>:3389, it attempted to connect for a long time before it timed out.

Hope this clears up what might be causing my issues!

Many Thanks,
-Jason

#4 Baltboy

Baltboy

    Bleepin' Flame Head


  • Members
  • 1,430 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Pennsylvania
  • Local time:05:38 AM

Posted 04 March 2012 - 12:02 PM

Two things come to mind when i read this.

First is RDP requires three things in order to connect. First is a user name on the server. Second is a password on the server, and third is the IP of the server. The fact that you can connect localy tells me that you are using a user name and password on the server. You need to go into the users profile. Where depend on if you have a domain setup or not. If you don't then just go to the users in the control panel. If you do then go to Active Directory users and computers. Under the users profile enable the setting allowing them to access the server remotely.

Second is the firewall on the server. If RDP is not enabled on both the incoming and outbound filters the connection will fail. See this article Here.
Get your facts first, then you can distort them as you please.
Mark Twain

#5 tcehaliasgar

tcehaliasgar

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:05:38 AM

Posted 28 November 2012 - 06:42 AM

In order to have remote desktop connection outside your network, you need to use remote support services such as logmeinrescue, gosupportnow, gotomypc etc. and connect over internet. Both the computers need to be on same network if you want to internally establish remote connection without using 3rd party remote services.

#6 Baltboy

Baltboy

    Bleepin' Flame Head


  • Members
  • 1,430 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Pennsylvania
  • Local time:05:38 AM

Posted 01 December 2012 - 07:47 PM

In order to have remote desktop connection outside your network, you need to use remote support services such as logmeinrescue, gosupportnow, gotomypc etc. and connect over internet. Both the computers need to be on same network if you want to internally establish remote connection without using 3rd party remote services.



This is not absolutely true since a standard VPN can be setup and used to establish a RDP session.
Get your facts first, then you can distort them as you please.
Mark Twain

#7 pieterw3

pieterw3

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:38 PM

Posted 20 September 2013 - 06:45 AM

It is possible that your router needs additional configuration, what is the model of your router?

 

and to make surre you use the correct public ip adress go to

 

http://whatismyipaddress.com/



#8 Sasi Kumar

Sasi Kumar

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:04:08 PM

Posted 12 November 2013 - 11:18 AM

Your router must use

ip nat inside source static tcp 192.168.x.x 3389 123.250.x.x 3389 extendable

and

Starbucks must allow/open port 3389 in their router / Firewall

 

Also may you need to check your firewall setting to allow outside home network to connect to your system.



#9 techwizard

techwizard

  • Members
  • 25 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Lakeland, Georgia
  • Local time:05:38 AM

Posted 09 December 2013 - 10:03 PM

A shot in the dark here, you mentioned you used a computer on the internal network and it worked then went to Starbucks and it didn't. So you are using 2 separate computers? Is it possible that one has IE 9 (the one that connected) and the other has IE10 installed? Sometimes...I emphasize sometimes there are issues using remote desktop and being able to successfully connect when IE 10 is installed, though this should give you an error if this is the case



#10 x64

x64

  • Members
  • 352 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:London UK
  • Local time:11:38 AM

Posted 10 December 2013 - 02:11 AM

...

Second is the firewall on the server. If RDP is not enabled on both the incoming and outbound filters. ...

Technically the above is slightly incorrect. I'll come back to tthat in a mo....

 

Reading the thread, the obvious thing not attended to is the local Windows Firewall on the server (additionally there is no mention that the servers default gateway is set to the router, but I assume it is).

 

The correct firewall setting is "Remote Desktop (TCP-in)" "Enabled" for "ALL" profiles (set in "Windows firewall with Advanced Security" (wf.msc)

 

The slight issue with the original suggestion is that we are only worried about inbound (OK, allowing outbound isn't an issue, but it is not the subject of what we are trying to achieve. - I offten see the opposite [which is much more dangerous] - someone doing outbound access, hitting issues they do not understand and setting the firewall to allow inbound as well out of desparation - the blunderbus method of firewall configuratiion is a poor one!).

 

Additionally once you get it working, if you have the opportunity to set a differennt external port on your router port forwarding rule, try to use that (so the router listens on a differenf port - say 47816 or something like that , and forwards that to 3389 on the server.

 

There are miscreants to scan the internet for open RDP ports and try to log in. If not maybe change the administrator usernme on the server and definitely use a very strong password.



#11 JohnnyJammer

JohnnyJammer

  • Members
  • 1,117 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:QLD Australia
  • Local time:08:38 PM

Posted 16 December 2013 - 09:31 PM

like x64 said, having an open port 3389 is dangerous and not to emntion you subject your self to token kidnapping which if i where to obtain would get acess with out authorization. Anyway who, all i will say is, no NOT have direct RDP access to a  server, creat a free VPN (IPCop for instance with OpenVPN, make sure you enable GREPPTP(Port 47 on the router to point to red interface in IPCop) which acts as the gateway and proxy filter if need be.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users