Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

PCI to USB driver not installing (Win7)


  • Please log in to reply
7 replies to this topic

#1 rory_chi

rory_chi

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:04:45 PM

Posted 20 February 2012 - 08:36 PM

Hi, I noticed today that my internal webcam for my Acer laptop was not working. I tried reinstalling the webcam driver but an error always pops up saying that the webcam can not be found. Later I noticed when I plugged in my flash drive, phone, etc, these were not detected either.
In device manager the webcam was not listed, and I didn't spot any unknown devices and searched for hidden devices.

However there is a (!) near 2 "Standard Enhanced PCI to USB Host Controller"s under USB Controllers. I right clicked to update drivers and windows said my drivers were up to date, but nothing worked still. I uninstalled the drivers and rebooted, and when windows tried to automatically update drivers they failed.

Under device status is says:
"Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)"

Thanks for any help to get my devices recognized again.

BC AdBot (Login to Remove)

 


#2 caperdog

caperdog

  • BC Advisor
  • 954 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Nova Scotia
  • Local time:05:45 PM

Posted 20 February 2012 - 09:35 PM

scan for malware never hurts (malwarebytes.org)

download driver from Acer web site and install

#3 rory_chi

rory_chi
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:04:45 PM

Posted 20 February 2012 - 09:51 PM

I scanned using avast and superanti spyware which were clean, i'm running malware bytes now just in case..I just did a clean reinstall of win7 yesterday if that makes any difference.

which drivers do you mean? I've tried reinstalled the one for the camera but that error always pop up and doesn't recognize the camera. I dont think it's broken since there's no response from usb devices either. Where would I download/how can I fix this broken pci to usb driver?

#4 caperdog

caperdog

  • BC Advisor
  • 954 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Nova Scotia
  • Local time:05:45 PM

Posted 20 February 2012 - 10:11 PM

what model Acer do you have ? did it come with win7 ?

#5 rory_chi

rory_chi
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:04:45 PM

Posted 20 February 2012 - 10:27 PM

its an Aspire 5742
it came with windows 7 already on it, I formatted my drive and reinstalled win7 yesterday because of a virus. everything was working fine when the usb/camera suddenly stopped being recognized, maybe something weird from a windows update? I'm not sure

#6 caperdog

caperdog

  • BC Advisor
  • 954 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Nova Scotia
  • Local time:05:45 PM

Posted 21 February 2012 - 07:30 PM

if you reinstalled from a windows dvd you may need the chipset driver

if you reinstalled from a recovery partition on your hard drive i would think it would have installed.

your chipset driver (and camera driver) are here
http://support.acer.com/us/en/product/default.aspx?tab=1&modelId=3277

Edited by caperdog, 21 February 2012 - 07:35 PM.


#7 caperdog

caperdog

  • BC Advisor
  • 954 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Nova Scotia
  • Local time:05:45 PM

Posted 21 February 2012 - 07:47 PM

issue with SP1

http://www.sevenforums.com/windows-updates-activation/151740-windows-7-sp1-usb2-bug.html

http://forums.mydigitallife.info/threads/24666-The-Windows-7-SP1-USB-Driver-Bug-%28what-it-is-and-how-to-fix-it%29

#8 rory_chi

rory_chi
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:04:45 PM

Posted 22 February 2012 - 06:43 PM

hi,
I have those drivers and I did try uninstalling all usb controllers but that didn't work. I ended up doing a system restore to a couple days ago before I noticed the problems and everything is recognized now. Thanks for the link to the usb driver update fix! I'll save it in case I do an update and drivers stop working again

Edited by rory_chi, 22 February 2012 - 06:44 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users