Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Problem With "my Documents" Folder


  • Please log in to reply
8 replies to this topic

#1 Tim_is_here

Tim_is_here

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:03:05 PM

Posted 16 February 2006 - 12:48 AM

I am running XP professional on a PC with two users. For simplicity, I will call them User A and User B. User A (me) has administrative privileges, and User B is just a glorified guest account that hasn't been used in quite some time. I am the only one that uses this machine.

The problems I'm having are with the "A's Document's" and "B's Documents" folders under "My Computer". "Shared Documents" is fine.

The problem with "B's Documents" is that when I hover the mouse over that folder, it says the same thing as the "Shared Documents" folder: It says "Contains files and folders shared between users of this computer." Of course, in the case of "B's Documents" this is not true. This folder is not shared, and there is no "hand" showing under the folder. If I doubleclick on the folder, it goes to "C:\Documents and Settings\B\My Documents" as it should, and properly displays the files there.

The "A's Documents" folder has additional problems. First, like B, when you hover the mouse it gives the same message as above ("Contains files and folders shared between..."). Also like B, it isn't actually shared, and there is no "hand" under the folder. Unlike B though, it has the additional problem of pointing to the wrong place. If I double-click on "A's Documents" it takes me to "C:\Documents and Settings\LocalService\My Documents". As this is empty, My Documents appears to be blank. However, if I go to "C:\Documents and Settings\A\My Documents" all of My Documents are indeed there (thank god).

I have no idea how this got all screwed up. I can tell you though that whatever happened, happened recently -- either today, or at most a couple of days ago. Before then, things were normal. I only noticed this problem today. I cannot afford to lose a day's work over this silliness though, so I cannot use a system restore point. Besides, I use GoBack, and the furthest I could go back is one day. Who knows if this would even be far enough back to fix the problem.

By the way, my machine is protected from viruses and spyware. Norton Antivirus is always running, as is Microsoft AntiSpyware. In addition, my PC runs Microsoft AntiSpyware and Lavasoft Ad-Aware full scans daily.

Any idea how I can fix this? "A's Documents" and "B's Documents" folders both are read-only. I know how to change that, and thought that maybe I could delete both these folders and recreate them -- but then they would appear as shortcuts instead of folders (I assume). And I'd wonder if there'd still be something inherently wrong with them, such as the incorrect hover text and who knows what else. So before messing with anything I thought I'd come here first. Any ideas on what might have happened, and what I should do? Thanks very much!

Tim

BC AdBot (Login to Remove)

 


#2 phawgg

phawgg

    Learning Daily


  • Members
  • 4,543 posts
  • OFFLINE
  •  
  • Location:Washington State, USA
  • Local time:12:05 PM

Posted 16 February 2006 - 02:37 AM

I have definitive answer.
I have winXP, one user (presently, I've had other setups)
The dropdown message appears on my shared documents, and my user documents in "My Computer" as you stated.

Shared Music & Shared Pictures only are the result of clickin' it.

My username Documents = only those two folders above (defaults) and the actual one.
It's location should be C:\Documents and Settings\username\My Documents

No "My Documents" should be in LocalService, a hidden folder.

What placed it there remains unknown, and I can't test it, only speculate.

If not malware, a strange twist of windows OS unwizardry for sure.

Your layers of defense, those mentioned, would not eliminate my thinking spyware.
In fact that kind of shift at a system file level would indeed be the kind of malware
that could presently be unidentified by any of those.

Hard to say.
Best answer might be to post a log.
If you do hold up on making any significant changes once you do,
so the analysis is accurate.
patiently patrolling, plenty of persisant pests n' problems ...

#3 Enthusiast

Enthusiast

  • Members
  • 5,898 posts
  • OFFLINE
  •  
  • Location:Florida, USA
  • Local time:03:05 PM

Posted 16 February 2006 - 09:35 AM

Backup your data, use restore, and replace the data.

If you are the only user why aren't you sharing documents?

You shouldn't use an admin account while on the internet because anything that sneaks in while you are on an admin acount will have access to the admin rights. Create a limited account for surfing.

#4 Tim_is_here

Tim_is_here
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:03:05 PM

Posted 16 February 2006 - 03:26 PM

I have definitive answer.
I have winXP, one user (presently, I've had other setups)
The dropdown message appears on my shared documents, and my user documents in "My Computer" as you stated.

Shared Music & Shared Pictures only are the result of clickin' it.

My username Documents = only those two folders above (defaults) and the actual one.
It's location should be C:\Documents and Settings\username\My Documents

No "My Documents" should be in LocalService, a hidden folder.



Thanks for the reply.

Unfortunately, the problem I had/am having isn't that I'm lacking the above knowledge...it's that the system doesn't allow me to use that knowledge to change what these folders point to. They're protected folders. Also, even if I could change "A's Documents" to point to the right place, aren't I likely to have the same incorrect "hover text" message saying that the folder is shared? "B's Documents" currently points to the right place but has the wrong hover text, too.

#5 Tim_is_here

Tim_is_here
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:03:05 PM

Posted 16 February 2006 - 03:35 PM

Backup your data, use restore, and replace the data.

Which data, and which backup/restore method do you mean? How will this get my folders to be corrrect? The folder contents are already correct, it's the folders themselves which are "broken".


If you are the only user why aren't you sharing documents?

I created that other account for when I have visitors at my home who want to use my PC. Not a common occurance, but that's the purpose. Making everything I have visible to them would defeat that purpose.


You shouldn't use an admin account while on the internet because anything that sneaks in while you are on an admin acount will have access to the admin rights. Create a limited account for surfing.

Good point, I should probably do this.

#6 Enthusiast

Enthusiast

  • Members
  • 5,898 posts
  • OFFLINE
  •  
  • Location:Florida, USA
  • Local time:03:05 PM

Posted 16 February 2006 - 04:37 PM

Which data, and which backup/restore method do you mean? How will this get my folders to be corrrect? The folder contents are already correct, it's the folders themselves which are "broken".


Whatever data you have in YOUR documents folder as well as data being stored by any other programs you are using.

You should always back-up data on a regular basis. If you have ever had a hard drive crap out or Windows totally crash and have to be installed, you should know why!

There are many programs available (like Dantz Retrospect for one) to schedule and automate backups (usually on a tape drive, slave hard drive or an external hard drive), or you can do it using the Windows backup utility and burn it onto cds or dvds.

There are external USB hard drives that are designed for this purpose and come with the software. I have one made by Western Digital, but there are many others available. They are multi-purpose and can be used for anything else you do with any hard drive as well.

From rereading your original post, I think that your system is set up the way it is supposed to be on a system with more than one user account.

Before you “restore” anything, do one other thing first:

Sign on using your guest user “A” account and actually try to open your “B” non-shared documents file.

I think you will find it will tell you that access is unauthorized.

Then try to open the file/s you couldn’t previously open. I think you will be able to.

If it does so, that is the way it is supposed to be. If you want the B user to have access to the A documents file, set the file to be shared which can be done when signed on with an account with administrator rights.

Edited by Enthusiast, 16 February 2006 - 04:41 PM.


#7 Tim_is_here

Tim_is_here
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:03:05 PM

Posted 17 February 2006 - 04:53 PM

Before you “restore” anything, do one other thing first:

Sign on using your guest user “A” account and actually try to open your “B” non-shared documents file.

I think you will find it will tell you that access is unauthorized.

Then try to open the file/s you couldn’t previously open. I think you will be able to.

If it does so, that is the way it is supposed to be. If you want the B user to have access to the A documents file, set the file to be shared which can be done when signed on with an account with administrator rights.



That's the way it works, and that's the way I want it. But that's not the issue really, the problem is that "A's Documents" points to the wrong directory, and the system doesn't allow me to change where it points. Backing up and restoring won't change where that folder is pointing.

But yes, I agree that backing up regularly is a good idea.

#8 Enthusiast

Enthusiast

  • Members
  • 5,898 posts
  • OFFLINE
  •  
  • Location:Florida, USA
  • Local time:03:05 PM

Posted 17 February 2006 - 05:08 PM

After reinstallation of the op system I believe creating the second user account will automatically set where the user's documents are stored(or third, because you should have two user accounts - one admin and one limited for surfing, etc) You can set your user accounts to share the documents folders (and exclude the guest account) and you can also set the "targets" to the folder you want both to use by using Windows Explorer and right clicking on the documents folder and selecting properties.

You will have to use the account with administrator rights to do this.

By the way - you can do that without reinstalling the op system.

Edited by Enthusiast, 17 February 2006 - 05:10 PM.


#9 Tim_is_here

Tim_is_here
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:03:05 PM

Posted 18 February 2006 - 06:37 PM

After reinstallation of the op system I believe creating the second user account will automatically set where the user's documents are stored(or third, because you should have two user accounts - one admin and one limited for surfing, etc) You can set your user accounts to share the documents folders (and exclude the guest account) and you can also set the "targets" to the folder you want both to use by using Windows Explorer and right clicking on the documents folder and selecting properties.

You will have to use the account with administrator rights to do this.

By the way - you can do that without reinstalling the op system.


I was just able to fix my misdirected folder problem by changing a registry key that was wrong...I changed it to point to C:\Documents and Settings\A\My Documents instead of C:\Documents and Settings\LocalService\My Documents and viola, the folder problem was fixed. :thumbsup:

Now that is taken care of, when I have time to experiment next week I'm going to do your suggestion as well. That's a great idea to create a safer user account that points to the same documents folders! I didn't realize that you could do that. Just to make sure I understand, when you said "you can set your user accounts to share the documents folders (and exclude the guest account)" you were referring solely to what you said next, changing the target of "My Documents" of the new user to that of my old one? That's all I need to do?

P.S. Anyone else using IE who wants to make their system safer for browsing might also want to make another change I recently made: go to Tools -> Internet Options -> Advanced and uncheck "Enable Install on Demand (Other)". Now web sites can't automatically install BHO's without your knowledge. If there's a BHO you want, you can temporarily turn that back on.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users