Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

dcomcnfg problem can't access permissions


  • This topic is locked This topic is locked
19 replies to this topic

#1 abricru

abricru

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Local time:01:56 PM

Posted 11 February 2012 - 07:53 PM

My original problem was that I am unable to drag and drop anything on my computer. I also can't cut and paste. I followed all the steps about removing malware etc. that I was referred to on this forum. I am satisfied that any virus or malware has been removed.

I found a fix to the problem in Microsoft Answers Forum. It requires using dcomconfig. I click start/run/dcomconfig and the screen comes up but when I click on my computer the whole screen disappears so I can't get to the default access permissions.

When I was following the earlier steps and ran chkdsk it did find problems but I thought they were corrected. Not sure if this has anything to do with it.

Please help. I have followed all the steps I was told.

Thanks!

BC AdBot (Login to Remove)

 


#2 James Litten

James Litten

    Ԁǝǝ˥q


  • BC Advisor
  • 1,946 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:12:56 PM

Posted 11 February 2012 - 08:49 PM

Hi

This can be a tricky problem :) Lets start with the easy things.

Could it be a faulty keyboard or mouse?

Check if any keys are stuck on your keyboard (particularly shift, alt, ctrl, esc) Turn off the computer and tap each key a few times to make sure none are sticking or acting wonky.

Check the mouse buttons by clicking them a few times to make sure they feel right.

Do you have an extra mouse or keyboard plugged in? Or maybe using a mouse and a keyboard with a touchpad (try removing the mouse and see if the touchpad works).

Do you have a wireless keyboard or mouse? If so, could there be another one in a nearby box or drawer or used by a nearby person that could be interfering?

Make sure there are no extra receivers plugged into the USB ports from old wireless mice or keyboards (this happened to someone here last week and was a bear to figure out).


If those don't work
Answer these questions please.

Did this just start happening out of the blue?

Did you install any new hardware or software shortly before it started?

What were you doing when you first noticed it?

Why do you think it is not malware or a virus?

How much free disk space do you have on your C: drive?

James

#3 abricru

abricru
  • Topic Starter

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Local time:01:56 PM

Posted 12 February 2012 - 05:13 AM

Hi,
Thank you for answering my post. I have checked the keyboard and mouse and they seem to be fine. I have had to change mice several times in the last months because of a puppy who loves to eat them. The drag and drop/desktop problem has been going on a couple of months and I don't remember when I noticed it. I don't think it is malware or a virus because I followed instructions in a previous post for malware removal and I am hoping it was successful. I did have some infections though, so it is possible that it was not totally fixed. None of the scanners are showing anything though.

Free space = 57.2 GB

Edited by hamluis, 12 February 2012 - 08:25 AM.
Removed unnecessary quote.


#4 James Litten

James Litten

    Ԁǝǝ˥q


  • BC Advisor
  • 1,946 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:12:56 PM

Posted 12 February 2012 - 12:06 PM

Okay, good. Thank you for answering all those questions.

When my dog was a puppy he had a taste for literature, the bindings of hardcover books to be exact. :)

Next I want to define the problem as best as possible.

There are three issues that I'd like more details about.

Drag and Drop
It normally works like this.
Hover mouse over item
Click down on left mouse button and hold it down
Moving mouse moves item (Drag)
Lifting finger off of left mouse button releases item in new place (Drop)

What happens for you? Is it a problem with Drag or Drop?

I teach programming and a couple of years ago I wrote a tutorial on Drag and Drop for webpages. Here is the demo page that I wrote for that tutorial...

EDIT: Removed link

Can you drag and drop the dark grey square within the light grey box?
If not what happens?

Copy and Paste
What issues are you having with copying and pasting text?
Can you select text with the mouse?
Can you select text with the keyboard? (using shift and the arrow keys)
Can you right click and choose copy or paste on the context menu that pops up?
Can you copy and paste using keyboard shortcuts? (ctrl-c to copy, ctrl-v to paste)

Dcomconfig error
You mentioned...

I click start/run/dcomconfig and the screen comes up but when I click on my computer the whole screen disappears

Was that when you Right-Clicked on 'my computer' or Left-Clicked?


James

Edited by NeverSayDie, 13 February 2012 - 10:44 AM.


#5 abricru

abricru
  • Topic Starter

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Local time:01:56 PM

Posted 12 February 2012 - 04:25 PM

Before I go any further... are you saying that if one of those things that comes with the wireless mouse is lying around somewhere nearby it could be interfering with the mouse I have now? If so, I need to do a search because there are pieces and parts of mice scattered everywhere and I think I did see one of those things that plugs into the usb. Maybe more than one, lol. I'm going to clean up a little bit and see if I find any before I get back to you. Thanks again.

#6 James Litten

James Litten

    Ԁǝǝ˥q


  • BC Advisor
  • 1,946 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:12:56 PM

Posted 12 February 2012 - 04:51 PM

Yeah, that would do it. :)

I have seen it many times and the problems are always slightly different but often bizarre.

Let me know if you have any difficulty or it doesn't work.

James

#7 abricru

abricru
  • Topic Starter

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Local time:01:56 PM

Posted 13 February 2012 - 08:32 AM

Where is the excanvas.js file that you want me to put the dragdrop.html file in?

I can highlight the file and the menu comes up to cut or copy but then when I go to the destination and hit paste nothing happens. It does not happen when I am trying to cut and paste or copy text, that works fine. The only thing I can do with a file is delete. The shortcuts control c and control v do not work either.

Was that when you Right-Clicked on 'my computer' or Left-Clicked? Right clicked.

So far I haven't found any mouse transmitter (if that's what you call it.)

Thank you for your help!

#8 James Litten

James Litten

    Ԁǝǝ˥q


  • BC Advisor
  • 1,946 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:12:56 PM

Posted 13 February 2012 - 11:02 AM

Hi

I apologize for confusing you with that page.

Apparently, you did not see the draggable boxes and only saw the code. We will move on and not worry about that :)

More questions ...
What browser are you using and what version is it? You can click HELP and then ABOUT to find the version if you do not know.

These three questions are kind of important...
Reboot your computer.
When you right click on a folder or file you see the options for
CUT
COPY
1. But you do not see any option for paste, correct?
Now, choose COPY from the menu and then right click on your desktop.

2. Do you now see these two items in the menu?
PASTE
PASTE SHORTCUT

3. If you do, please choose PASTE SHORTCUT and let us know if that worked.

I hope you don't mind all of the questions but like I said before, I prefer to try the safe easy options first before digging into the system to make changes to its core :)

James

#9 abricru

abricru
  • Topic Starter

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Local time:01:56 PM

Posted 20 February 2012 - 07:44 PM

Hi

I apologize for confusing you with that page.

Apparently, you did not see the draggable boxes and only saw the code. We will move on and not worry about that :)

More questions ...
What browser are you using and what version is it? You can click HELP and then ABOUT to find the version if you do not know.

These three questions are kind of important...
Reboot your computer.
When you right click on a folder or file you see the options for
CUT
COPY
1. But you do not see any option for paste, correct?
Now, choose COPY from the menu and then right click on your desktop.

2. Do you now see these two items in the menu?
PASTE
PASTE SHORTCUT

3. If you do, please choose PASTE SHORTCUT and let us know if that worked.

I hope you don't mind all of the questions but like I said before, I prefer to try the safe easy options first before digging into the system to make changes to its core :)

James


Sorry it has taken me so long to reply. My mother had a stroke and I haven't had much free time.

I am using Firefox 10.0.2. I tried to install Google Chrome today, but when the installer was finished I don't see a shortcut or even a folder in my program files.

When I right click on a file I do see the copy and cut options. I copied and chose paste shortcut on the desktop but nothing happens.

Thanks again for your help.

#10 James Litten

James Litten

    Ԁǝǝ˥q


  • BC Advisor
  • 1,946 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:12:56 PM

Posted 20 February 2012 - 09:24 PM

Hi

I hope all is as well as it can be for you and yours.

Your answers narrow it down to three likely suspects.

1. Incorrect registry settings.

2. Problem with Internet Explorer (IE can affect your desktop and Windows Explorer)

3. DCOM permissions (your original dcomconfig question :) )

We can check 1 and 2 very easily...

1. I need to see some values of your registry.

Open notepad and copy/paste the text in the quotebox below into it:

@echo off
>ddreg.txt (
REG QUERY HKCR\Interface\{0000010e-0000-0000-C000-000000000046} /s
REG QUERY HKCR\CLSID\{00000320-0000-0000-C000-000000000046} /s
)
start ddreg.txt


Save this to your desktop as ddreg.bat
For "Save as type" choose "All Files" otherwise it will add a .txt to the end of it.

Double-click ddreg.bat and after it runs, it should open a file called ddreg.txt in notepad. Copy the contents of that file and paste it into your reply.


2. Can you run Internet Explorer?
Does it seem to work properly?
What version do you have?

Let me know if you have any problems or questions with this.
James


EDIT:
I did some more research on ALL of the weird issues you've had so far in this thread and there are some things here that make me feel that you may have a virus or a partial virus that was not completely cleaned off of your system.

Do you have an Antivirus program running and is it current?

Edited by NeverSayDie, 20 February 2012 - 09:52 PM.


#11 abricru

abricru
  • Topic Starter

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Local time:01:56 PM

Posted 20 February 2012 - 11:22 PM

Hi

I hope all is as well as it can be for you and yours.

Your answers narrow it down to three likely suspects.

1. Incorrect registry settings.

2. Problem with Internet Explorer (IE can affect your desktop and Windows Explorer)

3. DCOM permissions (your original dcomconfig question :) )

We can check 1 and 2 very easily...

1. I need to see some values of your registry.

Open notepad and copy/paste the text in the quotebox below into it:

@echo off
>ddreg.txt (
REG QUERY HKCR\Interface\{0000010e-0000-0000-C000-000000000046} /s
REG QUERY HKCR\CLSID\{00000320-0000-0000-C000-000000000046} /s
)
start ddreg.txt


Save this to your desktop as ddreg.bat
For "Save as type" choose "All Files" otherwise it will add a .txt to the end of it.

Double-click ddreg.bat and after it runs, it should open a file called ddreg.txt in notepad. Copy the contents of that file and paste it into your reply.


2. Can you run Internet Explorer?
Does it seem to work properly?
What version do you have?

Let me know if you have any problems or questions with this.
James


EDIT:
I did some more research on ALL of the weird issues you've had so far in this thread and there are some things here that make me feel that you may have a virus or a partial virus that was not completely cleaned off of your system.

Do you have an Antivirus program running and is it current?


When I click the ddreg.bat file a black screen comes up really fast and all I can read is error: system .....
This is all that comes up in the ddreg.text file:

! REG.EXE VERSION 3.0

HKEY_CLASSES_ROOT\Interface\{0000010e-0000-0000-C000-000000000046}
<NO NAME> REG_SZ IDataObject

HKEY_CLASSES_ROOT\Interface\{0000010e-0000-0000-C000-000000000046}\NumMethods
<NO NAME> REG_SZ 12


I can't get Internet Explorer to open.

I have Charter Security Suite which is called F-Secure and it is up to date. Also have Malwarebytes that runs all the time.

#12 James Litten

James Litten

    Ԁǝǝ˥q


  • BC Advisor
  • 1,946 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:12:56 PM

Posted 21 February 2012 - 12:15 AM

You are missing some registry keys and values related to drag/drop. We can replace them but I'm afraid that there are probably more values missing that may be causing your other problems.

Lets try fixing the drag and drop and see if the other things work after that like running Internet Explorer or Chrome.

Open notepad and copy/paste the text in the quotebox below into it:

REGEDIT4

[HKEY_CLASSES_ROOT\Interface\{0000010e-0000-0000-C000-000000000046}\ProxyStubClsid32]
@="{00000320-0000-0000-C000-000000000046}"

[HKEY_CLASSES_ROOT\CLSID\{00000320-0000-0000-C000-000000000046}]
@="oleprx32_PSFactoryBuffer"

[HKEY_CLASSES_ROOT\CLSID\{00000320-0000-0000-C000-000000000046}\InprocServer32]
@="C:\\WINDOWS\\system32\\ole32.dll"
"ThreadingModel"="Both"


Save this to your desktop as ddchange.reg
For "Save as type" choose "All Files" otherwise it will add a .txt to the end of it.

double-click ddchange.reg and when it asks if you are sure that you want to add it to the registry click YES.

Reboot the computer and see if drag and drop works.

Let me know if you have any problems or questions with this.
James

#13 abricru

abricru
  • Topic Starter

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Local time:01:56 PM

Posted 21 February 2012 - 11:03 AM

It worked twice and then it locked up and no icons work or anything. Just get the hourglass. I am in safe mode now because it won't let me do anything in regular.

#14 James Litten

James Litten

    Ԁǝǝ˥q


  • BC Advisor
  • 1,946 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:12:56 PM

Posted 21 February 2012 - 11:43 AM

Alright, it is easy to undo.

Try this
Click START
RUN
type in

regsvr32 ole32.dll

click OK

It should say something about successfully registering ole32.dll. If it does, reboot to normal mode and see if it is working.


Before I tell you how to revert it back to how it was before, I want to see if there was a problem with the changes being made. Can you double-click the file we made named ddreg.bat and post the results in your reply. It should show the new keys we added and that way I can make sure nothing strange happened with the registry edit.

Also, what exactly do you mean by "It worked twice" ? Did the drag/drop work?

Don't panic :)
James

#15 James Litten

James Litten

    Ԁǝǝ˥q


  • BC Advisor
  • 1,946 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:12:56 PM

Posted 21 February 2012 - 10:24 PM

I noticed that your post count was higher than just the posts that you made in this thread so I looked at your other posts.

I found this one in the "Am I Infected" forum from February 7th.
http://www.bleepingcomputer.com/forums/topic441627.html/page__p__2587739#entry2587739

I'm sure that you probably thought that I knew about this but unfortunately I did not. I would have responded quite differently if I had :)

Your system is behaving like it has a virus or parts of a virus in it. Perhaps a virus cleaner attempted to remove it and did not do a complete job which may have resulted in broken files and settings.

We did not change anything in your registry, we simply added three values and one key that were missing.

I checked 8 XP SP3 machines (2 laptops and 6 desktops) and they all had the values that you were missing and which we added. There was one value that was slightly different on some of the machines but if I changed it to the value you used and rebooted, it had no ill effects particularly for drag and drop capabilities. This is because it was the value of what is called the "human readable name" and is only used for display purposes and not for any programming.

We can remove the values that we added but I really believe that they are necessary.

Your system was completely missing the following 3 keys (and the values for them).

HKEY_CLASSES_ROOT\Interface\{0000010e-0000-0000-C000-000000000046}\ProxyStubClsid32
HKEY_CLASSES_ROOT\CLSID\{00000320-0000-0000-C000-000000000046}
HKEY_CLASSES_ROOT\CLSID\{00000320-0000-0000-C000-000000000046}\InprocServer32

Technically, something deleted the ProxyStub that mapped an IID to a CLSID and then deleted the entire key for that CLSID. Most importantly the in-process server value for that CLSID which points to ole32.dll was deleted. If an antivirus program thinks that ole32.dll is infected with a virus, it could conceivably delete these keys but it would be a dangerous way of cleaning unless it was planning on replacing it with a clean copy and rebuilding the registry keys but was interrupted before accomplishing this.

Something deleted them. It might have been a virus, an antivirus cleaner or a registry cleaner. That means more keys than the ones we checked have probably been deleted. Especially if it was a result of cleaning CLSID's with ole32.dll as the in-process server (there are about a dozen of those).

You should follow Cryptodan's advice in the aforementioned thread and get help from the Malware Team to make sure that your system is clean.

After that if you still have problems, I will help you.
James




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users