Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

How to Give Myself Permissions to Delete Microsoft Games Folder


  • Please log in to reply
6 replies to this topic

#1 Booh-kitty

Booh-kitty

  • Members
  • 237 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:La-La Land
  • Local time:11:33 PM

Posted 05 February 2012 - 04:47 PM

Windows 7 Ultimate 64bit

My user account has administrator privileges. When I tried to delete the folder, I am informed that I need permission from SYSTEM.

I tried to give myself permissions in properties, but have had no success.

I opened the properties dialogue by right-clicking on the games folder in programs files
I click on the 'Sharing' tab
'Advanced Sharing'
'Permissions'

I gave myself all permissions: full control, change and read. I saved the changes and then tried to delete the Games Folder. I still don't have permissions from the system to delete it.


So then, I clicked on the 'Security' tab in the 'Properties' dialogue. Administrators on this computer have full permissions. But since I can't delete the folder, and even though my account is administrative, I gave myself full permissions.

This time, I get the message "An error occurred while applying security information to:
C:\Program Files\Microsoft Games
Access is denied.

I have to get rid of his folder! I'm addicted to these games and thereby wasting A LOT of time! It's driving my crazy :crazy:

Please help

Edited by Booh-kitty, 05 February 2012 - 04:53 PM.

Whether you think you can or can't, either way you are right.
-Henry Ford

BC AdBot (Login to Remove)

 


#2 LucheLibre

LucheLibre

  • Members
  • 608 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Tennessee
  • Local time:12:33 AM

Posted 05 February 2012 - 05:25 PM

Click the start orb and type features. Select Turn Windows Features on or off.

Uncheck the Games entry and click OK.

Also undo all of the permissions work you've done so far.

Edited by LucheLibre, 05 February 2012 - 05:26 PM.

If it looks like I know what I'm doing, there's a pretty good chance the only reason for that is because
I once asked someone to run chkdsk /r and a BC Advisor smacked me in the back of the head.

~ LL ~


#3 James Litten

James Litten

    Ԁǝǝ˥q


  • BC Advisor
  • 1,945 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:11:33 PM

Posted 05 February 2012 - 05:28 PM

Would turning off (kind of like uninstalling) the games so they no longer show up be good enough?

If so, those games are installed as Windows Features.

To turn them off ...

Click the Windows Orb in the lower left corner of your scream (used to be the START button in XP)

in the search text box enter

Programs and Features

and you will see a link to click for Programs and Features

In the left column of the Programs and Features window click
Turn Windows Features On or Off

Click the plus sign next to games
Uncheck the games that are fueling your addiction :)

If you remove the Microsoft Games folder, I believe that it will automatically be recreated every time that you reboot unless you change some registry keys.

If you need to go that far, let us know.

James

#4 Booh-kitty

Booh-kitty
  • Topic Starter

  • Members
  • 237 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:La-La Land
  • Local time:11:33 PM

Posted 05 February 2012 - 05:38 PM

If you need to go that far, let us know.

James


James, I just might have to go that far! I'm afraid I am a recovering obsessive/compulsive personality type :o

It's great for solving problems and getting things done, but sometimes it's harder to manage when it's something that doesn't actually require brain cells. The problem is that I can turn it back on!
Whether you think you can or can't, either way you are right.
-Henry Ford

#5 James Litten

James Litten

    Ԁǝǝ˥q


  • BC Advisor
  • 1,945 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:11:33 PM

Posted 05 February 2012 - 06:18 PM

LOL! Well if that's the case then you can easily undo what I would tell you to do :)

If it was because something about it interfered with your system then it would be a solution. For your situation, I'm afraid the only solution is to find a friend, allow them to have the administrator account on your PC with a secret password that only they know and have them either

A. Set a policy to block the games on your PC either through the Group Policy Editor or with registry entries (depending on the version of Windows that you have).

or

B. Use the built in parental controls to make a list of programs that you are allowed to run.

This is what I do for businesses that don't want employees playing Solitaire :)

James

#6 Booh-kitty

Booh-kitty
  • Topic Starter

  • Members
  • 237 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:La-La Land
  • Local time:11:33 PM

Posted 05 February 2012 - 06:26 PM

Something tells me I'm going to have to exercise some self-restraint. :o M

Oh well. At least I learned how to do something new :) Maybe I'll forget how to turn it back on.

Thanks!

BTW
Do you know what 'ORB' stands for?

Edited by Booh-kitty, 05 February 2012 - 06:33 PM.

Whether you think you can or can't, either way you are right.
-Henry Ford

#7 wjames811

wjames811

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:11:33 PM

Posted 06 February 2012 - 12:15 AM

Its not working for my computer, why?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users